1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support Galaxy Ace wifi problem


  1. saurabhp

    saurabhp Member

    whenever i use my phone wi-fi for few days without restarting phone not even once, it starts giving prolems. after few days of continuous use(i.e. turning wi-fi on when needed and then turning it off) it doesnt't turn ON. it shows "error" written in wi-fi menu...den i've to restart phone to use wi-fi again...and at that tym bluetooth also doesn't turn ON. does anyone know how to rectify this prblm???

    Advertisement
  2. ayush29k

    ayush29k Well-Known Member

    Its a very common issue, you will have to reload the wifi driver whenever you face this problem.
    From your dial-pad enter: *#*#526#*#* wait for the following status message to appear.

    WLANTest Engineering Mode
    Status...
    Driver loading successful

    Now tap the Back button to exit and try the wifi now it should work.
    Report back if this doesn't help you.
    Cobra21 and joannegoldie like this.
  3. Mohy786

    Mohy786 Well-Known Member

    I have the same problem now and whenever i type that code in it says Driver loading UNsuccessful, and then the phone just restarts after a while........
  4. Mackinon

    Mackinon Well-Known Member

    Even i Get the Driver loading UNsuccessful ever third time i dial the *#*#526#*#* and then i have to restart the phone to fix it temporarily..
  5. ayush29k

    ayush29k Well-Known Member

    What android versions are you guys running??

    Ok try to setup a static ip connection,
    In Advanced settings of the wifi settings, scroll down to IP settings and input the following:

    IP address > 192.168.2.130
    Gateway > 192.168.1.1
    Netmask > 255.255.255.0
    DNS 1 > 8.8.4.4
    DNS 2 > 4.4.4.4
    Tap on the Menu button and choose Save.

    If you are only experiencing Wi-Fi connectivity problems with your home wireless router, yet you are able to access Wi-Fi through a wireless router at work - disable the option prior to using the work router.

    I just found this workaround on net, for me 526 works perfectly.
  6. Mackinon

    Mackinon Well-Known Member

    Hi Ayush,
    This solution helped me when i was trying to connect my sisters SGA to my home wifi but in my case, i use wifi both in my office as well as home and usually i get the connection error when i am switch between home and office or vice versa. the code *#*#526#* doesn't always work and usually gives Driver Laod UNsuccesful error the next time i try to connect after using the code to reload the driver.

    By the way i am using 2.3.6 (DDKQ8)
  7. ayush29k

    ayush29k Well-Known Member

    It might be a problem with the baseband DDKQ8 you are using.
    You can try a factory reset (better by clockwork mod recovery ,if u have installed it and is rooted)or if it still exists JUST FLASH the stock rom via ODIN...here is a thread if u don't know flashing:
    http://forum.xda-developers.com/show....php?t=1034145

    I used to have the same problem while i was on DDKQ6 2.3.4, but since i switched to CM, its completely gone.

    HOW THE WIFI DRIVER GETS DAMAGED!!!!
    After switching on wifi or hotspot wait some minutes so that the wifi or hotspot are fully active...after that only shut them off...
  8. Mackinon

    Mackinon Well-Known Member

    i have flashed DDKQ8 via odin a couple of times and the problem seams to be existing in the firmware itself..
  9. Ryuinferno

    Ryuinferno Well-Known Member

    This is actually a common bug in SGA phones regardless of the baseband but still not fixed. Until then, the safest and most effective way is to reboot your phone.
  10. PJ147

    PJ147 Well-Known Member

    I only had this on certain roms.
  11. ayush29k

    ayush29k Well-Known Member

    Its there in many roms but still there are some without it, in some the 526 trick solves the issue(temporarily), in some you have to set a static IP and yet there are some just stuck with no solution at all.
    Samsung really has no consistency in its rom production :p
  12. anksin

    anksin Member

    I have tried the above steps but after entering manual IP and DNS settings, it doesnt get connected to wi fi and I have local cable internet
  13. c2tarun

    c2tarun Member

    This worked for me :) thanks
  14. deppparadis15

    deppparadis15 New Member

    Hi i'm having the problem these days about Wi Fi and just like you said:
    "If you are only experiencing Wi-Fi connectivity problems with your home wireless router, yet you are able to access Wi-Fi through a wireless router at work - disable the option prior to using the work router."
    i can't only use my Wi Fi at Home....
    Pleaseee pleaseeee help me....
    in didn't undrestand what did you mean by "disable the option prior to using the work router."
    Please help me...
  15. aditii

    aditii New Member

    i hav the same prob..i tried everything..frm rebooting my fone to dialing the code..but it isnt wrking..it is stuck on obtaining IP address...plz help
  16. khizer94

    khizer94 Member



    Hey, first switch off ur phone and wait 30 seconds then remove the battry and wait 4 minutes, now put battry and switch on then chek it will work this is the solution of ur problem no need to try codes or factory reset Goof Luck!
  17. khizer94

    khizer94 Member



    Hey, first switch off ur phone and wait 30 seconds then remove the battry and wait 4 minutes, now put battry and switch on then chek it will work this is the solution of ur problem no need to try codes or factory reset Goof Luck!
  18. khizer94

    khizer94 Member




    Hey, first switch off ur phone and wait 30 seconds then remove the battry and wait 4 minutes, now put battry and switch on then chek it will work this is the solution of ur problem no need to try codes or factory reset Goof Luck!
  19. khizer94

    khizer94 Member

    Hey, first switch off ur phone and wait 30 seconds then remove the battry and wait 4 minutes, now put battry and switch on then chek it will work this is the solution of ur problem no need to try codes or factory reset Goof Luck!
  20. khizer94

    khizer94 Member

    Hey, first switch off ur phone and wait 30 seconds then remove the battry and wait 4 minutes, now put battry and switch on then chek it will work this is the solution of ur problem no need to try codes or factory reset Goof Luck!
  21. witchume

    witchume Member

    Try switching off your 3g settings then turn on wifi.basically i've tried inputting codes to wlan test it just turn to error.........3g and wifi should not used at a same time......For korean ace do not flash any rom to your phone...it would only give a wifi and bluethooth probs...
  22. witchume

    witchume Member

    I have experience problem with korean ace before...i had it flash it s5830 stock and roms.....It brick,no matter how many times i've flash it with its korean stock it only freeze to samsung logo.......Then the solution came ........Jtag and after done i flash it with its stock shw-m240s and its done....recovered
  23. witchume

    witchume Member

    S5830 and shw-m240s are both sga but differ mainly in build.prop.....Korean ace is a clone of galaxy ace s5830.
  24. witchume

    witchume Member

    To make a korean ace a not so boring phone i manage to flash iconpacks for a new look on the icons,Fonts,and wallpapers........as of now there are no supports for modifying korean ace.......learn to love the things that you have as of now.
  25. witchume

    witchume Member

    And lastly do not flash any recovery rather than cwm 4.0.0.9 for both s5830 and korean ace.regarding for s5830 roms its better to check or read the contents of the rom before flashing it.most roms are being re modified for bloatware and to gain a
    better user free memory.....it always look different from the stock.some apps are removed..

Share This Page