Galaxy Ace won't enter recovery mode!


  1. jocarl011

    jocarl011 New Member

    Hi Guys, I have just bought an Ace and I can't get the phone to enter recovery mode to root the device!

    I have tried the hold home + power button till i see a samsung logo and also holding vol down + home + power button but still cant!

    My phones first and only logo I get is the samsung ace logo but most guides seem to say this is supposed to be the second of 2 logos and the first is a simple Samsung logo??

    My phone is running gingerbread XXLB1 and came with that from the shop.

    Thanks.

    Advertisement
    :
    off the hookys likes this.
  2. Rush

    Rush {<>}~{<>} Guide

    I've moved your thread to where you will most likely get faster responses.

    Hello and welcome to AF. :)
  3. jocarl011

    jocarl011 New Member

    Ok thanks.


    Anyone know what I can try or why it's not entering recovery?
  4. ayush29k

    ayush29k Well-Known Member

    just keep on holding the home button till you see the recovery menu :D
    vol+home combo is for download mode only....
  5. chrcol

    chrcol Well-Known Member

    1 - turn phone off.
    2 - hold down home button.
    3 - whilst still holding down home button hold the power button down to turn phone on.
    4 - when you see samsunbg logo let go off pwoer button but keep holding home button.
    5 - when you see recovery menu can let go of home button.

    hope this helps.
    jull00sp likes this.
  6. Lyta

    Lyta Active Member

    I keep em held down till the recovery menu comes up :)

    Would safe mode help you think ??

    Cheers.
    jull00sp likes this.
  7. jlcarpenter

    jlcarpenter New Member

    Does anyone have an update for this? I have the same problem. The Galaxy Ace screen appears first. I hold the home and the power button and have released the power button when the Ace screen appears, when the Samsung logo appears, and when it disappears. It continually goes to the login screen.

    Thanks,
    James
  8. CherryPoppins

    CherryPoppins Member

    I have the same problem, although instead of the samsung logo appearing I have an error message of a mobile phone, then a yellow triangle then a computer icon help?!
  9. Manoj Lovell

    Manoj Lovell Member

    May be u need to download the Clockwork Recovery and then try the home and power button option. it should work it worked for mine.

    my phone model is Galaxy Ace S5380. if yours the same give it a try :)
  10. kmuema

    kmuema New Member

    This is how you do it: Press home key then simultaneously press power and volume up keys. When the Samsung galaxy logo appears, release the power and volume up keys. Safe mode should come on shortly.

    Works for s-5830i

    If it works, please press thank!

    Bon voyage.
    kbhkiss, amauryt, aceyy and 5 others like this.
  11. ravi4719

    ravi4719 New Member

    How can i repaired my samsung galaxy ace as it is crashed during updation and even it is not start by pressing power key with menu key and also doesn't start in recovery mode. Pls help me fast.
  12. ayush29k

    ayush29k Well-Known Member

    Power key + menu is the recovery mode itself.
    If you are using a non rooted device, and you were updating through Kies or OTA you can go to the service center to get your software reinstalled.
    Your phone might have been bricked, crashing in mid process usually does that.
    I hope you are still under warranty.
  13. Nedialkata

    Nedialkata New Member

    thanks man it worked you a da best ,no really you are da best man ever :) :) :) :D:D:D ;) ;) ;)
  14. HakunkaMatata

    HakunkaMatata New Member

    kmuema, thank you very much. Your method does of course work on my Galaxy Ace GT-S5830M. I've read a whole bunch on posts that state to hold down Home + Power, and release power when logo comes up, WHICH IS WRONG.

    thanks again,
  15. oldchick70

    oldchick70 Active Member

  16. ayush29k

    ayush29k Well-Known Member

    You were accessing download mode, you need to get into recovery mode not download mode. Is your phone model similar to S5830 or S5830i?
    They both have different hardware and different key combinations for recovery menu.
  17. oldchick70

    oldchick70 Active Member

    I have already got the zip file on the SD card

    - After transferring your file on your phone disable the USB by pressing "Disconnect storage from PC" after that remove the USB cable and turn off your phone "Power off".

    [Entering recovery mode on GT-S5830]

    - Make shure you start the phone like this : Long press and hold the (Power Button) + (Home Button)

    My phone looks just like the one in the tutorial, but it's a Telstra (Australia) locked model, hence the T not i
  18. ayush29k

    ayush29k Well-Known Member

    I asked about S5830 and S5830i because they are both galaxy ace phones but they are extremely different in terms of hardware, so all the rooting and other guides are different for the 'i' model than the original S5830 model. These models have further variants and you should know that what model is your phone like. Because if you use stuff for the other model you will damage your phone big time.

    So I checked on the net, the 't' model is as same as S5830 so you can use this tutorial and other S5830 products and guides, but having a network locked system might give problems. Now i never used a carrier locked phone so i don't have any experience if the rooting affects the locked carrier systems or any of that matter. You should try the tutorial again, keep the power and home button pressed until you see the yellow recovery menu and attempt to flash the zip file again.
    Also go through other guides for rooting given on the internet, there are many people with telstra australia S5830t phones they should be able to help you out better.
    Good luck!
    oldchick70 likes this.
  19. oldchick70

    oldchick70 Active Member

    ayush29k
    Thanks very much for your help and time.
    I appreciate that :)
    I will look again, but as I just want to get rid of the 'bloatware' it may not be practical to root, in the long run and I can't afford to lose my Ace!
  20. ayush29k

    ayush29k Well-Known Member

    Its quite practical actually and useful, if you are able to root then by all means you should do it, this phone has a lot of hardware limitations, mostly the internal memory limit and this can be solved by rooting.
    The main reason people go for android and smartphones is because of applications, but with a memory this small this phone is almost useless.
    Now it will take a little bit of your time and effort searching around for a working method but its worth it. Look in the xda forums, you will definitely get a solution.
  21. wama14

    wama14 New Member

    This really works

    thanks man
  22. wama14

    wama14 New Member


    everybody this actually works trust me!!!!!! :d:d:d:d:d:d:d:d:d:d:d:d:d:d:d:d:d:d:d:d
    nfetwi likes this.
  23. brendamolloy78

    brendamolloy78 New Member

    I have done this a million times and it still wont work for me :-(
  24. aceyy

    aceyy New Member

    this is how you do it: Press home key then simultaneously press power and volume up keys. When the samsung galaxy logo appears, release the power and volume up keys. Safe mode should come on shortly.

    Works for s-5830i

    if it works, please press thank!


    I've done this, but when I'm in the menu and stay on reboot system, I can't select it. What do I have to do now???
    please help me!!!!!!!1
  25. aceyy

    aceyy New Member

    by me the same, when I select reboot system, it says the phone can't mount rebooting. what do I have to do?
Loading...

Share This Page