Galaxy GT-I7500L update issuesSupport

Last Updated:

  1. noroads

    noroads Member

    Hello, I am having problems with my Galaxy after trying to update to 1.6

    To start I will explain my phone a bit. This is a 7500L that started its life as a Bell phone, but I have paid the $75 to unlock it and am, well was (lol), using it on Virgin Mobile Canada.

    I have tried many different firmwares, each with different results. Some problems i have had with them include a boot loop or never-ending startup music (very annoying). But every version I have tried all leave me with the same major problem. No service. I can search for networks, which I can find Rogers Wireless (tho I cannot connect to it).

    I have tried the following solutions:
    1. Add the Bell APNs
    2. Use a different version firmware & roll back to original.
    3. Putting my SIM in another phone (works fine)
    4. Using one package in Odin / deleting the cache/amss files / using the individual BOOT,PHONE,PDA,CSC files / just using BOOT, PDA, CSC / I have even tried just flashing the PDA file (currently using it like this)

    I have ensured that I have been doing a factory reset right before and right after the flash... I just don't know what else to do. Been reading the forums for almost a week now trying to fix this!

    I appreciate any help I can get with this, and will be checking back every twenty mins or so If more info is needed.

    Best, Trevor.

  2. Snazzy

    Snazzy Well-Known Member

    Bell Apn will not work on the virgin network. You must use the virgin apn.
  3. noroads

    noroads Member

    I just looked at my girlfriends Blackberry to get the Virgin Mobile APN and hers is showing

    I'm going to go to google and try to find an APN for Virgin Mobile, I appreciate the input. What are the chances of it being :rolleyes:

    Edit: I was just reading over at Howard Forums to use the same APN as Bell customers.
  4. Snazzy

    Snazzy Well-Known Member

    Yes I just read the same article. Bell acquired Virgin couple of years ago.

    Hmm, not sure why it is not working for you. My Bell APN is as you state
  5. Lelouch

    Lelouch Well-Known Member

    Try putting your girlfriends APN settings to see if it works (can't hurt to try :p ).

    Or you can try Galaxo or go for GAOSP (now Bell friendly) to see if that ROMS maybe have the APN you need. Better to say, ditch Sam*censored stock ROM and go for Galaxo first and GAOSP later. ;)
  6. noroads

    noroads Member

    Been working on this in my free time but still no luck. I have put the APN settings in just as they appear on the gf's blackberry but it still won't work. I am also running GAOSP which is very neat but still doesn't get service.

    When I flashed the BOOT/PHONE/PDA/CSC files originally I found out after to not flash the phone file. By only flashing BOOT/PDA/CSC afterwords will that erase the PHONE or just reflash the other 3 files, leaving the PHONE file from previous flashes? This is the very last solution I can think of, will try for a few more days still though.
  7. Snazzy

    Snazzy Well-Known Member

    Ahh yes if you flashed the radio portion (AMSS?) then yes you will have problems as the Bell i7500L has a unique radio. Unfortunately Bell never released an update for this phone so we have no files from them. All is not lost as the Brazilian i7500L has the same radio as us and those files are floating around which you can find by searching through the threads here.

    Your solution I think is to find and flash ALL the Brazilian files via Odin, boot and confirm your phone works on Bell 3G. If that works then start again but DO NOT include the AMSS this time. There is a couple of great threads here specifically how to flash a Bell i7500L without the radio.

    Good luck!
  8. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    In fact the original Bell firmware was released, so there's no need to use a Brazilian firmware (although it's a good solution).

    There's a tutorial right here on how to use Odin with a Bell i7500L. ;)

Share This Page