1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Galaxy Nexus battery issueGeneral


  1. raakeshbisht

    raakeshbisht New Member

    The problem with my Galaxy Nexus is battery back is not good at all...just got it before 3 days and since then I am experiencing this problem;more than 50% Battery is consumed by display as showed in settings>battery.

    Battery backup is very poor I tried all the recommended things and downloaded Battery saver app also.Still Battery is not lasting more than 10-12hrs.
    Anybody have a permanent solution?

    Advertisement
  2. AJ McKay

    AJ McKay Well-Known Member


    Ditch the battery saver app. 10-12 hours on the stock battery is pretty good. Display at 50% is perfectly normal.
  3. Tim K

    Tim K Well-Known Member Contributor

    I'd have to agree with AJ. If you could offer some more details it would help to confirm it.

    1. What is your screen brightness set at?
    2. Under the battery usage graph under display, what is your screen on time.
    3. What is your signal lime? If you could post the battery usage details screen you get from clicking on the graph that'd be great.
    Finally, what is your split between time on WiFi, 3g and 4g?
  4. AntimonyER

    AntimonyER AF Addict VIP Member

    I consistently get screen battery usage over 50% in my phone, its just a function of having a phone with a large, high density display, combined with lots of screen up time. And 10-12 hours is about par for the course, if your screen usage is 50% of it. Sorry, its just not a device with a massive battery.
  5. Digital Controller

    Digital Controller The Real Bass Creator Guide

    If you are having issues regarding your battery look into getting an extended battery, i have one now, was 20$ on Amazon and has made my battery life last up to 40 hours on a single charge.
  6. Perec

    Perec Member

    Go to Apps settings and disable all apps you never use, especially the apps and services that's try to connect to internet and exchange some data. Turn off the auto-sync of your Google account, Location access service and bluetooth. Turn off wifi and data connection when screen is off (in Google Play there are bunch of apps doing this automatically: Juice Defenfder, Long Battery Life, etc..)

Share This Page