Galaxy S boots to a black screenSupport


Last Updated:

  1. me1

    me1 New Member

    Hello and thanks for looking,

    I have a Galaxy S (GT-I9000M) which doesn't boot past the start-up splash screen and sound effect. Eventually it will just switch to a black/blank screen and do nothing more. The back and menu buttons still light up if tapped.

    The history how I got it this way, was I was using the app web-sharing lite to transfer some files through wifi without the need of a usb cable. I was transferring a large movie file when the phone locked up. I reset the phone, and upon boot every app and service was crashing. Tried this a few times, then pulled the battery etc, still the same. Then I booted into recovery mode(vol up+home+pwr), and applied wipe data/factory reset, then rebooted. This is when it started to only boot into the black screen.

    This is a Canadian phone, service/bought through bell, the phone had the one click root applied to it so TI Backup could run on the device. So I think I'm out of luck with any warranty service.

    I can get into the phones recovery mode and download mode, so I think there is still hope for this phone to be recovered. What I don't know is what firmware version Bell ships with these devices, and where I can download it?

    If anyone with a Bell Galaxy S has had any experience recovering their phone and would like to share your secrets would be most appreciated.

    Cheers.

    Advertisement
  2. vikingisson

    vikingisson Well-Known Member

    You're lucky to be able to get to recovery. Most of us can't so when this happens we're hosed. There are a few threads on this and it seems that the internal SD gets corrupted. So if you can flash then that's your option now. Mine did this yesterday and I'm still in the 1st 14 days but I'll be nervous with the replacement.

    Question, have you applied a lag fix? Rooting and unlocking shouldn't have any effect but I'm wondering if lag fix might make it more sensitive to these sudden bricks.

    I'm especially nervous because Bell and the retailers are not friendly to those that buy outright. The carrier connection is not our problem, the phones are defective.
  3. jaihind

    jaihind Member

    This has happened to me also. Oddly after I applied lag fix, I noticed some time after that the phone kept crashing repeatedly and returns to the home screen.Then every app I opened crashed with some launcher error message. I restarted and it won't get pass the galaxy splash screen. Luckily I was able to return it to the Bell for a new placement.

    Could the lag fix have done this? I don't know exactly. I applied the lag fix as soon as I got the phone. Dare I apply again?

    The firmware is Eclair.UGJH2 on my Bell phone.

    Has there been lots of issues like this after applying the lag fix?


    Would samsung fix the lag in 2.2?
  4. me1

    me1 New Member

    Thanks for the quick replys,

    Yes I did have the lag fix applied now that you mention it. I had run it for about a week with no issues until it all crashed.

    I had downloaded UGJH2, with PIT 512. I have attempted to flash this several time but I still get result. I was hoping I was using the wrong version.

    I've tried flashing it in Odin with and without the Re-partition option checked and it appears to be the exact same sequence. I wonder if it isn't partitioning properly?

    Thanks again for the responses.
  5. vikingisson

    vikingisson Well-Known Member

    I ask about lag fix because it changes partitioning and that might suffer from a weakness in the Samsung design (and might be why we have lag in the first place, the fix might be dangerous and maybe they know it). I'm only guessing here.

    To the lucky guy that has a chance to reflash, a repartition might be required since you couldn't undo your lag fix beforehand. I haven't touched Odin and the others so I can't say for sure. So if you can blow away the internal card and flash fresh you might have hope.

    Future Shop/Bell won't have a replacement until Tuesday so I'm still nervous that they will honour it as promised. They tried to deny me but I bought it fair and square even though they have a policy not to sell as they did. However with the replacement I won't be doing the lag fix and hope that the 2.2 update will make it work right. I might decide to only unlock it and sell it as new in the box. Too much money to risk. I'm quickly falling out of love with this toy.
  6. me1

    me1 New Member

    So I managed to get everything back up and running, thanks for help.

    I think I've learned my lesson, I'm going to stay away from the lag fix this time. Seems a bit buggy still.

    Cheers.
  7. vikingisson

    vikingisson Well-Known Member

    Good for you. mine has to be exchanged. But the bugs have to be fixed or it goes back for good.
  8. elena11

    elena11 New Member

    I have absolutly the same problem. My phone was only unlocked with a code. The screen was flicking like changeing from app to an app and I just restarted it. After this only goes to the black screan and that's it. No lag fix, no rooting, nothing at all. I left it with Bell to have it sent to Samsung, becasue I am after the 30 day mark. I really hope this is not a design problem, becasue I like the phone better than the IPhone 4.

    Alos My wife has the same phone unlocked with e code, and one day it loccked itself and asked for the code again. Any idea why? Thx.
  9. Cambot

    Cambot New Member

    I have exactly this problem, and I haven't rooted it or installed lag fix. The phone is toast and only after 1 week. I recently upgraded with Bell. I've tried a factory reset but it doesn't even go past the splash screen. The screen just goes dark no matter what I do. I've removed the battery, removed the SIM card...pretty much anything. Same result. This will be going back to Bell tomorrow for a replacement with the provision if it happens again I get another new one...not sent out to be fixed.

    There's something seriously wrong with this phone.
  10. Cambot

    Cambot New Member

    So after returning to the seller, they've noted they've seen this behaviour before with a couple of Galaxy S's. They exchanged it on the spot, but noted there was a firmware available and he strongly urged to apply the firmware. I downloaded/installed Kies from Samsung Apps however it said the firmware was already up-to-date and wasn't necessary. So maybe they've already flashed newer ones at the factory.
  11. vikingisson

    vikingisson Well-Known Member

    You can know if it is the newest by trying the 3 button download mode. If it now works then you are good. If not then you should take it back until you get one that works. The problem is that the 'fix' is labeled as the same version as the one from a few weeks earlier. There are ways to trick it to update but being brand new you shouldn't have to risk that.
  12. Cambot

    Cambot New Member

    Thanks...could you explain the "3 button download mode"? Not sure what you mean by that...
  13. Cyb3r5c4r

    Cyb3r5c4r Well-Known Member

    [​IMG]
    HOWTO GET INTO DOWNLOAD-MODE:
    - Turn off your Phone
    - Hold VOLUME DOWN + HOME Buttons
    - While holding VOLUME DOWN + HOME Buttons press POWER Button until you reach Download-Mode
    - Release all Buttons
  14. WooMasta

    WooMasta New Member

    So basically teh only way to fix this is either sending it in for repair or having it exchanged right?
  15. theLane

    theLane Member

    I am having this issue right now with a phone I bought used. Is there a fix that someone here knows about since posting in this thread stopped?
  16. JaePhillips

    JaePhillips New Member

    I have exactally the same problem as you it lets me boot in to both download and recovery mode but if i factory reset it it does the same thing how did you fix it.
    My parent are going to kill me! Also if you take it into samsung to get fixed will they except it if you have rooted (jailbroken) it? Please help I really don't no what to do
  17. usufr1

    usufr1 New Member

    hey man i've got a problem with my samsung galaxy i9000
    the thing is i downloaded an app call spb shell 3d from the internet. and installed it.
    It worked fine for few minutes then suddenly everything got stuck. Then i took out the battery and put it back on and power on the phone. Everything started normal exept that the "touch the screen to unlocks"screen comes and after i unlock the screen just remains black nothing works but the "back button" and the "settings" button works and on pressing them the phone vibrates.
    i dont know what happened man . And i am freaking out because i just bought it a week ago.
    P.S:I've tried the "volumeup+homebutton+powerbutton" combo. It does not work either.
    so if anyone knows how to fix this problem please let me know.
    And thank you reading this post

Share This Page