1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Galaxy S (I9000) Backup


  1. hippo_potamus

    hippo_potamus Active Member

    HELP

    http://androidforums.com/samsung-galaxy-s/156616-galaxy-s-i9000-backup.html

    Hi,

    I have rooted my phone (installed Terminal and confirmed I could su to # prompt) and tried to use Titanium Backup or MyBackup Pro.

    Everytime I tried to backup at root level, there is this prompt asking me to Accept Root while it does it backup. It prompts like 30 or 50 times through each backup session. I've made sure I checked the "Remember" option already but it seems to not remember it.

    I rooted my phone using the One-Lag fix at "http://forum.xda-developers.com/showpost.php?p=7587405&postcount=417" because I needed to run the LagFix512.sh script to make my phone work decently.

    Is there a way to stop this prompt or
    Is there a way I can assign the backup programs to run as root by chmod at terminal screen or something?

    Any help appreciated, thanks.

    Advertisement
    :
  2. hippo_potamus

    hippo_potamus Active Member

    Ah, I found the solution ...
    ---
    $ su
    # (remount for your phone, Nexus One is 'mount -o remount,rw /dev/block/mtdblock3 /system', other phones will use the same pattern, but may vary on the '/dev...' bit)
    # rm /system/app/Superuser.apk
    # pm uninstall com.noshufou.android.su

    # (same remount command as above, but with 'remount,ro' instead of 'remount,rw')
  3. snapper.fishes

    snapper.fishes Well-Known Member

    So, what you did was basically remount super user app? Can you please post the exact commands you used? Thanks.
  4. hippo_potamus

    hippo_potamus Active Member

    1) Install terminal application and go to root ... su
    2) rm /system/app/Superuser.apk
    3) pm uninstall com.noshufou.android.su
    Exit.
    Go to market and download Superuser 2.3.4 and install.

    That's all I did and it is working perfectly.
    snapper.fishes likes this.
  5. snapper.fishes

    snapper.fishes Well-Known Member

    Thanks.
Loading...

Share This Page