1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

galaxy s i9000 usb problemSupport


Last Updated:

  1. falkirkbairn1951

    falkirkbairn1951 New Member

    hi ,
    i am having problems with my galaxy s i9000 when i attach my data cable to my phone and try and use kies my usb wont connect all it does is flash from screen to screen i gave tried a new data cable and also installed a new version of kies 1.5.1 but still cant connect.

    any help would be great thanks in advance:mad:

    Advertisement
  2. nacnudsco

    nacnudsco Member

    Mine is the same. It charges via USB, but will not ping as a new "USB" device..what have I accidentally changed? What software could cause this? I'm going to do a factory reset..and start again..I have remembered to save my contacts to an external SD card. :) We'll see what happens next :) Good luck
  3. falkirkbairn1951

    falkirkbairn1951 New Member

    sorry but doing a reset did not work for me but heres hoping it works for you please let us know how you get on
  4. nacnudsco

    nacnudsco Member

    Did the factory reset...still no go....
  5. killerchic

    killerchic New Member

    Hi Im having same problem, I have uninstalled and reinstalled software but still no good,

    Hi Im new to this android stuff and was enjoying all the new things.

    :confused: I have been using my samsung galaxy s for a few weeks now and was having no problem with kies and connecting my phone. Now I plug my phone in and kies starts up but no connection is being made and my phone just constantly flashes between the main screen and the usb picture. Dont know why it has started doing this nothing has changed on either phone or computer. Any Ideas. Thank you
  6. nacnudsco

    nacnudsco Member

    I was being a total twit. I forgot that I had swapped my USB cable for my charging USB cable that came with my car charger. All USB cables are not created equal. There are 4 wires (Universal Serial Bus - Wikipedia, the free encyclopedia ) in a USB cable, you only need two to make the device charge, the other two are to carry data.

    Obviously the manufacture saved costs, of course ( http://www.realityinfo.org ), in making their charging cable by making it only a two core wire, instead of four core. So the charging still worked, leading me to believe that there was a configuration issue.

    So I am now using the 4 core cable and all is working perfectly.
    I feel like a dumb ass :)

    Good luck, the rest of you, with your solutions, if you find any..
    Peace.
    tedpan and hhuergo like this.
  7. snapper.fishes

    snapper.fishes Well-Known Member

    If your screen is flashing between the home screen and the mtp app, there's a file in your memory (most likely internal memory) that your phone doesn't like. You need to format your internal memory to solve this.
  8. saj_2001ind

    saj_2001ind Well-Known Member

  9. falkirkbairn1951

    falkirkbairn1951 New Member

    hi everyone i have found out how to fix the usb problem if anyone needs help please let me know and i will post a thread:D
  10. dirtyddd

    dirtyddd Member

    If you have a fix why not just tell everyone instead of making people ask you for it? I find you have to do a combination of things to get it to work like run the software first then plug in or vise versa even then it only works 20% of the time.
  11. falkirkbairn1951

    falkirkbairn1951 New Member

    Reason being it is long winded but thanks for your concern, by the thread that you have posted you seem to know how to fix it as well? so why are you only given bits and pieces in your thread the same applies to you post the full fix and stop your complaining
  12. dirtyddd

    dirtyddd Member

    All I know is what I posted. Whats your fix?
  13. dukemist

    dukemist Member

    i am not able to connect my phone in usb mass storage mode.
    every time i connect and try to open the drives, the explorer hangs and i have to restart my pc.
    any suggestions guys

    Attached Files:

  14. Geryatrix

    Geryatrix Well-Known Member

    I can't offer a general fix, but I can tell you what worked for me and it's simple.

    1. Remove external SD card
    2. settings>SD card and phone storage> int SD card>unmount SD Card
    3. Connect to computer
    4. settings>SD card and phone storage> int SD card>mount SD Card

    You should then see the internal SD card in windows explorer, once you have done that you can re-fit the ext SD card and repeat

    Hope that this helps.
    emmes likes this.
  15. LateNiteMike

    LateNiteMike Well-Known Member

    I'm going to post this here because I don't use Kies for my USB connection. Forget Kies, you don't need it for a USB connection.
    Here's a copy of my other posting elsewhere in this SGS forum. I don't know how to link to it...so I am just doing a copy and paste. I hope this is useful.

    [​IMG] The best way to USB to a PC using XP.
    Quote:
    Originally Posted by DroidRick [​IMG]
    Thanks for getting back to me finally Mike.

    When I connect now I just basically need to:
    1. Connect the cable from SGS to PC
    2. Pull down menu on home screen and mount the USB connection.
    (I have the settings set, not to ask on connection, just do USB)

    That's it!
    When I'm finished, I do it in reverse.

    Your steps are basically the ones people should follow when trying to connect to a PC with WinXP for the first time.
    Having said that, I am sure some will need to install USB drivers for the Android as I did.

    The reason I say this is because I followed your procedure when I was trying to make a connection and it didn't work (on two WinXP PC's).


    You're absolutely correct regarding your short steps to setup a USB connection to a PC (with XP). I thought surely there must be a quicker way to perform this task...and you have it. I tried it and it works.
    My hat's off to you DroidRick, good work !
    :)

    Hopefully we've boiled this down to the point to where any newbie can now get their USB setup and going with minimum hassle.
  16. rcl4444

    rcl4444 New Member

    Here are some great solutions in a similar thread:
    http://androidforums.com/samsung-ga...-galaxy-s-i9000-mtp-application-crashing.html


    Most common reasons for this issue that I've found:
    1) MTP app issues from int or ext sd card containing file names with extensions longer than 16 chars (check out link for solution & little app to help fix ;) http://androidforums.com/1446922-post5.html )
    2) Need to remount int or ext SD cards (see earlier post - thanks Geryatrix :))
    3) Need to reformat one or both SD cards (usually internal)
    4) Missing or currupted drivers (check out link http://androidforums.com/1576152-post33.html )

    These are all when the phone quick swaps between Home screen & USB connecting screen. If phone appears OK and Kies doesn't connect:
    1) Missing or currupted drivers (check out link http://androidforums.com/1576152-post33.html )
    2) Need to update to latest version of Kies
    3) Try different USB port
    4) Check USB cable - USB charging cables don't always carry data as only 2 wires (1 pair) needed to charge - data needs more.

    From what I've read the above covers/resolves vast majority of cases. If all this doesn't work I suggest bite the bullet and take it to a service centre. There are other possible reasons and solutions you can find that require rooting the phone, SD card partitions, other advanced user stuff. Making a mistake trying advanced stuff can majorly screw up your phone so why risk it? Just remember to change the USB settings on your phone so you can connect it as a mass storage device & back up your data first. (settings>about phone>USB settings>Ask on connection...then connect SGS to PC. Select the Explore option on PC pop up, go to your phones notifications pull down menu>select the USB connection notification. Then select Mount (like LiteNiteMike says above)

    BTW: Factory resetting almost never works!

    Hope this helps - GOOD LUCK!
  17. hhuergo

    hhuergo New Member

    yeah... excellent, that was my problem... thanks
  18. Plastiman

    Plastiman New Member

    Hi, I've one more solution to add: Try cleaning the connections with an alcohol swab. I had tried the ports, different computers, different versions of kies/drivers/windows, cables,etc. I cleaned the ports (which are small!) and boom! 8 drivers installed (which is likely too many but that was A OK.

    Hope that helps someone faster than I figured it out.

    G
  19. stevenn21

    stevenn21 Active Member

    i have the samsung galaxy s i9000 on firmware 2.33 and when i go into usb settings there is no option for ask on connection.
    its set on samsung kies already but it wont connect to keys in the kies software it says connecting but then it dissapears and doesnt connect even though the phone says connected press the home key to exit samsung keys.
    anyone can help?

    EDIT: i fixed it by unmounting the external sd card

    also see my other post which might help people who cant start kies at all:

    Ifound a fix for win 7 64 bit worked for me.
    I installed the new version of kies but the computer would not recognise the phone anymore also the drivers wouldn't load.
    And when i tried to run kies it would say kies has stopped working.
    I tried every thing and was about to give up until i decided to type kiesdriverinstaller in to the start box then clicked on the kiesdeviceinstaller option that popped up in the list of the start menu.
    Then i waited 2 mins ans typed kies into the start menu and hit the kies option to open it and it worked!
    Now i can open kies from the desktop shortcut icon.
    Kies still wont connect my phone though
    EDIT: i fixed it by unmounting the external sd card now it connects
  20. Jimmy Mbugua

    Jimmy Mbugua Member

    Strangely mine too which is on Froyo 2.2 does not show USB settings on Settings-> About phone
    But I can swear I had this option on the phone, i.e to able be to select how the phone connect to USB and I actually selected "Ask". But this was before I fixed the 3 button combo problem. Could the procedure to fix the problem have removed this choice option?
  21. stevenn21

    stevenn21 Active Member

    i also had the ask on connection option somewhere but its gone now.
    i have never heard of the 3 button combo option so can't comment on that.
    you will find the usb settings in settings > wireless and network> usb settings.
    but the only options there are:

    samsung kies
    media player
    mass storage.

    there is no ask on connection option in there.
    what is the problem with your phone maybe i can help
    Jimmy Mbugua likes this.
  22. Jimmy Mbugua

    Jimmy Mbugua Member

    @stevenn21
    Thanks; I think I was mislead by someone in this topic on the whereabouts of the setting. Anyway, after your tip, I find that the feature is still in my phone, Kudos
  23. stevenn21

    stevenn21 Active Member

    the ask on connection setting or the usb settings menu?
    where did you find the ask on connection setting?
  24. Jimmy Mbugua

    Jimmy Mbugua Member

    Settings-> Wireless and network -> USB settings

    1. Samsung Kies
    2. Media Player
    3. Mass Storage
    4. Ask on Connection
    When I connect my USB cable all the options are displayed and I choose what I want
  25. stevenn21

    stevenn21 Active Member

    no i still dont get the ask on connection not even with the cable connected oh well

Share This Page