Galaxy S Menu Button ProblemsSupport


  1. Digihome

    Digihome Member

    My wife has a Samsung Galaxy S I9000 and whatever application she is in the menu pops up as if the menu button has been pressed. Of course, she is not pressing the button at the time.

    Have any of you run into this problem? I hope it isn't defective hardware...

    Advertisement
  2. M22RDY

    M22RDY Active Member

    It sounds like a hardware problem, but a safe bet in every senario would be to backup your files and reset it back into factory settings.

    Settings > Privacy > Factory Data Reset

    If it still does it after it wipes itself then it will be a hardware fault as there will be no additional software effecting it.

    You can also try removing Battery, Sim, External Memory etc and leave them out for 5 mins and attempt that before the factory reset.
  3. Digihome

    Digihome Member

    I tried removing the battery for a few minutes but that didn't seem to help. I will try your other suggestions tonight and hopefully it fixes it.

    Thanks!
  4. M22RDY

    M22RDY Active Member

    Remember, remove the Sim-card, memory card, and battery for at least 5 minutes.
  5. Digihome

    Digihome Member

    I performed the factory reset and it appears to have fixed the problem. Apparently, she installed a bunch of applications prior to having the menu problem.

    Thanks for you help!
  6. M22RDY

    M22RDY Active Member

    Good Result,

    Thats the two fail-safes that I've found with the galaxy-s.

    1) Remove all the components (battery, sim, memory card etc.) for 5x minutes and re-insert them.

    2) Factory Reset (backing up all the stuff is the most annoying stuff)

    You could also try installing the apps 1 by 1 until you find the culprit.
  7. Digihome

    Digihome Member

    Spoke too soon, it seems like both the menu and return buttons are screwed. The phone is going back to the store...
  8. Keyth

    Keyth New Member

    I have this problem also, everytime I click back or the menu button one of the keys lights up and then neither key can be pressed unless I hit the power button.
  9. Digihome

    Digihome Member

    My wife returned her phone and will be receiving a new one in a couple weeks. I sure hope this doesn't become a widespread problem with the Galaxy...
  10. bwong365

    bwong365 New Member

    I have the same problem, problem is Sasktel told me that I'd have to send it in for repairs, which means waiting 4 weeks for the phone to come back. Furthermore if they can't reproduce the issue in the shop, they send it back to me as is and charge me $25... some warranty eh... this is kind of ridiculous, I basically have to wait for the problem to get worse (assuming it does), or I just take a chance on a loaner phone with a month, and a possible $25 hit with no phone improvement...

    I sorta wish I'd gone with an iPhone right now
  11. voltchaoz

    voltchaoz Member

    Have you tried unmount the external sdcard from the settings?
    Try it.
  12. yanickfc

    yanickfc New Member

    Hi,
    I have the same problem!
    I did a factory rester, removed batterie and sim card for 5 minutes, unmount the internal card since and I don't have an external one
    It still do it! and its random, sometime I can use it for an hour without any problem, then it starts to give me a hard time..
  13. survivorevil

    survivorevil Member

    i see im not the only one. im really pissed off with this problem. Ive had the phone for 2 weeks. It had been working perfect until today that started doing the same thing as described here. I cant return the phone since i bought it from europe and im in the us. This is really frustrating because it seems to be a hardware issue
  14. wickedmoose

    wickedmoose New Member

    Hi Guys. I had the same problem. I was so disappointed with my phone.
    I googled like a mad man and found this fix.

    Just dial this into your phone *#*#2663#*#*

    Select the option to update your touch firmware and voila.

    Mine is working great now.

    Hope this helps.
    shawnzopellet likes this.
  15. survivorevil

    survivorevil Member

    Mm too late for me. I already sold the phone and waiting for the galaxy s 2
  16. shawnzopellet

    shawnzopellet New Member

    This has worked perfectly and I have not had the issue since
  17. buranyi

    buranyi New Member

    I have same issue with Galaxy S. Menu button works sometimes for a few minutes to a few days and other times not at all. At times it will flash on and off and the keyboard will pop up.
    I will go through the various fixes suggested here but it sounds like a hardware problem and one Samsung is not acknowledging. Worse they will not fix the phone as it was bought outside Canada while I was travelling.
  18. zakiuddin89

    zakiuddin89 New Member

    I have a samsung galaxy gio (S5660) running version 2.2.1. Its been only two months since I got this phone. N all of a sudden, a couple of days back, I was using the native youtube app, n it was like my menu button went into tonic spasms.. Several bursts of d menu button n even d back button.. But mostly its as if d menu button has been pressed n held, activating d "search" feature. Been really difficult since then.. I think its happening more with android market n google maps n youtube.. can't be sure. Didn't notice any relation to my downloading of any specific application.. I even tried d *#*#2663#*#* option suggested above n for a short time d problem goes away but comes back again. Am thinking of doing a factory reset of my phone but am worried about losing my phone contacts n text messages. Can anyone help with this? Or at least direct me to a thread where I can look into how to back up msgs n contacts..
  19. samare

    samare New Member

    Hi,

    I bought a GT-S5660 phone last week from Singapore. Unfortunately the Back Key is not working now. Once in a while it starts working but it is last in few minutes. I did factory reset, upgrade android OS to 2.3.4, and tried that code (*#*#2663#*#*) as well. But still it doesn't work. Can somebody confirm whether this is a firmware issue or Hardware issue. This phone or parts not available in Sri Lanka. I'm in very unfortunate situation now.

    Thanks,
    Samare:confused:
  20. Alvaro.Andrade

    Alvaro.Andrade New Member

    I purchased a Samsung S i9000T last week which came with Eclair. Everything worked fine for a couple of days; suddenly "back" button broke.

    I followed the suggestion of doing a *#*#2663#*#* which seemed to fix the problem for a few days. I decided to upgrade to Froyo using Kies since I guessed earlier versions might be a little buggy.

    Today the problem suddenly reappeared. To make things worse I tried again with *#*#2663#*#* touch firmware, which seemed to broke the "menu" key as well. So now, neither "back" nor "menu" buttons are working.

    I'm a fan of Android and truly liked Samsung but now I question myself if that was the right decision compared to the iPhone.

    Hopefully somebody can help.
  21. Alvaro.Andrade

    Alvaro.Andrade New Member

    For the sake of documenting the issue: just before the "menu" button stop working, the "back" button was taking screenshots and sounded like a camera click.
  22. theillway

    theillway New Member

    I'm having the same issue: randomly, my phone will act like I'm hitting the menu button frantically. It didn't start until I upgraded to gingerbread (my wife has the same phone bought at the same time and hasn't upgraded it at all from 2.2, and doesn't have this problem).

    I tried dialing *#*#2663#*#*, but I just got a busy signal (maybe I have a different carrier -- uscellular?). I looked for other ways to upgrade the firmware but couldn't find anything I trusted. I took out the battery and the SD card (my version doesn't have a sim card), but that didn't help either.

    I am also having the related problem of my phone taking screenshots when I hit the power button. I know that power + menu is supposed to take a screenshot, so I'm guessing this is happening when the phantom menu button is triggering. This really starts to be a problem when I need to turn my phone off, but can't because it just keeps taking screen shots. Pressing the back button sometimes helps; it seems to stop the menu button panic and lets me turn off my phone.
  23. MattPayne

    MattPayne New Member

    I have a similar problem... neither my menu nor back keys will work at all! I've done the code, but it freezes when I try to update TSP FW Update! It makes my phone pretty much useless! I've reset the phone and I've even flashed the stock rom again! Nothing works!
  24. Gew

    Gew Active Member

    Most of us are still wondering if this issue is software or hardware related. Like I've stated earlier in similar threads, I have a Galaxy Gio (GT-S5660) running Gingerbread 2.3.3. It suffers from the exact same issue; BACK button being "phantom-locked" so that pressing HOME button (in the middle) takes screenshot instead of getting me to my home screen. Can't wait till Samsung releases further Gingerbread versions (eg. v2.3.5) so that I can see if they will have worked this sh*t out. Till then, this phone is mostly just a huge annoyance.
Loading...

Share This Page