Galaxy S "Unable to Scan for Networks"Support


  1. theskywalker

    theskywalker New Member

    When i turn Wi-Fi on, it always say "Unable to Scan for Networks"
    I tried to turn off, pulled the battery, turn back on but does not make any different. does anyone have this problem?

    Advertisement
  2. Phawx

    Phawx Active Member

    I think people would love to have your problem right now. Most of us don't have it yet.
  3. Ahmed Alzayani

    Ahmed Alzayani Active Member


    Try to reset to factory setting, if you still get the same issue , do ROM re-flash (or let the carrier/Samsung service agent do it for you) , if you still get the same issue, it most likely a hardware issue; so replace it under warranty.
    theskywalker likes this.
  4. thebigstig

    thebigstig New Member

    I have the same issue. Been on the phone this morning to Samsung (25/06/2010) and they are calling me back.......watch this space......
  5. androidsj

    androidsj New Member

    Had my phone for a week, ok till yesterday, now it has the dreaded "unable to scan networks" message. Can't understand what's changed to stop wifi from working. Any ideas anyone?
  6. androidsj

    androidsj New Member

    Well I can answer my own question now! Got Samsung's number but not working on Sunday, tried factory reset (settings/privacy/factory data reset), not the hard reset involving the volume key which doesn't work.

    And IT WORKED!!!!!!!!
    FasterEd likes this.
  7. Noose475

    Noose475 Member

    I'm in korea. Wife has the S phone. She has the same problem. She just found out in the korean forum. That a lot of New S users are having the same problem as well. She switched the phone three times and still has the same problem. Think it might be the hardware. She checked my motoroi and its fine. So we know its not the router. Hopefully samsung will correct this b.s.
  8. sbiml

    sbiml New Member

    I had the same problem as everyone else...no wifi access at home. I knew something with the 'droid was amiss because I just got this phone to replace a Blackberry 9700.

    After reading a number of forums it appears the problem is with security keys. Although I did not want to I disabled the WEP at home and...voila! 4 bars of wifi.

    Give it a try if you're not concerned about security. I don't know that I'll keep the setup this way but it's a step in the direction of someone figuring out a real cure.
  9. cricen

    cricen New Member

    same problem here.... kinda lame, I'd like to see this fixed rather than factory resting every flipping time it happens. BTW Samsung was NO help:mad:... Seeing as a factory reset is my only option can anyone recommend a good backup app?
  10. TenerifeWiFi

    TenerifeWiFi New Member

    We just had a WiFi client who had 2 of these (his and his wife's) start with the same problem at the same. Factory Data Reset worked, but it suggests that there is some sort of trigger for the problem which both phones encountered. Hopefully nothing to do with our WiFi network.

    Does anyone know if a cause has been found?

    Cheers.
  11. tiethilo

    tiethilo New Member

    i got the problem when connecting to a network in a cafe which on the galaxy s was listed as secured while staff claimed (and my laptop confirmed) it's an open network. when the phone asked for a network key i did not enter one but just hit connect upon which wifi stopped working. in fact it switches off again within a few seconds after turning it on.

    i have not reset the phone yet, hoping to find a better solution...
  12. Sdi1000

    Sdi1000 Member

    Same with mine. Working perfect for about a week, the shutts down the wifi.
    Have done a factory reset twice. After thet it will work for some days, and then quit again. Obtaining IP, and then says network is disabled. I have changed Router security from WEP to WPA/WPA2 PSK without any change, also tried to disable security in my router, but same story...network disabled. I have 3 laptops working just fine in my home wifi :mad::mad::mad: Samsung needs to FIX THIS !!!
  13. mshankars

    mshankars New Member

  14. Mr_Sir

    Mr_Sir New Member

    Hey there.. If anybody is still having problems with galaxy s' wifi here's the solution.

    Samsung Apps

    Go to this website and click 'Hent kies2.0'

    Download this and install, it look's very much like Itunes. When program is installed link the pc to your galaxy s and press the mobile icon.
    Mine says GT-I9000.

    Aftwards install the latest firmware.

    Worked for me. Good luck :D
  15. ObadiahBadger

    ObadiahBadger New Member

    Have this problem and have tried the recommended solution, but keep getting a message that the phone has disconnected. Have turned off all that I can find, but still happens. any suggestions, please?
  16. atheneheaven

    atheneheaven New Member

    I had the problem where it would keep disconnecting you when it tries to download the firmware to the computer. I updated KIES (most useless software in the world) this month and this seems to have sorted the problem with this. Updated to the new firmware, i never had the problem with unable to scan for networks before, but it seems to have become a feature now.
  17. Stacilee

    Stacilee New Member

    Yes, taking security off my router didn't work for me either. Only a reset would work, although next time I'll try deleting the file as explained in mshankars' link. (I already have the sdk's and stuff on my computer--otherwise, I would advise people to just do a reset if they haven't worked with sdk's and such already.)
  18. Matthew Suekel

    Matthew Suekel New Member

    Had the same problem after I rooted it, it said unable to scan for wireless networks. I factory reset it and stuff it wont fix, please help, and soon someone.

Share This Page