Galaxy S2 battery drains fast

Last Updated:

  1. ashiquerahiman

    ashiquerahiman New Member

    I am Galaxy S2 user from Dubai,I am using it for four months comfortably,from last month battery starts drain fast,if I fully charged it will stay only for maximum 12 hours,it was upto 30 hours friends also facing the same issue,please help.I suspect some updates troubled us.

  2. iT0mm0

    iT0mm0 Well-Known Member

    firstly download the latest siyah Kernel

    set max cpu as 1200
    min cpu as 200 ( 100 uses more battery)

    Ondemand is a fantastic governer

    tick apply at boot


    when booted turn on aeroplane mode

    switch phone off for a minimum of 60 seconds

    restart and turn off aeroplane mode

    8 hours sleep and only 3% battery used

  3. caloyzki

    caloyzki Well-Known Member

    where i can find this to my phone? i dont know where i can look all what you said. pls be specific. ty
  4. iT0mm0

    iT0mm0 Well-Known Member

    before i go into great detail can i ask which kernel and rom combination you are currently using please, its only because its going to take me a long time to link if you are using something completeley alien to me
  5. caloyzki

    caloyzki Well-Known Member

    baseband : LPS

    kernel : 3.0.29-siyah-v3.1.2+gm@gm-mint #28

    build number : andyX rom v11.

    is this a good combo?
  6. iT0mm0

    iT0mm0 Well-Known Member

    different to what i use but easily transferable

    reboot to recovery and set the default profile to battery (in kernal options)

    reboot and download extweeks

    now set cpu governer to ondemand

    set min to 200

    max to 1200

    tick apply at boot


    when rebooted press and hold power button you will see aeroplane mode, click on this (you will lose all connections)

    switch phone off

    leave for at least 60 seconds (it clears some big wakelocks)

    reboot and switch off aeroplane mode ( you can tell as wifi, 3G etc is back)

    if you leave alone for 5 - 10 mins have cpu spy installed you will now see that deepsleep is now working
  7. caloyzki

    caloyzki Well-Known Member

    where to download extweeks?
  8. caloyzki

    caloyzki Well-Known Member

  9. iT0mm0

    iT0mm0 Well-Known Member

    misc > default cpu governer

    ondemand works for me but lulzactive is also a good one, although the wakelocks were unbelievable
  10. caloyzki

    caloyzki Well-Known Member

    ok. i am in ondemand now. how about set min to 200
    max t0 1200??? this is under where?
  11. iT0mm0

    iT0mm0 Well-Known Member

    goto system settings>Rom control > performance, and set it from there

    this is where i cant help anymore as im on AOSK

    hopefully someone on a sammy rom can take over :)
  12. caloyzki

    caloyzki Well-Known Member

    i got it my friend. thank you so much for ur help,
    how am i gonna set it back to default the one that i tweak in kernel options? ty this is my last question my friend.
  13. Kie

    Kie Well-Known Member

    Sammy based roms don't have a ROM Control setting :)

    OP, you should download a program called Voltage Control. It's the easiest way to set yuor clocks as well as choose the governor.
  14. caloyzki

    caloyzki Well-Known Member

    hi kie, i just downloaded voltage control. what is the best settings that i need to change?

    my battery drains so fast and i downt know what is going on. cannot get 1 day of use. it is so frustating.
  15. Slug

    Slug Check six! Moderator

    There are no "best settings", as every processor behaves differently. The most important thing is to test any changes you make thoroughly before setting it as the boot-up default.
  16. Kie

    Kie Well-Known Member

    What Sluggy said. You can try my settings as a basis. I'm comfortable with those settings, and they give me an awake day's usage (7am-11pm) by which time it's usually down to 20-25%.

Share This Page