Galaxy S2 battery woes after Android 4.0.3 upgradeSupport


  1. RWG67

    RWG67 New Member

    Hi All

    I am having same problems. Phone hot and battery being drained even when unused. Have followed as much advice as possible from above. Main thing draining mine seems to be the google calendar sync.

    Even when idle I am using 474MB of the 831 available. When I click 'clear memory' it closes 23 applications and drops the usage to 384 but then it creeps up again.

    I am struggling to get the battery to even last a couple of hours!!! Any news of an update/fix or am I scratching around for a solution.

    Many thanks in advance.
  2. ricog

    ricog Member

    I was just about to upgrade from 2.3.4 to 4.0.3 until I read this thread. Now I'm hearing the battery is dead after a few hours? Thats scary.

    At the moment on my rooted stock 2.3.4 S2, phone 100% at 5:15am, and drops to about 35% at 11pm. Although I have a car charger, I'd rather not have to keep charging the thing, as I heard it shortens the overall battery life?
  3. evohicks

    evohicks Well-Known Member

    Same here on unbranded, battery is definitely better on ICS than GB.
  4. Forbidden 403

    Forbidden 403 Well-Known Member

    This used to be true for older generation of Li-Ion batteries not the newer ones.
    ricog likes this.
  5. ivanover

    ivanover Member

    This is indeed the problem, a rogue application that loops and drains battery. But may I ask how were you able to snipe the very same app that was causing the trouble?
    I can see no way to identify it for sure.
    Thanks
  6. Russell Ng

    Russell Ng Well-Known Member

    Look at the battery statistics is one. Its under settings/about phone/battery

    Or use BetterBatteryStats to look at what's (processes) causing wakelogs.
  7. Forbidden 403

    Forbidden 403 Well-Known Member

    You can export the log from Better battery stats and analyze it properly.
  8. Rheumatoid

    Rheumatoid Well-Known Member

    I too am getting about half the battery life since upgrading to ICS. Battery info shows 80% of usage is Android OS.

    CPU total = 8h 23m
    Keep Awake = 5h 49m

    does this suggest something is keeping it awake?
  9. Really struggling to find a solution to my problems. Updated my phone through Kies to 4.0.3. now I get an error message every 30 seconds saying battery paused voltage too high. Tried new battery, tried charging 100% then taking out battery, downgrading firmware, rerooting, restoring factory settings even cleaning out the usb port. When connected to a pc this only charges the phone, only connects through Odin. When i take out usb or normal charger the battery icon on my phone shows that it is still charging up to 5 mins after disconnecting. Also battery can appear to be at 15% to 100% no matter how long the phones been charging. Please help if anyone can because im close to throwing the thing up the wall. I dont class myself to be a noob with this kinda thing but this has me stumped!!
  10. lamisere

    lamisere New Member

    Hi,

    had the same problem, the galaxy was constantly hot and battery didnt really charge.

    I uninstalled my mobile security. works fine now
  11. Olle84

    Olle84 New Member

    Hello

    I have the same problem here.
    I updated my android and now my battery is empty in 8 hours (2000 mAh).
    At my better battery stats I have the most problems at the following subjects:

    Wakelocks
    =========
    MAIL_SERVICE (com.android.exchange.Exchange Services): 2 h 43 s (7243 s) Count:1921 29,1%
    FacebookService (com.facebook.katana.Facebook): 4 m 1 s (241 s) Count:12 1,0%
    *sync*_gmail-ls_Account {name=jarcodejonge@gmail.com, type=com.google} (com.google.android.gm.Gmail): 3 m 35 s (215 s) Count:51 0,9%


    Kernel Wakelocks
    ================
    "multipdp" (): 3 h 24 m 6 s (12246 s) Cnt:(c/wc/ec)1241/0/1240 48,8%
    "secril_fd-interface" (): 2 h 13 m 5 s (7985 s) Cnt:(c/wc/ec)2931/0/0 31,8%
    "PowerManagerService" (): 2 h 4 m 44 s (7484 s) Cnt:(c/wc/ec)5327/0/0 30,1%
    "l2_hsic" (): 51 m 47 s (3107 s) Cnt:(c/wc/ec)10756/0/0 12,4%


    can anybody tell me what the problem is?
    as exchangeservices I use gmail (4 till 5 mails a day)
    and I use my work mail, that works with the usual email program from samsung (Email) we are working with outlook mail (20 mails a day).

    It was never a problem with version 2.3 till 2.6
  12. Ratdroidette

    Ratdroidette New Member

    Hi - Newbie here!

    I received a GS2 last week from CPW (Orange contract) and was very happy with it on 2.3.4. Plugged into Kies and updated to 4.0.3 last night and geeze
  13. villamike

    villamike Member


    Same as me, heres a screen shot

    I have rebooted, nothins seems to work, why is the Android OS so high?

    Attached Files:

  14. kryzzay83

    kryzzay83 Well-Known Member

    Common problem. Anyone found the solution?

    My Android OS was at 51% plugged into usb charging and the battery was dying faster then it could charge!

    Just tried a few of those suggested tips on the XDA forums, reset the phone also and now my battery is charging normally and is already at 31% from 14% in about half an hour.

    Something is stuffing up with the Android OS battery usage but what? :confused:
  15. jamonbread

    jamonbread Member

    I had this issue with GB still on my s2, only a month after owning the phone. There's quite a few threads on this issue online. You need to clean the USB port and lift the pin up towards the screen lightly to remedy the problem, in the short term at least anyway. Failing that you need a new USB PCB fitted in the device. I'm to scared to send my phone back to Sammy to sort the issues out as most people that did got their phones returned and their warranty voided for moisture damage to the USB's PCB. The good news is the part is cheap and easy to replace, if that's any consolation?

    Some Sammy dealers have apparently told an XDA forum member that they are aware of the issue but they are refusing to recognise the problem. Apparently a batch of S2's left the factory without sufficient anti-oxidizing coating on the small USB PCB's or something like that? I can't confirm this obviously. Enough people seem to be having this issue. If your voice commend app ever starts to start up on its own, then you can be pretty sure you have this issue with the PCB part.

    I'm sim free and I recently upgraded to ICS and my phone now takes all day pretty much to charge ( form around 12pm to 8/9pm its at 88% then I admit defeat taking it off the charger) You could fry an egg off it while it is charging. By morning I'm down to 30% even after leaving the phone in aeroplane mode all night to conserve power. The phones pretty much useless to me now as it will never charge in time for work. I've removed almost every app I can and disabled a lot of stuff I don't use. The OS itself in battery stats is the one that seems to be munching most of the juice? Kind of had enough of this phone now and I've only had it for nearly 3 months at most.
  16. jamonbread

    jamonbread Member

    Had the day off work today. I left the phone this morning after the alarm went off in aeroplane mode till about 1.30ish this afternoon. It was at the usual 30%ish area that its been at most mornings since the ICS update. Put it on charge at 1.30pm and it finally reached 100% by 7pm.

    Still sucks at 5 and a half hours, but at least its an improvement of sorts to the usual 8/9 hours I've been usually having to let the phone cook all day at.
  17. Mrs Ozio

    Mrs Ozio New Member

    Hi All
    green (ever green) here and I hope you can help me.
    I've upgrade my SII intl. version in the weekend via wireless update (not Kies) and had the following issues:
    1. same issue with Exchange email as reported above by Chri5H. The Exchange service the Exchange server has stopped working well and updates the emails every day till 12 PM and than stopped till the next day. I've checked the setting, the sync period etc - nothing. I tires to recreate the account - same issue
    Any advice?

    2. can connect to Wifi - have sevral networks I link to and all are showing as "obtaining IP..." and are not being connected. tries to re connect and enter the passwords but still the same problem

    for now to battery issues but we will see...

    thanks
    Mrs. ozio
  18. Ratdroidette

    Ratdroidette New Member

    Thought I'd share my success story here. Thanks to the XDA Forum I've at last managed to roll back my unbranded CPW SG2 from ICS to GB 2.3.4 which was what it was shipped with. I orignally used the suggested firmware on the main XDA guide for flashing, but the official release version is also ICS 4.0.3 so that didn't help much. I then had to find older versions of firmware on samfirmware. After a disaster using a 2.3.6 UK orange version (as I'm on orange but forgot that this would "organify" my phone!) I eventually went for 2.3.4 for UK / Ireland and that has done the trick. I was very worried about using a firmware that didn't match up to the original PDA of my phone, but at least I've got a functional handset now and if I ever need to send it in for repair under warranty I hope I can just hook it up to Kies and re-load the ICS again for my original PDA.

    Anyway - hope this helps anyone who is a total novice like me, and wants to rollback from ICS to GB 2.3.X. :thumbup:
  19. plum

    plum Member

    I had battery issues after switching to ics. It got a bit better after a few days.

    But then I switched my email program from the stock to another (k9) and my battery life is 24 hours now.



    Sent from my GT-I9100 using Tapatalk
  20. jamonbread

    jamonbread Member

    This morning s2 seemed to be OK again, it only took a few hours to charge as per normal and it stayed nice and cool in the process.

    Stuck my phone back on the charger when I get in today around 6pm, and its still charging now after 4 hours. My phones only got a few apps on it at the moment and battery stats don't give me any new clues? I disabled the email exchange programs as I only use gmail or login to accounts via the web browser. I think I'm going to send mine back to Sammy if they don't get out any stability updates out soon.
  21. spm

    spm New Member

    Hi,

    New member here.
    I've been reading this thread with interest as both me and my wife have the SG2 with Orange UK contract. I upgraded both a couple of weeks ago to ICS and while I've had absolutely no issues with mine, my wife's battery life is really poor.
    Checking the battery usage, the stock email app uses around 23% of the battery whereas on mine it doesn't even register. The exchange services usage is also higher on hers.
    This makes absolute no sense as she only has gmail and hotmail via exchange set up in hers whereas I have four accounts with two exchange emails, so I'd expect mine to have the battery drain.
    Suggests to me buggy Samsung email app.

    Anyone been able to solve this?

    Many thanks
  22. orbiton

    orbiton New Member

    Go into Settings/Accounts and Sync and uncheck Background Data to stop the client constantly sending data packets to the server when the phone is idle. There seems to be a bug in the client side of a mail program. This can of course cause slight inconvenience for some programs so another maybe more user friendly option is to to download Juice Defender which will stop data usage when the phone is idle. Hope this helps
  23. 1981

    1981 Well-Known Member

    yep true. battery life has taken a big hit after the ICS update. takes like 3.5-4 hrs to full charge now. and sometimes, even the charge drops while charging through AC. wat a waste.
    in GB it used to be around 2.5 hrs for a full charge. and obviously lasts lesser now. plus the increased heat on the device while charging. the used RAM in the task manager also seems to be much higher now in ICS. wonder its got any effect too on the battery.
    anyways something needs to be done by SAMSUNG on the next update and soon.
  24. RenzaB

    RenzaB New Member

    Johannesburg, South Africa. Android upgraded via Wi-Fi. Phone performance was noticeable improved at first, but then started having problems with battery needed to be recharged; system freezing and only rebootable on removal of battery and then applications have to be re-registered randomly e.g. Kindle. email was working fine before, but problems now on push email. And then Opera Mobile installed as default Internet. Sorry I am a senior wannabe Technophob, so maybe this has been addressed before, but I am stumped. I love the phone and don't want to knock it - so hopefully there is a 'patch' to fix this. Thanks for your patience!
Loading...

Share This Page