Galaxy s2 Battery won't charge while being onSupport


  1. Sacha87

    Sacha87 New Member

    Hi everyone, this is my first post and I need your help! :)

    First of all, LOVE the Galaxy s2, even though it has some problems - which phone doesnt, right?

    I've had the Samsung Galaxy S2 for 2 months. It worked fine.
    Since a week my phone won't charge the battery while being on. I would charge my battery almost every night. At night almost empty, I wake up and its full. Now a week ago I woke up and the battery had only 3 % left and it was VERY warm. Unplugged it, tried it again. Turned phone on and off... Nothing worked. When my phone died, I left it to cool and then charged it again in it's off state for a few hours. I turned it on and the battery was full again!

    I use the original charger, I haven't changed anything since having the phone.

    So now I can only charge my phone while it's off.. Not ideal...

    Has anyone had the same problem?? Any advise is welcome!

    Thanks!

    Advertisement
    :
  2. greggebhardt

    greggebhardt Well-Known Member

    That is not the norm as my SG2 stays on 24/7 and charges just fine. Sounds to me like you got something CPU intensive running in the background.

    How well does your battery last after UN-plugged.

    What do you have running, any social. Also check under phone and power and it will tell you what is going on. You can post that here and some may be able to help you!
    Sacha87 likes this.
  3. Sacha87

    Sacha87 New Member

    My Galaxy stays on after fully charged for about a day, if I don't really use it; day and a half.

    Before I start charging I always check the taskmanager (the one that was already on the galaxy) and I close all applications. BUT if I go to setting -> applications -> running services there are still loads of apps active like the social apps (whatsapp, skype, facebook..) and a lot of other things. But this has been the same since I got the phone and it always charged normally.

    Under Phone and Power also nothing abnormal going on, like from the start the most energy eating is the display..

    The strange thing is that when I plug it in to charge whilst being on, it detects being charged (the battery icon shows being charged) but it isn't really charging. It will even turn off eventually.

    I've tried charging it through the original charger (worked fine before) and the usb cable through the pc (also worked fine before).

    And once I've charged it full whilst being off, it will work fine for a day/ day and a half like always.

    Im thinking my battery might be broken but that's crazy right? I havent dropped it once, and its practically new!

    Android version: 2.3.3
    Under -about phone - battery usage - I am seeing now that apart from the display (using 36% ) there is also android OS which is using 34 %.

    Thanks for helping!
  4. lankunit

    lankunit Well-Known Member

    Download Android assistant (from android market) and check which process is burning your CPU before charging and during charging. From personal experience I had the facebook widget on the homescreen and it was bugged burning 30-40% CPU constantly so that even on charge the phone will die and go very hot since it is using so much power. After getting rid of the widget everything returned back to normal. I think your phone is indeed charging except the use of power exceeds the charge rate.
    Sacha87 likes this.
  5. Sacha87

    Sacha87 New Member

    I installed android assistant. not a single app is using more that 4% . I also tried whilst charging.

    But yesterday I deleted 'Webroot Security' because suddenly it was using 58% of the battery. Very weird because I've had that app for a few weeks and there was no problem.
    Maybe there was some app I downloaded that conflicts with webroot security, I just downloaded some simple free games..

    I will tell you if the problem is solved tomorrow and if not.. :S

    Thanks for your help!
  6. André_FG

    André_FG New Member

    Try also to turn off the 3g, because some aplications stay conected to the internet (some games too, downloading the ads) and it uses a lot of power.
    I had the same problem (my battery warmed up to 140
  7. Sacha87

    Sacha87 New Member

    I got mine working again :D

    After I deleted Webroot Security it worked again. And the android assistent is also very handy!

    Thanks!
  8. bluekarlo

    bluekarlo Active Member

    Wow might try this one, in my case I have to turn my S2 off and then plug in the charger and then turn it on again cause if I don't it won't charge :(
  9. Riche101

    Riche101 VIP Member VIP Member

    Webroot as a whole is an awful product got it for my pc once big mistake caused so many issues
  10. RichardEl

    RichardEl New Member

    Same problem: S2 not charging while on, phone getting unnecessarily hot even while not being used. I had a battery monitoring widget installed. Once I deleted that widget, the problem disappeared.
  11. rahulkumar5274

    rahulkumar5274 New Member

    my galaxy s2, i just got it from my friend, and its giving me problems, i charge my battry, it will work fine for 2-3 days, if it runs out it will charge properly, bt nw when i put it on charge , it doesn't charge , if i check after 1 hour, it still remains same level when i put it on charge, for this i changed my battry, bt new battry has same issues, i have apps but i don't use it, i close every background app through task manager.
    i plugged it in night checked in morning, its still low, and phone turned off, it was same with the last battery. now,i turned off the phone and plugged it , nw its, charging, but it wasn't before while turned off, its pissing me off, i love this phone its awesome, but now.......

    any suggestions guys, sry for my English, i really need help.
  12. eivahd86

    eivahd86 New Member

    hello, how to know if my phone has webroot installed? where should i go to check it? please help. thanks.
Loading...

Share This Page