Galaxy S2 Charge Fault (not port)Support


  1. madmarf

    madmarf Member

    hey all. ive got a fault with my galaxy s2 i9100.

    it suddenly stopped charging and wont connect to the pc (no software was updated) so i gathered it was the usual port problem. i have since ordered 3 different ones, all genuine samsung and still it will not charge or coms with PC. if i measure the batt terminal pins im getting 0.98v there when the cable is plugged in but no charge. i have hotwired an old usb cable to the terminals for now and have been able to charge the battery so i can look around the phone if need be. do you htink this is software related? and if it is, can someone tell me how to down/up grade it with an SD as it cant comunicate with the PC.

    thanks all

    Advertisement
    :
  2. Harry2

    Harry2 Well-Known Member

    I take it that you tried all of the USB ports of your PC, so I think the 5V of your PC's USB is defect.
    Note, the 5V USB voltage is the same for all USB ports of the PC.

    So you might look for a defect fuse on your PC's mainboard.

    Harry
  3. madmarf

    madmarf Member

    hi harry,

    no PC is fine. the ports are all ok and i have also tried it with a samsung usb mains charger and another few i have (they cant all be broken) and they all work my other phones / equipment
  4. Harry2

    Harry2 Well-Known Member

    Maybe a mechanical problem of your phone's microUSB socket.
    Did you look for bend pins and fluff?

    Harry
  5. madmarf

    madmarf Member

    as stated above ^^^^ ive replaced that 3 times
  6. Harry2

    Harry2 Well-Known Member

    Sorry, I thought you meant cables.
    I take it that you tried it with different cables ;)

    Harry
  7. madmarf

    madmarf Member

    yes several cables, chargers 2 batteries and 3 usb boards
  8. dmg3

    dmg3 New Member

    Hey madmarf

    Same issue here.

    Symptoms are :

    - the phone started complaining the voltage was too high even when it wasn't charging.

    - Typically the port is the cause of this but for me this progressed to the phone constantly thinking it is in dock mode.

    - After a week or so of that, it finally progressed to not charging except when switched off (but it won't remain switched off; as soon as the charger is inserted, it boots up and starts charging).

    - It's also not recognised as a USB device by any PC. However, it is detected just fine in software download mode - Vol Down + Power + Home for 10 secs.

    - When it is powered on, it's extremely hot.


    I have:

    - Tried with multiple chargers

    - Tried with multiple cables

    - Replaced the battery

    - Replaced the USB board (only once in my case) and checked all the internal plugs are secured to the mainboard

    - Done multiple factory resets

    - Flashed the Samsung Official firmware back onto the device using ODIN3 v1.85 (firmware version I9100XWLP3_I9100O2ULP4_I9100XXLP)


    But I still have the same issue. Sad face.

    Because the phone is detected just fine in ODIN MODE, I believe it is not a hardware issue, but an I/O system problem. If this was a PC, I would be looking for a bios update from the mainboard manufacturer. I'm not exactly sure how to update the non-volatile memory of a smartphone - if anyone has any ideas I would be interested.

    An important note is that I have never loaded any custom firmware on this device. Like you, this started happening out of the blue a couple of weeks ago on the stock ICS firmware that I upgraded to using Samsung Kies almost 6 months ago.

    The only thing that is slightly suspicious is that the phone is 25 months old; 1 month out of its warranty period. But that's the sort of underhandedness I would expect from a company like Apple rather than Samsung.

    Did you make any progress?
  9. madmarf

    madmarf Member

    unfortunately 4 usb boards (genuine) later i still cant get it to work. it sometimes shows voltage on the battery charge pins and does charge but dosent display that on the phone. no matter what though i still cant get it to coms with the pc, wont recognise anything. i think ive got main board problems, isnt any signs of water damage though. i love the phone and would rather use it than my HTC ONE X but i just cant spend more adn more money on it!
  10. CrackBaby

    CrackBaby Well-Known Member

    Are you running Windows 7 64 by any chance, on the PC?
  11. smich73

    smich73 New Member

    Similar issue here. After 25 months of happy use the smartphone stopped charging. Actually it charges very very slowly sometimes slower than the battery drains out, but you cannot charge it from 0%.
    Tried a new battery but nope. When the battery is charged it seems to operate ok (USB connectivity ok) but it gets hot and discharges rather fast within 3-4 hours without extreme use. The funny thing is that if you shut it down and then turn it on it appears to have lost more than half the battery (from 70% to 30). That is strange because it is not so easy to discharge a battery within a few minutes!
    When the battery is empty I cannot charge it using my phone but have to use external charger or other phone. The technician who checked it said the port seems to be fine and the problem might be in software or power management circuit on the motherboard. the phone is rendered useless. THe most dissapointing issue is that this happened right after the warranty ended, like many others.
    Any hints would be great, as I can be very stubborn to fix it, provided it is a software issue.
Loading...

Share This Page