1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Galaxy s2 doesn't turn onSupport


  1. ceawhale

    ceawhale New Member

    Here's my story about my Galaxy s2 for T-mobile. My phone randomly turned off 2 days and whenever i tried to turn it on, it would restart and basically never get pass the blue loading bar screen. Second, i found out about this boot loop sequence and i was able to do a factory wipe.
    After i factory wiped the data etc off the phone, i was able to use it until it ran out of battery, but then after i found out it ran out of battery, it wouldn't let me turn it back on, it wouldn't get pass the loading screen, once again. On the other hand, i am able to go to recovery mode or download mode, but the phone shuts off before i can even try and click on the options i want.
    Today, i found out that if i kept pressing power button consecutively on the phone, I'd be able to go to my home screen and basically act as if nothing ever happened, it'd function as a new phone! I then had the nerves of turning off my phone just to make sure it finally works now, but my hopes were crushed and now the pressing the power trick does not even work anymore. It would probably work one out of 10-15 times, and in the end it'd still restart. I am using a gingerbread galaxy s2. My friend tried using the usb jib on my phone, and it worked but whenever he tried to plug in the usb, the phone would just restart. I am extremely frustrated with this, and if you can help, please do so because it's important that i fix this phone. If you have any questions, please feel free to ask!

    Advertisement
  2. Atma

    Atma Well-Known Member

    Welcome to the forums ceawhale. :wavey:

    Are you rooted? Tried flashing a rom or anything that started this? Does your phone charge when you plug it in? Do you have a warranty?
  3. ceawhale

    ceawhale New Member

    Are you rooted? Tried flashing a rom or anything that started this? Does your phone charge when you plug it in? Do you have a warranty?
    Hi there, thank you for the welcoming me to the forums. No, my phone is not rooted, it has always been gingerbread etc i never tried rooting because i never knew how:/ I believe this started when i was just browsing around facebook, so i'm not entirely sure what happened... Uhmm i tried going to download mode through the volume keys and power button when it's connected to usb to the i think it's odin3? and it'd be in the download mode but as soon as the computer says it's connected, the phone would just turn off again and bam, it's like nothing ever happened. My phone does charge when it's plugged in, but it doesn't show it's being charged but i remember my battery was dead last night and i charged it till today and now it's got power. ANd no i don't have a warranty:/ i really hope you can help me
  4. Atma

    Atma Well-Known Member

    Hi ceawhale. I don't really know what is causing these symptons.

    Do you know anyone with a phone like yours you can try their battery and see if you have the same problem?

    Try powering off your phone and removing your battery. Remove your sim card, put your battery back in and reboot. That help anything?

    Try going to the app store and install Avast or Lookout and scan your phone if it will stay on long enough.
  5. ceawhale

    ceawhale New Member

    I don't know anyone that has my phone and yes i've tried what you told me.

Share This Page