1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Galaxy S2/Google Calendar Sync ProblemSupport


  1. mike.mossop

    mike.mossop Member

    Hi,

    I've recently started using Google Calendar, and initially I was able to sync it without much problem with the Calendar app on my Samsung Galaxy S2. The only problem I had was that it would only sync one of my Google Calendars (I had one for personal stuff, and one for work).

    In an effort to fix this problem I cleared all of the data in my Calendar and Calendar Data applications on the phone based on advice in multiple posts I've read in this and other forums. Now when I sync my calendars all of the appointments still saved on Google fail to reappear in my phone!

    I have narrowed down the problem to the fact that my Google Calendar no longer appears as a choice under Calendar>Menu>Settings>Calendars (before I cleared all of the data I could select either or both of My Calendar and my Google Calendar there, but now I only see My Calendar).

    How do I get my Google Calendar to re-appear here?

    Any help would be much appreciated!!
    Thanks, Mike

    Advertisement
  2. Hawker

    Hawker Well-Known Member

    Download and run an app called business calendar free.
    In there you will see all your google calendars.
    the next time you run the stock calendar all your google calendars will have magically reappeared.
    Canurria likes this.
  3. mike.mossop

    mike.mossop Member

    Thanks hawker,

    That worked like a charm!

    Just one last thing. Now my personal and work calendars (along with Canadian holidays) appear in all places, but the birthdays that are associated with my contacts only show up in my google calendar (on the web), but not in my GS2 stock calendar, or in business calendar free.

    Any ideas?

    Thanks again,
    Mike
  4. Hawker

    Hawker Well-Known Member

    Go to calendar
    menu>settings>calendars

    you should see "Contacts' birthdays and eve..." in your list of calendars.
    Ensure this is ticked.

Share This Page