Galaxy S2 GT-I9100G Phone-Yellow_Triangle-PC Icon, USB Jig does not go to download mode.Support


  1. madcowchow

    madcowchow Member

    Hello All,

    My very first post :D and for a very new android user...

    Got a weird issue, hope someone and help? So... after failed f/w update(bad idea to upgrade over vbox session)...

    I power on my phone, and get single image displaying "Phone - Yellow Triangle - PC".

    Three Button combo does not get me back to download mode.. and displays the same image.

    I also made my own USB jig (confirmed 100% that pins 4 and 5 are shorted with exactly 301K ohms), plugging it in automatically switches the phone back to the same display image.

    Plug the Phone on the PC via usb cable, Powers it on automatically back to same display image. Linux does give the following on dmesg however:

    ] visor: USB HandSpring Visor / Palm OS driver
    ]cdc_acm 2-2:2.0: This device cannot do calls on its own. It is not a modem.
    ] cdc_acm 2-2:2.0: ttyACM0: USB ACM device
    ] usbcore: registered new interface driver cdc_acm
    ] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters

    Minicom cant connect to /dev/ttyACM0 (115200 8N1)

    Any suggestions/Ideas are welcome. Thanks.

    Advertisement
  2. madcowchow

    madcowchow Member

    So what does the "Phone - Yellow Triangle - PC" image mean in the first place? is this phone a soft or a hard brick?
  3. Kie

    Kie Well-Known Member

    You're not bricked. Phone -> Triangle -> PC means you should re-flash using Odin. Try hooking your phone up to your PC again (with the phone triangle PC thing showing) and open Odin. Odin will recognise the phone and you'll be able to re-flash.
    madcowchow likes this.
  4. Gearu

    Gearu Well-Known Member

    It's the insecure kernel causing this.

    [​IMG]
  5. Kie

    Kie Well-Known Member

    Now that's the kind of 'kernel' you do not want to flash!
  6. madcowchow

    madcowchow Member

    Thanks for the replying. Knowing that it isnt a hard brick, gives some relief :) and hope...

    Odin does not recognize the phone either. (doing it now on native windows 7 x64) I have the USB modem drivers installed. But Odin status does not turn yellow...

    okay, about the insecure kernels, if im not mistaken, arent they just pre-rooted stock kernels? got a list from here...

    Huge Download List of Insecure Kernels/Firmware to Root Samsung Galaxy S2 (SII) - Android Discussion - Pandaapp - Forum | Free Your Mobile Life!
  7. madcowchow

    madcowchow Member

    whoa... silly me, im such a poor windows user. checked device manager, and had the exclamation mark on an unknown device... updating the driver fixed this, now odin does pick the device... (@kie thanks!)

    anyone know where i can get the official firmware? links from the sticky giving me an fbi takedown notice. :(

    http://androidforums.com/samsung-galaxy-s2-international/482428-galaxy-s2-gt-i9100g.html
    [With ZQKJ6 Kernel] ONLY for [I9100G] Full New Official Firmware ZQKJ6! - xda-developers


    thanks again.
  8. madcowchow

    madcowchow Member

    okay its now hardbricked.... lol...
  9. Kie

    Kie Well-Known Member

    What firmware did you install?!
  10. madcowchow

    madcowchow Member

  11. Shotgun84

    Shotgun84 Well-Known Member

    I don't think the guy who wrote that guide knew what they were on about. Xwkj2 is for the gti9100 and not the g version. I'm not surprised it bricked your phone.
  12. madcowchow

    madcowchow Member

    That explains alot :) thanks.
  13. niazmn

    niazmn New Member

    hello
    I had the same issue.. the problem is that u r actually flashing with a ROM from i9100 and ur phone is i9100G... after flashing with any appropriate rom of i9100 G using ODIN, the phone yellow triangle and pc icon will disappear after

    hope it will solve your problem.
  14. rubenswing

    rubenswing New Member

    You are wrong XWKJ2 IS for the GT-I9001G I have a G phone and its the same version that I am using. I cannot post a screenshot (I do not have the req. no of posts) but I am sure it is as I am using it
  15. Shotgun84

    Shotgun84 Well-Known Member

    Well you learn something everyday.

    I was just going on everything I've read that the g version won't accept European firmware and XW is the code for Europe.
  16. Just2mit

    Just2mit Member

    Hi today i was trying to update my samsung galaxy gt-i9100g to ics with odin and when i tried it showd me fail than i am unable to switch switch back to download mode or anything it just shows yellow triangle and pc icon please need help
  17. ironass

    ironass Well-Known Member

    As far as I am aware, ICS has not been released for the, "G", variant of the SGSII.

    Can you post a link to the firmware that you tried to flash please.
  18. carloslima

    carloslima New Member

    I hope have already solved your problem, but in case you didn't do as I did and it's bricked do these:

    1-Go to sammobile and search for the firmware for the GT-i9100G and download it,
    2- open ODIN with administrative run
    3- remove your sd and sim cards
    4- connect the usb cable before the battery
    5- still without battery hold the both volume keys and the power
    6- put the battery
    7- the sign will appear and disappear the first time, when it does, lose the volume keys still holding the power, when it come again hold the volume keys again.
    If you timing is right odin will recognize it, just flash with the firmware that you have downloaded.

    The GT-i9100G has a different chipset and the processor is from Texas instrument while the GT-i9100G uses one from arm.

    The firmware isn't the same and samsung din't release the ICS for the GT-i9100g yet, we'll have to wait a bit longer.

    Good luck.
  19. shadman_d

    shadman_d New Member

    Idid this trick but the messege in odin apear as
    <ID:0/017> File analysis..
    <ID:0/017> SetupConnection..
    <ID:0/017> Initialzation..
    <ID:0/017> Get PIT for mapping..
    <ID:0/017> Firmware update start..
    <ID:0/017> cache.img
    <ID:0/017> NAND Write Start!!
    <ID:0/017> factoryfs.img
    <ID:0/017>
    <ID:0/017> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1
    and also "fail"

Share This Page