1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Galaxy S2 gt-i9100GSupport


  1. Shotgun84

    Shotgun84 Well-Known Member

    The idea of this thread is to provide a comparison between the gt-i9100 G and the gt-i9100. A full comparison can be found in the link below
    Samsung Galaxy S2 GT-I9100 vs. GT-I9100G Ultimate Comparison Guide. All You Need to Know! | 10Division.com

    Even though the two models basically have the same features, the difference in hardware means that firmware and kernels from one model WILL NOT work on the other.

    I know that many of you will have already known this but there will be others who didn't. So I am trying to provide a place where questions can be asked about updating firmware and kernels on the G variant.

    I'm hoping by keeping questions about flashing the two different models separate will save confusion and avoid people bricking their phone by flashing the wrong things.

    Advertisement
    :
    Highenemy and Slug like this.
  2. kcajith

    kcajith New Member

    I have got one peculiar issue with this I9100G S2 (OS-2.3.6) phone..The headset button of the earphone does not respond to a QUICK short single click to answer a call or pause a song while playing. The call answer or song pause though works fine on this I9100G S2 when i do a long click and release of button but does not repond to a short click and release.
    To test it further i used the same earphone on a I9100 S2(OS-2.3.6)..it works as expected for short click & release..I tested on few other I9100G S2 phones running on OS 2.3.6 and the issue persists.

    I even took this to a authorised service center of Samsung and confirmed the issue is with the new I9100G phones.

    I would appreciate any help to resolve this small issue as the short click and release for the button is required so that i can use it for music players on my phone to jump over to next songs..with long click this would not be possible.
  3. hashim2000et

    hashim2000et New Member

    I have got new samsung galaxy s 2 i tried to down load like face book,skyp and curren market reports.But,it says to have google account after some trial and failed register on google when i have gmail accout.So what would be the solution?
  4. leedunk

    leedunk New Member

    My gs2 is GT-i9100G
    Baseband - I9100GDZKJ2
    Kernel - 2.6.35.7
    Build - Gingerbread. DXKj1

    Kies says this is the latest firmware. Is it true?
    Is it only possible for me to update the firmware for my Baseband version?
  5. Shotgun84

    Shotgun84 Well-Known Member

    Kies updates are regional and carrier specific. So if kies says that there aren't any updates then you are on the latest official firmware available for your phone.
  6. sumitgawande

    sumitgawande Member

    My Galaxy S2 is GT-i9100G
    Baseband - I9100GDZKJ2
    Kernel - 2.6.35.7
    Build - Gingerbread. DXKj2

    Kies says a new firmware upgrade KL3 is available. But fails to update when i update it. :(
  7. imran678

    imran678 New Member

    hey i bought a gs2 i9100G and it had signal issues... it was a canadian phone n i live in srilanka... i changed da firmware version to i9100DDKE2 which actually is a baseband version of i9100... my phone's signal issue is solved bt display is da problem now... da display i nt bright n even wen i switch on my camera everythin is blurry... what can i do??
  8. Shotgun84

    Shotgun84 Well-Known Member

    I have answered your post here
    http://androidforums.com/galaxy-s2-international-all-things-root/482437-galaxy-s2-gt-i9100g-all-things-root.html

    Hope it helps.
  9. Philosis

    Philosis New Member

    I have a problem on my S2, I'm using camera after awhile it hang. I turn it off. when I reboot it, the camera it wasn't work and a message appear "camera failed". I couldn't use it anymore. So I put it on my pocket, then I feel hot, it's my phone screen getting hot and the battery easily draining so fast. I take out my battery and let it cool. Then put it back and turn it on. the camera become ok. What may be the cause of it? What should i do? Can someone know how?
  10. Rakesh Kr

    Rakesh Kr New Member

    Dude even i m facing the same problem, samsung customer care agreed that S2 G series has lot of problems and the production of the same has been stopped.They replaced me with the new handset and unfortunately they have replaced the same G version and now as the problem still persists i demanded for replacement again, they have denied it and now i am fighting in consumer forum.

    Thanks
    Rakesh
  11. sarvan750

    sarvan750 New Member

    i too have experienced those problems. the phone heats up quite fast, especially when i play games for about 20 mins non-stop. i also had the camera failed problem once. the phone also automatically switched off while playing, two times now. and i couldn't boot it up until i removed and re-inserted the battery, and its been just over two weeks since i got it. should i be concerned?
  12. Xzizia

    Xzizia New Member

    PLZ HELP!
    I had the official 4.0.3 by samsung before. Then my friend installed ROM manager and OPERA, witch looked like ICS for Nexus.
    Now I wanted to install the XXLP2 firmware and so I did it with odin.
    I downloaded this ICS to try it out but when I get in to my recovery mode I dont have the “Mounts and storage” or “Install zip from sdcard.” like I used to, so I cant install this ICS.
    I REALLY NEED HELP <3333333
  13. Xzizia

    Xzizia New Member

  14. Shotgun84

    Shotgun84 Well-Known Member

    Welcome to the forum Xzizia.

    I've just got to check if you have the gt-i9100 or the gt-i9100G
  15. S2KL

    S2KL New Member

    Hello All,

    2 days back got flashing message to update to Firmware (49MB), it was downloaded , Installed successfully. After that it prompted for Reboot -- Ok, all is fine. Immediately got one more message saying: additional update of firmware(11MB), said Yes, download, installation went well.
    again Reboot -- Ok... Phone never comes up. :mad::confused:

    Tried Hard reset but no help.

    Please someone help me out.

    Thanks!!
  16. S2KL

    S2KL New Member

    Someone please help or suggest me...
  17. Russell Ng

    Russell Ng Well-Known Member

    Not sure by what you mean phones never come up. Does the phone even turn on?

    My suggestion is to send it in and get it looked at by Samsung service since its probably still under warranty.

    If you can turn on the phone, try pressing Power+Home+Volume Up.
    That will bring you to a screen for options like factory reset, wipe cache, and I think firmware recovery. If you try those, it might work.

    Cheers
  18. godalmighty

    godalmighty Member

    At present ICS is only available for the Samsung Galaxy SII, GT-i9100, GT-i9100M, GT-i9100P, so i'm sorry to tell you that it is not available for your model yet.
  19. smashar

    smashar New Member

    hello friends.. i have this problem that i cannot open facebook on my i9100g. i tried it not only on facebook app but also directly through browser.. it just logs in bt no news feed, messages, notification opens.. even i have loaded many facebook chat browsers like im+, ebuddy, fb messenger, gochat etc but facebook doesnt open on any of them.. only through opera mini i can log in on fb and check the news feed but still facebook chat is not possible on that.. can anybody help me plzzzz!!!!
  20. buffbh

    buffbh Member

    Samsung galaxy s2 GT-I9100G. i hate my choose. why have not ICS
  21. citroen

    citroen New Member

    I installed ICS yesterday on y i9100 and it has stopped the photo auto-rotate. Google the problem and it seems lots of others are having the same problem but no answers yet!
  22. jijuvarghese

    jijuvarghese New Member

    I have GT-I9100 samsung galaxy s2 ,I want to connect the PC internet to my mobile through usb is it possible, How to do this
  23. zagir

    zagir New Member

    I have GT-I9100 samsung galaxy s2 ,I want to upgrade Android OS, v2.3.4 (Gingerbread), upgradable to v4.x to my mobile through usb is it possible, How to do this
  24. Russell Ng

    Russell Ng Well-Known Member

    Officially.

    Download latest Samsung Kies on your PC. Connect the phone to the PC via the USB. Kies will tell if your phone is due for an upgrade. If it does, it will tell you to backup, make sure the battery is charged... etc, then perform the upgrade based on screen instruction.


    Unofficial.
    If Kies says firmware is the latest, then you are officially not due an upgrade. But you have unofficial option. Upgrade via ODIN. Try the official method first.

    Cheers
Loading...

Share This Page