Galaxy S2 is NOT USB TETHERING ANYMORE :(Support


Last Updated: 2014-01-06 16:17:04
  1. shocksl

    shocksl Active Member

    kay guys I am using a Rooted Samsung Galaxy S2, on gingerbread.

    I use it for tethering... Unfortunately the wirless tehering on it has always been crap, as it drops after a while and I need to restart it every so often. So I never tether with it Wireless for that reason.
    However the USB tethering has always been FLAWLESS. Never had a problem, doesnt drop connection etc. Just recentlly it wont allow me to connect via USB anymore. The 'USB tethering' under the Tethering and hotspot option is greyed out. So I can't check it anymore :(
    Also when i connect the USB to my PC, the phone charges etc , but it wont allow me to access the stuff of my phone via the computer.

    I have Kias installed on my machine (which I re installed a couple of times)
    I have tried 3 different USB Cables, they all work
    I have master factory resetted the phone on 2 occasions.
    I have tried on a different USB ports and different computers.
    I have tried using with / without USB debugging

    I am still facing the same problem :(

    Could anybody please shed some light on how to resolve this issue??

    Advertisement
  2. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Welcome!


    What carrier do you have? If you tell us that we can get this the attention it needs from other users with the same device
    shocksl likes this.
  3. shocksl

    shocksl Active Member

    Thank you so much
    I use the network Three in the U.K (Hutchinson 3G)
  4. geofferey

    geofferey Well-Known Member

    Do you currently pay for tethering from your provider? Is this a service they charge extra for?

    Tethering features like Wifi hotspot sharing can be enabled/disabled on the phone by the network carrier. It's one of the main reasons people root their phones. This may be the same for USB tethering also.
    shocksl likes this.
  5. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Nah Three dont disable that mate :thumbup:
    shocksl likes this.
  6. LilBit

    LilBit Well-Known Member Contributor

    shocksl likes this.
  7. argedion

    argedion The TechnoFrog VIP Member

    Moved to the Galaxy S2 international where you should be able to get better assistance.
    shocksl and Slug like this.
  8. geofferey

    geofferey Well-Known Member

    shocksl likes this.
  9. Slug

    Slug Check six! Moderator

    Welcome to Android Forums, Shocksl. :)

    I'll move this to the Galaxy S2 (International) sub-forum, where other GT-i9100 users may be able to offer solutions.

    edit: o noes, I haz been ninja'd by a frog! :eek:
    shocksl and LilBit like this.
  10. shocksl

    shocksl Active Member

    Thanks guys for having me :)

    No the sim has all you can eat data, which means I can use it for tethering. I am currently using the same sim card in a different phone, works absolutely fine.
  11. geofferey

    geofferey Well-Known Member

    Have you tried reverting your phone to stock? I.e. flashing it with an official package from Samsung?
    shocksl likes this.
  12. shocksl

    shocksl Active Member

  13. geofferey

    geofferey Well-Known Member

    If your phone is SIM/carrier unlocked reverting to stock should not re-lock the phone. The guide I posted doesn't only remove the root it revert the phone completely back to factory in case anything went wrong in the system to cause tethering to become inactive.

    Edit: will > should
    You can also re-root the phone afterward.
  14. shocksl

    shocksl Active Member

    My phone is locked on 3G so If i do that. then I wont be able to use my sim

    Can someone tell me how to do everything . I.e go back to factory settings from reverting to stock as u have said above.. to redoing the Root, so this time I can have Jellybean or something and my phone can unlock again....

    If someone can show me step by step. ( or just post the links I will need to follow). I will be grateful
  15. geofferey

    geofferey Well-Known Member

    First type this into your dialer and tell me the lock status of your phone. All of them....

    Also if you may can you tell me the method you used to unlock your phone?

    *#7465625#
    shocksl likes this.
  16. shocksl

    shocksl Active Member

    ntework lock off.... network subset lock off..... sp lock off...cp lock off
  17. geofferey

    geofferey Well-Known Member

    Your phone is carrier unlocked, even if you restore it completely it will remain unlocked. I don't know if you will have to apply APNs manually for 3G to work but it should be able to load these settings from the SIM card (I deal mostly with CDMA phones).

    Did you follow a guide kinda like this one to unlock the phone?
    I will also need the model # from the back of the phone.

    http://forum.xda-developers.com/showthread.php?t=2024514
    shocksl likes this.
  18. shocksl

    shocksl Active Member

    all I did was use a software i downloaded from play store to unlock if i remember correctly...it was a while ago... i remember doing something on the computer too, to root it.

    the model number isGT I900
  19. geofferey

    geofferey Well-Known Member

    Yes you had to root it in order to run the software that performs the unlock. I've attempted the procedure before. It permanently unlocks the phone. In this case I can even assume root is unnecessary for you to have unless you are using it for some other purpose. Just use the guide I posted to restore the phone. It should update it to Jellbean & correct any problems. Once you have completed the guide post back and I will give you further instructions on rooting your device if you need it done. & please let us know how it goes.

    Edit: Have you tested your phone on any other computers to make sure it wasn't an issue with your computer and not the phone?

    Here's another guide...
    http://www.thegeekcubes.com/how-to-update-samsung-galaxy-s3-gt-i900-with-jellybean-4-1-2/
    shocksl likes this.
  20. shocksl

    shocksl Active Member

    thanks for that... but that shows S3 and I have an S2??
  21. geofferey

    geofferey Well-Known Member

    My bad. Just use the first guide I posted.
    shocksl likes this.
  22. shocksl

    shocksl Active Member

    Thank you soo much for your help so far!! I have 'stocked' my phone. I must admit I actually love the new settings on my phone from the jellybean version.

    Unfortunately the 'USB tethering' is still greyed out and I cant check it. :(
  23. shocksl

    shocksl Active Member

    Just a quick update!! after a couple of restarts, it has finally started to work again! Thanks a billion guys for your help. 'stocking' the phone has deffinately done the trick!!!

    I love the new Jellybean firmware on it. Only downside is that when I put Youtube on for a song, then if I press the right handside button to take the screen off. the youtube song video would also stop playing.... but I am not complaining!

    it's great thanks!
    geofferey likes this.
  24. Screech

    Screech Well-Known Member Contributor

    [RANT]Why do people insist on using YouTube, a video service, for music or audio? It is such a waste of bandwidth if you don't plan on watching the video anyway. My wife does that too, I almost want to block YouTube from her computer, or make a redirect rule to a music service (Google Play, Pandora or something) from her computer.[/RANT]

    Not sure why people were suggesting a problem with bandwidth limits though, how would a bandwidth limit prevent accessing the files on the phone while connected to the PC with USB (it wouldn't). The problem clearly was that the phone was not recognizing the data connection to the PC, just seeing the power from it. Glad you got it sorted though.
  25. bevisj

    bevisj New Member

    I'm just a novice but here is a thought. I also have an S2 and had the same problem with things being grayed-out until I installed the new USB Driver update. Just do search on S2 USB Driver Updates. Use the official Samsung site with your specific model. Worked for me...

Share This Page