Galaxy S2- issues with microUSB/Charging/ConnectivitySupport


  1. Mindfields

    Mindfields New Member

    Hi,
    I've been using the Galaxy SII for about a couple of months, running flawlessly till date, but all of a sudden the microUSB connector has started giving some problems.

    1. The phone shows 'Charging' even when there is NO cable connected at ALL.

    2. The charging status goes on/off randomly without any connectivity.

    3. MTP starts to initialise at random.( Images attatched ) and the media scanner keeps popping up.

    4. Battery has no issues, charges properly when i actually connect a CHARGER.

    5. The phone does not switch off completely, a battery symbol, similar to the one that shows when charging, keeps recurring even with no charger connectivity.

    Is it something to do with the OS? or the hardware? Any kind of help would be deeply appreciated. Thank You.

    PS: I have attatched some of the screenshots.

    Attached Files:


    Advertisement
  2. mrao

    mrao Well-Known Member

    Wow....that's weird...it could probably have something to do with an app you installed recently....try uninstalling all 3rd party Apps and see if this problem persists...if its still there , try a factory reset...if its still there, then it's time to visit the service center
  3. Russell Ng

    Russell Ng Well-Known Member

    Try cleaning the USB port with a toothbrush carefully. I read that it helps.
    Mindfields likes this.
  4. mrao

    mrao Well-Known Member

    Yup..do the cleaning bit first...and see if the problem persists, before moving on to what I've recommended
  5. steslatt

    steslatt Well-Known Member

    There is another thread on here about this. Many other people have the same problem including me. Mainly I get the charging icon appearing when the phone is not even plugged in. I've found that cleaning the usb port or wiggling the usb plug gently seems to get rid of it.
    Its a faulty usb port, I'm just waiting for the problem to become worse then i'll be sending it back.
    Mindfields likes this.
  6. Yeah try this, i had exactly same issue yesterday. Clean contacts in usb port with bit of alcohol and brush. Also try pushing contacts up slighty so theres better connection with charger, be carefull though very fragile.
    Mindfields and sole07 like this.
  7. Mindfields

    Mindfields New Member

    Thanks a lot guys, i cleaned the USB port thoroughly with some comp. air and alcohol. Everything seems O.K. now, except for a weird problem with mass storage, Windows is unable to recognize the device whenever i try to connect it in storage mode.
    I've tried changing cables, re-installing drivers, even tried the same thing on other PCs with no luck whatsoever.
  8. Russell Ng

    Russell Ng Well-Known Member

    If problem persists, then bring it to your retailer and get it checked out. Apparently some of the posters mentioned they managed to get the service centers to replace that USB part or something like that and it works after that. Its probably a poorly design/manufactured part. Most likely manufactured since not everyone have the same problem.

    Cheers
  9. sluggo72

    sluggo72 New Member

    I did the toothbrush/compressed air thing and it worked like a charm on my girlfriend's s2.

    I was going to use the alcohol as a last ditch because I'm always very shy about putting ANY liquids into any electronics port.

    Thanks again!

Share This Page