Galaxy S2 Low on space & not enough storage error (SOLVED)Support


  1. cr4zyjay

    cr4zyjay Member

    Hi all,

    Firstly, I have checked on loads of forums and sites about this and no threads or solutions provided much insight on how to resolve this. Most thread owners just simply stated they had this problem but did not go into any detail as to what they have installed and the storage capacity numbers their phones are specifying to them. That's why i am seeking my answer on my own thread. Please, dont redirect me to some other thread or another website. Please, if you have some time and are willing - help me out. Thank you.

    I am currently with a big problem on my phone. I cannot install anything and I cannot update any apps.

    I randomly get the "low on space - phone storage space is getting low" notification, and I get an error message when i try to install a new app or update an exisiting one: error: not enough storage space

    Here is what I have done up to now to try and rectify the problem:

    - Root the phone and get Root App Delete to disable junk apps that come with the phone, and disabled every bit of non essential app needed, including themes and widgets that i dont use
    - Move every app i can to the SD card
    - Regularly check and clear cache on apps that store cache, such as chrome
    - Cleared out the phone logs such as calls received and made, sms

    What I am left with in terms of storage numbers are:

    - Internal storage: Total space = 1.97GB, Apps = 317MB, Available = 200MB
    - USB Storage: Total space = 11.50GB, Apps = 1.06GB, Pics and videos = 166MB, Audio = 256KB, Downloads = 3.44MB, Misc = 12.43GB, Available = 10.27GB
    - SD card: Total space = 59.46GB, Available = 47.01GB

    With those figures in mind, the only things I have installed on the phone that I have downloaded or are listed under the downloaded apps are (in order of size highest down to lowest):

    Chrome - 53.66MB
    Maps (stock google maps) - 39.61MB
    Facebook - 26.41MB
    Kies Air - 21.86MB
    Adobe Flash Player 11 - 12.87MB
    Voice command - 12.45MB
    Whatsapp - 11.73MB
    Google play music - 11.61MB
    Google play store - 11.14MB
    YouTube - 10.02MB
    Google play services - 8.59MB
    Gmail - 7.70MB
    eBay - 5.57MB
    Three (Three Network UK stock app to check on account balance) - 4.17MB
    PayPal - 3.87MB
    Flashlight - 2.53MB
    FPSE (playstation emulator app) - 2.35MB
    SuperSU (comes with root) - 2.31MB
    MX Player - 1.63MB
    Samsung push service - 1.57MB
    Screencast (used to capture video of whatever is happening on the phone, got it to make Gran Turismo replays on the phone with FPSE) - 1.56MB
    Bards tale - 860KB
    Memory Booster - 716KB
    FPSE PSX BIOS - 696KB
    Street view - 584KB
    Lloyds TSB (mobile banking app) - 323KB
    Root App Delete - 312KB
    08 Wizard (finds alternative phone numbers to high premium numbers) - 216KB
    Bightness level - 156KB
    0800 wizard (same as above) - 128KB
    Chrome to phone - 100KB

    I have added all that up and it comes to: 257.301, or rounded up to 257MB

    I dont get what the problem is here. I have 200MB of available internal storage, so installing or updating anything - if the app where to need to dump a small amount of data on the internel storage as it does with all apps, there is space there for that.

    I also have plenty of USB storage / internal phone flash storage i.e. the 16GB which on my phone is cheekly cut down to 11.5GB total space, and with this amount of free space I am still not able to install or update anything. I cannot even move an app back to the phone from the sd card - it says it cant because there is not enough storage.

    Please, can someone help me fix this? I am banging my head against a brick wall, well... im going to at this rate.

    Advertisement
  2. cr4zyjay

    cr4zyjay Member

    i've just noticed my available space on the applications list has gone down all of a sudden by 1MB. so i suspect something is just piling up and using space. but i have no idea what. i've checked each app to see if the clear cache button is white / allowed to be cleared but none are. im really lost here.
  3. kelis32

    kelis32 Well-Known Member

    Hello

    Are you running a custom ROM ?

    Have you tried clearing cache and dalvik cache from recovery ?
  4. cr4zyjay

    cr4zyjay Member

    Hi,

    Nope, standard stock rom. All I have done is rooted it with: Root_SuperSU.0.96.Only-signed, via the stock recovery. I also have the: Unroot_SuperUser-Busybox-Uninstaller-Update2-signed whenever i want or need to unroot

    No i havent cleared any cache of any sort from recovery, because i dont know what i am doing and dont want to break my phone. What cache is available to clear via recovery and where exactly do i look? what is dalvik cache?
  5. cr4zyjay

    cr4zyjay Member

    i went to recovery and all i could see related to cache or dalvik cache was clear partition cache. i did that and it was nearly instant. restarted the phone and checked the available space from downloaded apps list and its just 2MB i gained.
  6. kelis32

    kelis32 Well-Known Member


    Dalvik cache is where your app data is stored, as you are rooted im assuming you will have CWM recovery, to get into recovery turn off your phone and the powr up by holding home - power and volume up at the same time.

    You will then be presented with a menu, use the vol keys to scroll up and down and the power key to select.

    Scroll to wipe cache partition and select, you willbe taken to a second screen to confirm your selection

    Then scroll to advanced and select, scroll to wipe dalvik and select, then confirm on the next screen, once this has been done scroll to go back, select and then reboot system.


    There are multiple reasons as to why this occurs and sometimes its easier to bite the bullet and reflash your firmware to see if that fixes it
  7. cr4zyjay

    cr4zyjay Member

    i dont have CWM recovery. all ive got is a rooted phone with the root method i outlined above.

    in recovery i think it is the stock recovery (3e) / android system recovery.

    if i put CWM on there, is there a way to get it on there without a custom rom and without removing my stock recovery, i.e. can i have x2 recovery systems and access CWM via the stock recovery and then do what you said to do?

    in a nutshell, in the past i did have a custom rom, custom kernel, and custom recovery and i spent over 24 hours of pain on trying to get my phone back to stock in every aspect and i finally figured out how to do it. so now im back on my stock rom, stock kernel for my carrier and stock reovery. i dont want to break anything again!
  8. kelis32

    kelis32 Well-Known Member


    In short , no, not without doing things you obviously dont want to do, again i would suggest just reflashing your stock firmware to see if that fixes things.

    Given what you have said about your past troubles im sure there will be a level of corruption on your phone, flashing stock rom via ODIN is in no way as complex or "dangerous" as some of the things you have previously done
  9. Slug

    Slug Check six! Moderator

    I suspect that is exactly what the problem is. The figures don't tally:

    What then is using that missing 1.4GB? I have 824MB under Apps and still have 1.09GB free. I suspect some sort of corruption of the file system, the easiest solution for which is reflashing your firmware.
  10. cr4zyjay

    cr4zyjay Member

    thanks guys. i dont know if a reflash is the same thing as a factory reset / factory wipe via recovery but that's what i did.

    you're right i think it was corrupted, because when the phone came back on i found it was still rooted and root app delete was still installed, or had been reinstalled and it still had apps disabled in the recycler and apps uninstalled. super su was also reinstalled instantly by google play. so i enabled all the disabled apps in rootappdelete, did full unroot via supersu, again factory reset and this time i did it under the phone settings and chose to wipe the usb storage as well.

    this time when the phone came back it was not rooted and rootappdelete and supersu did try to install but thats just because of google backup doing its job i just stopped those 2 and left it to do the rest. i got root checker (free) and it confirmed root was not available.

    now my bare minimum apps are on there and i have rerooted in the same method and installed rootappdelete again and disabled the crap i dont want / need.

    now i have 283MB used space and 1.7GB free space on the internal memory with the same apps that i had before the first wipe, problem fixed!

    thanks again.
  11. kelis32

    kelis32 Well-Known Member


    Glad to see you got it sorted, you have done basically the same thing by factory resetting, the reflash just would have rebuilt the structure and preserved all your settings, accounts and apps but you would have lost root

    The factory reset though is a good option to get a nice clean phone if you dont mind adding back all those things, there are quite a few people who swear by this when upgrading etc as its basically just a clear out of all the crap you have accumulated over a period of time
  12. bradmccoy

    bradmccoy New Member

    I have the same problem. There is 15GB of internal memory, but 2GB is partitioned as "device memory" and 12 is partitioned as "USB storage".

    Only the device memory can be used for apps. And this fills up pretty quick. I only have around 200MB free and now apps and widgets aren't working properly and some app updates won't install.

    Is there some way to use more of the internal storage for "device memory"? Will I need to root the phone and repartion the drive?
  13. Slug

    Slug Check six! Moderator

    That's a limitation of the fixed-size fs partitioning used by Android 2.x. Even though the S2 has received updates to 4.1.x, this partitioning had to be retained to ensure backwards compatibility

    No, but with an external microSD installed you can move a lot of app data to that, which will free up space.

    No root needed for the above, and repartitioning will brick your phone unless you use a custom firmware and kernel that specifically support a new partition structure.
  14. YammyRiallgo

    YammyRiallgo New Member

    Hello guys, same problem here.

    My phone is not rooted and I have no SD card. I will try to make it as quick as possible - I just need to know what exactly should I do, how to do it I will find myself, I know there are plenty of websites and forum topics that will help me with that.

    So correct me if I'm wrong, but from what I understand, having non-rooted phone with no SD card there's no solution to my problem unless I buy a card or decide to root my phone?

    Or is the repartitioning you mentioned, a solution too and I just have to look it up (I'm not sure if "bricking my phone" is a good or bad thing, haha)?

    Thanks for your time and help guys!
  15. stu40

    stu40 New Member

    A simple way to free up storage space is by deleting all the log files in the device memory. Just dial *#9900# on your phone and select option 2 “Delete dumpstate/logcat” in the prompted menu. It's not necessary to root your phone either. I restored 1.4 gig of space after doing this.
  16. YammyRiallgo

    YammyRiallgo New Member

  17. Gameon

    Gameon New Member

  18. texdave

    texdave New Member

    Stu40....that was a priceless piece of advice. I have had to reset my Tab 2 multiple times to beat this damn error.
  19. by_tor

    by_tor Member

  20. PedroUK

    PedroUK Member

    Thx Stu40. I recovered 400mb. Great stuff!
  21. koala_

    koala_ New Member

    This is working!
  22. danpriceuk

    danpriceuk New Member

  23. Raptor_Jesus

    Raptor_Jesus Well-Known Member

    I like very much the simplicity of the solution!...

    Just that when I try I get the message: USSD code running... and then the error: Connection problem or invalid MMI code! :(
  24. gokul_roboticist

    gokul_roboticist New Member

  25. veerapathiran_s

    veerapathiran_s New Member

Share This Page