Galaxy S2 Sees 5ghz but won't connect.Support


Last Updated: 2013-02-01 12:27:17
  1. Esgargoth

    Esgargoth New Member

    Hey all,

    Have a Galaxy S2. My only major grumble witht he phone is that it simply won't connect for 5ghz network anywhere.
    It can clearly see the networks (tested on three different routers at different locations) but just says, saved secured and that's the end of it.

    What i have tried.

    Changed the 5ghz channels on the router, using each channel and trying to connect, tried 20/40 mhz. Changed the security type and even left it open to try.. still nothing.
    Tried selecting only 5ghz channel on phone but again it can see it but says NO.

    The only thing i have not tried is using custom firmware on routers to try the different region channels.
    I can't do this as i spent a fortune on my home router and am simply not allowed to break it before it's a year old.
    As for the other two, i don't own them so that is out of the question too.

    Any other ideas?

    Edit: Should point out i'm in the UK for regional purposes.

    Advertisement
  2. jaliy

    jaliy Well-Known Member

    galaxy s2 does not have dual band adaptor
    only 2.4ghz band will work
  3. upd103

    upd103 Active Member

    I agree with Jaliy. If you're even seeing 5GHz networks, you ended up with a much nicer phone than I have. I just checked my 5GHz network again cause I thought I missed something.......

    Nope. Still can't see it.
  4. Slug

    Slug Check six! Moderator

    The GT-i9100 definitely supports 2.4GHz and 5GHz 802.11n wifi. The fact that the OP is able to select "only 5GHz channel on phone" is evidence of that. However iirc it only supports a subset of the large number of 5GHz channels available - 36-48 I think.
  5. ChrisNI

    ChrisNI New Member

    I have the same problem as the original poster, although I was originally able to connect to my 5ghz network but can't any more.

    Tried clearing the cache as well as everything else mentioned above but to no avail.

    Strange ........................:confused:
  6. Esgargoth

    Esgargoth New Member

    Well still on this, just downgraded the phone to gingerbread and still the same problem. I think somewhere along the line something has gubbed the 5ghz side of things.
    Also i can no longer upgrade to ICS as it seems i downloaded a test version of ginerbread.
    :S omgwtfbbq - BOOM (Lesson to be learned. do not fudge about with op systems)
  7. USA1fan

    USA1fan Member

    I know I'm reviving an old post, but I'm seeing this same issue with my SGH-i777 (AT&T) S2. It sees most 5Ghz SSIDs, and even identifies the type of security in use, prompting me for the password, but then fails to connect every time.

    I've verified what it sees using inSSIDer too. I have two separate routers working (separated groups of wireless devices), both with N support. One router is operating on Channel 36, the other on 149 (according to inSSIDer on the Sammy), both with WPA2 + WPS security.

    The phone is running the latest official AT&T provided ICS firmware (4.0.4), but this issue has been there since I bought this phone in early October, when it was still running Gingerbread. I'm stumped as to how it could not only see the networks (meaning, correct channels available), identify the security (some sort of handshaking going on, right?), and yet still fail to connect in every instance, even without security enabled on the routers.

    Nobody has come up with any ideas or solutions yet? If so, it'd be great to hear about it. I will, of course, post back, if I ever figure this out.

Share This Page