Galaxy S2 Skyrocket USB Drivers


  1. 152515

    152515 Member

    I've been trying for days to get the usb drivers working, so I can eventually root my phone. However, I have had no luck. I apologize for my lack of grammar, but im just going to start listing things that might be relevant to my problem.

    I have Windows 7 64 bit
    I have a Galaxy S2 Skyrocket
    Plugging the cable into my phone and PC (USB) does nothing except charge.
    My phone has "USB debugging" enabled.
    My device shows up under "other devices" in device manager, but it says "not working, needs driver update (or something to that effect).
    Can't find drivers when it searches.
    Downloaded drivers manually, and get the error "Samsung mobile USB composite device" failed to install.
    Tried pointing driver update to the folder named "usb_drivers" that was created by downloading something from google via the SDK manager.


    I'm lost. Any help?

    Advertisement
    :
  2. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums!

    You need Samsung drivers, and the right one on top of that.

    Moved your question to the Skyrocket rooting forum so you'll get the correct information for this. :)
  3. 152515

    152515 Member

    I figured that not enough people frequent this particular subforum. I also downloaded 2 versions of the samsung drivers, and have the same "samsung mobile usb composite device" failed to install error. These however are only accessible but clicking, from device manager, "update driver", then browse my computer, then show a list of all drivers, then expanding the usb drivers.
  4. EarlyMon

    EarlyMon The PearlyMon Moderator

  5. 152515

    152515 Member

    I get a "Samsung USB drivers for mobile phones is already installed on your computer, do you want to continue anyway"?

    I continued, and get the same errors
  6. sdrawkcab25

    sdrawkcab25 Guides Guide

    I had a similar problem getting the drivers to install for the galaxy nexus and after hours of frustration a simple computer reboot solved the problem.
  7. karandpr

    karandpr Well-Known Member

    Did you try installing/reinstalling KIES .?
    Also
    Try sdrawwkcab25's suggestion .

    I had similar issue a year ago with my galaxy 551
    What worked for me is, reinstalling windows :eek: which really is annoying thing to do (please attempt it as a last resort ) ...
  8. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    At the beginning your computer's operating system was seeing the drivers, thus the "already installed" message, but the actual path to that file was not being seen.

    Now that you've done a manual attempt, portions of the second package are likely being seen by the system as conflicts.

    I'd start over by doing a search for those drivers by name and renaming them with a ".bak" file extension and moving them to a new special folder away from the hierarchy where they normally reside. If kies is installed, uninstall it.

    Then a reboot of the computer, and of course the Skyrocket.

    If your USB debugging was checked, uncheck it.

    Reinstall kies. You may see something like, "PC Suite is needed," just ignore that. The drivers should be installed now (per kies).

    Some users have success by going to http://www.samsung.com/us/support/downloads/SGH-T989ZKBTMB and entering your device model for the drivers but I'll bet that is where you found your drivers and had issues.
  9. 152515

    152515 Member

    Kies never recognized the device- just "please connect a device", or something to that effect.

    I have the drivers in a .bak from the Google thing installed by the SDK manager. I dont know if that's the same.

    I can't do a search for the drivers, I don't know how. I have search indexing disabled.

    Trying to find them manually now.

  10. buchog

    buchog New Member


    Mass Storage


    1. Connect your Samsung Galaxy S II to your PC or MAC using the supplied USB cable.


    2. A USB icon will appear in the notification area. (IN YOUR PHONE SCREEN)
    3. Pull down the notification bar and touch USB Connected.
    4. You will now see a USB Connected screen. Andy will be green and his left arm will appear as a USB connector.


    1. Touch Connect USB Storage.

    1. After a few seconds, the message on the screen will change to USB Storage In Use and Andy will turn orange.

    1. You should now have Removable Disk prompts on your Windows PC or MAC and can begin transferring content between the device and the computer.
    Note: Depending on whether you have a microSD​
  11. bigx5murf

    bigx5murf Well-Known Member

    I had this same problem, it was conflict between usb drivers from my old android (xperia x10). I eventually gave up, and just reformatted. Android drivers installed properly, and worked upon first boot.
  12. gmich83

    gmich83 New Member

    The person said that the PC is not recognizing the driver for the device. Your solution won't work. If the PC gives an error that the USB driver is not recognized, their phone won't have the USB icon when its connected.
Loading...

Share This Page