Galaxy S2 wifi problemSupport


Last Updated: 2012-06-28 08:40:24
  1. seagrid

    seagrid Member

    Hi, i have been using galaxy s2 for a month now. it's great

    I downloaded many apps using my home wifi, it usually works fine, but today, the wifi is connected, and the signal bar is excellent. But i cannot access any internet
    I thought it was the wifi router itself, but my laptop can connect and browse using the same wifi. so it is not the router's problem.

    Please, can anyone help me?? Does anybody has the same experience??

    Advertisement
  2. Sixel

    Sixel Well-Known Member

    It is the router. My friend has the same problem. She says that her router "locked her gs2 out" but I do not know what she did to fix it.
  3. Slug

    Slug Check six! Moderator

    The first thing to try is rebooting the handset.
  4. TobesEtc

    TobesEtc Well-Known Member

    I get a similar problem for time to time. l turn router and phone off/on then it works ok. No idea what causes it.

    BT Home Hub 3 on Infinity. SGS2.
  5. seagrid

    seagrid Member

    by "router" u must mean the router that gives wi-fi right? cause i have a modem which takes the internet from the provider and a router which routes the wi-fi (duh..)
    and i have restarted both of them, i even unplugged the power to the router and pull out the batter out of my galaxy s2 but it still won't work.. please help me :(
  6. Sixel

    Sixel Well-Known Member

    It might be that your router blocked any other connections like your phone. Contact your ISP see if that helps.
  7. Hawker

    Hawker Well-Known Member

    A few things to try:

    1. Verify that wifi is actually connected, and its not still trying to obtain an ip address.
    2. drag down the notification bar and turn wifi off, wait until the icon becomes disabled, then turn it back on again.
    3. Check your authentication type on the router. If its WPA/WPA2 then try setting it to WEP instead. I'm on WPA/WPA2 at home and works fine, but i can only get it to browse at work on WEP.
  8. Telengo

    Telengo Member

    What is the actually status of your wi-fi? Mine did this not long after purchasing my S2. It was bascially sat at "obtaining IP address" but still displays signal strength as it has actually connected at this point.

    This was after it getting no connection at all, and even adding a static IP address would not work. No idea why it suddenly started to do this as it worked for at least a week. I replaced my rubbish router and all my problems disappeared (the router was replaced for other issues not just this), but it was strange how both my iMac and netbook never had any problems with connection just the phone.
  9. rikki_sun

    rikki_sun Active Member

    i been having the same problem ever since i got my S2. it happens everyday.if i leave my phone on the desk untouched for about 10 mins , the wifi will drop(although the signal bar is full shows its connected) but actually the wifi wont work at all. i have to turn wifi of and on to get it back to work.then after few mins it happens again. until..forever..

    ive been told its the routers problem but couldnt do anything . im going to live in my gf's house next week for abt a week,i will test it with her wifi ,so see if it is really my router's problem or the Sii itself. and will update in this thread.
  10. houdini2005

    houdini2005 Active Member

    go into the router settings and change the wifi channel (had to change my router from channel 6 to 1)
  11. rikki_sun

    rikki_sun Active Member

    hey man

    i just had a look into my router,i have 13 Channels in Total! and the router itself

    sets it to channel 11 by auto scan(recommanded)

    how many channels do u have and how did u determine which channel is the right one for u >?!
  12. houdini2005

    houdini2005 Active Member

    i've got 13, i had to use trial & error for each channel (my main prob was market would'nt connect).
  13. Hawker

    Hawker Well-Known Member

    If you are rooted, use rootexplorer to edit build.prop file (/system/build.prop) and remove the code as shown below

    Code:
    # WiFi Tweaks and mobile data
    net.tcp.buffersize.default=4096,87380,110208,4096, 16384,110208
    net.tcp.buffersize.wifi=4095,87380,110208,4096,163 84,110208
    net.tcp.buffersize.umts=4094,87380,110208,4096,163 84,110208
    net.tcp.buffersize.edge=4093,26280,35040,4096,1638 4,35040
    net.tcp.buffersize.gprs=4092,8760,11680,4096,8760, 11680
    net.tcp.buffersize.hspa=4092,87380,262144,4096,163 84,11020
    net.eth0.dns2=10.32.193.11

    Then reboot and wipe dalvik cache and cache partition
  14. rikki_sun

    rikki_sun Active Member

    thx but im not rooted. i would like it to remain at factory state
  15. rikki_sun

    rikki_sun Active Member

    omg .. that would take me a day to do so..
  16. matttye

    matttye Well-Known Member

    99% of my wireless connectivity problems have been static IP conflicts.

    It's worth checking that your phone isn't attempting to use the same IP as another device on your network.
  17. Slug

    Slug Check six! Moderator

    If you're in the UK/EU you'll have thirteen channels to choose from.

    Install Wifi Analyser from the Market and it will show all available wireless networks within range, along with their signal strength, channel and other info. You can use this to work out which is the least-congested channel.

    Channels overlap somewhat and equipment accounts for this, so a weak signal on an adjacent channel won't necessarily affect your connection.
  18. seagrid

    seagrid Member

    i could access internet but i need to plug out and plug in the power from my modem like everyday.. still didn't solve the problem

    no, i didn't root my phone

    i have been turning on and off my wi fi but it just won't work

    yes, it is already connected, not "obtaining ip address"

    i have 13 channel, i have tried each of every channel and nothing changes, i still could not connect to internet using my home wi fi with galaxy s2

    oh, and i have modes which mode should i pick?
    11b only
    11g only
    11n only
    11bg mixed
    11bgn mixed

    and what each of them means??
  19. SebaKL

    SebaKL Well-Known Member

    My wifi works very well. I can surf, skype, you name it. I can load Market, view all the apps, BUT the only one thing I can't do over WIFI is download them. For some reason, I can download them without problem using 3G/H but the moment I'm home and try to use WIFI, I get the on going progress bar (downloading) and it just does nothing for hours......
    Any clues ?

    regards
    Sebastian
  20. vishesh26

    vishesh26 New Member

    hi, i have also getting this wifi problem two days bt my problem seems 2 be completely different. my wifi automatically turns off after a 5 sec scan when ever i try turning it on, without detecting any signals. sometimes the wifi signs go LIGHT GREEN COLOR and the setting options on my phone freezes and then i hav to remove battery to turn it on...hav tried updating the firmware restored the phone so many times but non of that helped.....plz help me out...plz....
  21. PhilG1903

    PhilG1903 New Member

    Not sure if it will help your problem or not, but I had a lot of trouble getting my SGS2 to connect to my home wifi. I tried so many different things stated in forums like this but couldn't seem to get them working.

    Today I was trying again and I playing around with some settings and noticed
    MAC address control listed in my wireless settings, which for noobs like me lets you set up a client list allow, deny or disable access to the wireless network.
    I remembered when I first got my S2 and looking through different pages like settings etc it had a MAC address. So I entered this into my router settings checked allow and saved settings. I have had no probs since. It automatically connects each time I'm in range and have phone wifi turned on.

    I have a Belkin Wireless N modem/router

    Hope this helps people still having trouble
  22. samdobbs

    samdobbs New Member

    I too am having this issue. Some digging showed:

    1) My SGS2 is connected to Wifi and to 4G (or Edge) when both are available. This is unlike the SGS1 which turns off carrier data when wifi is on (I couldnt find a setting to enable this toggling behavior on the SGS2)

    2) When switching from Wifi to 4G (or back, e.g. when one is out of range temporarily) the SGS2 routing tables seem to get messed up. AndroidStatus shows an IP address from the Wifi but the interface is the data network.

    Can anyone else help check this and note if you are seeing the same behavior? And have any solutions?!

    Sam
  23. Russell Ng

    Russell Ng Well-Known Member

    4G? Are you using the International Version. That doesn't have 4G.

    That said, with wifi on, the data line is off (3G icon at the notification bar is not shown).
  24. Mike Hawk

    Mike Hawk Member

    Im having probs with my GS2 as well.. cannot connect to any wifi public router no matter how strong the signal.. it just keeps saying the following things and repeats infinitely -
    1 -obtaining IP address from "insert wifi name here"
    2 - Disconnected

    This happens in an infinite loop, just going on forever. Im on a military base but we have a crappy wifi network and I used to be able to get on the wifi router no problem with this phone, but for the last 2 weeks it just wont connect. Ive been looking in this forum for a fix but so far have found none, I cant do static IP either (I dont think).
  25. Russell Ng

    Russell Ng Well-Known Member

    The phone can used both static IP and automatic. You can place it on static for example at work or home where you have a fixed IP, and then change it to automatic when you connect to public. You won't lose the settings for the fixed IP. Its still remembered.

    That said, I can't tell you why it won't connect since there could be so many potential issued, and not just due to the phone. It could be the wifi being protected, to having fixed IP or the phone must be set on automatic IP.

    Sorry

Share This Page