Galaxy S3 crashing when copying text to clipboardSupport


Last Updated:

  1. metnix1

    metnix1 Member


    Advertisement
  2. metnix1

    metnix1 Member

  3. alqasimk

    alqasimk New Member

    I joined this community just to say "thank you" !
    This is they only place I found a solution for this annoying issue after days of searching..
    dr3do likes this.
  4. barryl85

    barryl85 Well-Known Member

    Well this has just started happening to me, dont copy paste enough to warrant a factory reset and i sure as hell am not going to root my phone just to use the work around!

    What else can i do?
  5. barryl85

    barryl85 Well-Known Member

    This issue is starting to do my head in.
  6. FzeroX

    FzeroX New Member

    Hi,

    I am a new user android phone. I have just recently purchased my S3. I just rooted it today. And am also having the same issue (thus brought me here) with crashing when copying text to clipboard.

    I have attempted the steps listed above.

    I was able to wipe the cache, downloaded root explorer and deleted items in /data/clipboard/

    However I do not see advanved. when i rebooted. Am I missing something?

    Please help! Thanks!
  7. exwifeusesiphone

    exwifeusesiphone Well-Known Member

    Guys - I just got this for the first time the other day and there is an easier fix but you MUST be rooted. You do NOT need CWM.

    You need RootExplorer.

    Go to /data/clipboard and delete everything in the clipboard directory as mentioned above.

    Then, go to Settings/Application Management/All, scroll down until you find TestService and clear its data.

    Reboot. If you do not reboot copy/paste will not function. I do not think you need to fix permissions, and I was able to apply the fix without that step (which is the one that really needs CWM).

    If you are not rooted, you are screwed and have to do a factory reset. This is a major bug and I hope people are reporting it. This is a pretty unforgivable bug.

    You'll know the bug is back if you start getting "TestService" stopped working. messages and you'll have to do it again. I've noticed using S-Voice somehow can bring it on - I guess S-Voice uses the Clipboard for something. Probably has to do with corrupted writes to the directory, there's nothing we can do...
    ryance, TwoMails and olssim like this.
  8. FzeroX

    FzeroX New Member

    I have tried that but I do not see test service. I used to see test service stopped working, but now I don't see it anywhere. I can't even find it in apps.
  9. exwifeusesiphone

    exwifeusesiphone Well-Known Member

    You won't see it in the App Drawer. You need to do menu key/Settings/Application Manager then touch "All" on the right side and scroll down to find it.
  10. herby247

    herby247 New Member

    After fixing this problem with the amazing help from the guys on here and rooting my phone, I now have the above guide bookmarked until Samsung get off their arse and issue a fix for their phone!
    Upon fixing it myself I emailed Samsung UK support and I received a reply back saying its a known issue and there working on a fix and to factory reset my phone to fix it meanwhile. (Obviously I didn't say I was rooted etc) but I wanted to hear their reply.
    Then 3 days later I get another support email telling me the previous info I was giving was wrong and that I was to book my phone into a Samsung service centre to fix it......oh how I laughed!!
    Well my advice is report the issue but unless your willing to root, which you should do anyway, then follow the above guide, I am afraid factory reset is currently the only fix!
  11. aznguyen316

    aznguyen316 Well-Known Member

    Thanks bookmarking since I get my s3 soon.

    Is the root method like a permanent fix? Since it seems like the crashing can come back even after restore.
  12. herby247

    herby247 New Member

    Until Samsung release a fix, a factory reset is the only way you can get the copy and paste back.

    To be able to do this guide you MUST be rooted!!...............

    1. boot recovery (CWM) > advanced > wipe cache
    2. reboot phone > Root Explorer > delete /data/clipbord/*
    3. reboot recovery again > advanved > fix permissions
    4. reboot phone > it's fine

    Your phone NEEDS to be rooted for super user permissions on the phone and to use apps like root explorer, the good thing about this is its a 2 second fix once rooted if it happens again, and you dont loose all the settings you had , having the phone the way you want it as you dont need to do a factory reset!!
  13. andrei2112

    andrei2112 Well-Known Member

    same problem here, i do FR but after some days the problem is back again ,unrooted s3.ANNOING.
  14. psybab

    psybab Well-Known Member

    Had to do a factory reset for this a few days ago. Sad to hear that it will likely come back. I thought it had to do with me deleting bloatware (like YP mobile and whatnot), but I guess this is a full-on problem for everyone.
  15. barryl85

    barryl85 Well-Known Member

    Does a factory reset delete all data?
  16. ardyer

    ardyer Well-Known Member

    I had it happen last week, after about a month of use (stock, unrooted). It happened right after I downloaded the Gallery Lock app reviewed over on Android Central last week. After looking at the errors, my best guess is that something is corrupting the clipboard. Like other, the factory reset fixed it, but I'm disappointed to hear that it could come back.
  17. hvrc

    hvrc Well-Known Member

    Been happening here too guy's. I've emailed Samsung support, awaiting a reply because a factory reset, on a star device?! After I finally transferred all my files and apps?! I don't want to root yet just to get used to this phone first. But looks like that might be the only way depending on how this works out if it kept it up after a factory reset.

    Thanks for all the awesome help guys!
  18. barryl85

    barryl85 Well-Known Member

  19. Krunk83

    Krunk83 Well-Known Member

    Yes. Except what's on your external Sd card. This happened to me last week and I had to restore my phone. Pain in the ass but it worked.
    barryl85 likes this.
  20. Krunk83

    Krunk83 Well-Known Member

    Really? Setting up your phone doesn't take that long. Just reinstall your apps from google play on a desktop.
  21. lancer0123

    lancer0123 New Member

    When I reboot in recovery mode "advanced" is not one of the options. Where am I going wrong ?
  22. dr3do

    dr3do Member

    If you boot into recovery mode, it looks like which (left or right) one?

    [​IMG]
  23. Diman

    Diman New Member

    спасибо. мне помогло. теперь текст копируется и ничего не вылетает.
    dr3do likes this.
  24. laptopquestion

    laptopquestion Well-Known Member

    Easier if you post in English, since you can apparently read it :D

    Google Translate to the rescue, sort of......
    Thank you. helped me. Now the text is copied and do not fly
    dr3do likes this.
  25. HolyGrail

    HolyGrail Well-Known Member

    Left

Share This Page