1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Galaxy S3 USB connection problemsSupport


  1. fribourg

    fribourg Member

    I've been trying to connect my SG3 to my laptop for 3 weeks now with no success, since I bought the phone. Had this problem with my SG2 as well.

    I read many people are having problems with connecting Samsung Galaxy phones to KIES, and that overall the KIES is just a pain, I wonder why SAMSUNG doesn't find a fix for these things.

    Not only I can't connect my SG3 to KIES but the bigger problem is that I cannot connect it to my laptop at all. I've tried to install - installed/uninstalled the USB drivers several times - every single time failing.

    When I try to connect the phone to KIES via USB or WiFi it just keeps on loading the "Connecting" pictogram.

    Basically I cannot get any of my photos/videos out of the phone, cannot sync and everything else.

    Any help would be much appreciated.

    I am running Windows 7 64 bit.

    Thanks in advance

    Advertisement
    :
  2. breezex

    breezex Well-Known Member

    With your GS3 attached to your computer via USB is it listed in the "Computer" screen along with all of your hard-drives? If not, on the GS3 pull down the notification bar and touch the USB entry. Set USB to MTP. If that does not work try PTP.

    I have Win 7 on my computer and the GS3 connects.
    Macleather likes this.
  3. bearballz

    bearballz Well-Known Member



    I have Win7 as well and works just fine. I just plug it in and a box pops up with the Phone memory or SD card memory folders.

    -When you plug the phone into your computer a 3 prong symbol on the top left of your phone screen should appear.

    -Go into the drop down menu and it should say "Connected as a media device".

    -Tap on that and make sure the "Media Device" box is checked.

    -Detach the cable then re-attach it and it should be OK. The media files box should pop up on your computer. It should have a bunch of options including "explore files". Click on explore files and another box should show up with 2 folders, one for the phone another for the SD card if you have one in your phone.

    If that doesn't work, detach the sync cable and restart your phone and attach the cable again and see if that works.

    Also check your usb connection. Could be one of your usb ports is out of whack. Try a different port and see what happens. Also could be your sync cable as well.
  4. fribourg

    fribourg Member

    Thank you for your replies, unfortunately nothing I've tried has worked. I know from my SG2 once I plugged in the phone on any of my USB ports on the laptop the driver would be installed for the USB, for the SG3 it keeps on failing installing the driver which I guess makes it normal not to function correctly.

    I downloaded the USB driver from samsung.com installed it but it still does not work. Switched usb ports, tried all possible ways nothing works unfortunately.
  5. Darkax

    Darkax Well-Known Member

    Maybe you have problem at your pc? Since you could not connect s2 as well?
  6. fribourg

    fribourg Member

    With SG2 I did not have any kind of problem. I have stated once I was plugging in the SG2 the driver installation would have started. In the SG3 case it does start but I keep getting the failed message.

    Is there anything else I could try to get the USB device working?

    As far as I can see the USB ports are functioning correctly as all other devices I connect to them work in perfect condition, and the drivers also seem fine.

    I would really appreciate if somebody could help me with this issue
  7. Lato9905

    Lato9905 Well-Known Member

    This is what worked for me....unplug your phone from the computer. Start Kies and let it do its thing for a moment or two. When its finally at the "home screen" where it says no device is connected then try plugging in the phone. Dont start the program with the phone already connected.

    That was the issue I was having anyway.
  8. khanguyen519

    khanguyen519 New Member

    Fribourg, I had the same problem and i think this is your solution. I think the problem may come from a bad SD card(though i think your sd card is fine) after files have been written so much--my galaxy S3 told me to reformat it because it was corrupted.
    What i did was i turned off USB Debugging Mode and i turned it back on. I also went to reinstall my Samsung USB drivers to my laptop. after that, all is well. What i suggest now is copy all your data from your SD card to your desktop and format your SD card from your phone. transfer your files back after that. hope this helps.

    edit: ATT samsung drivers
    TMO samsung drivers
    #first post.
  9. Rolo42

    Rolo42 Well-Known Member

    I would uninstall all Samsung drivers/Kies, reboot, and then install the current SIII drivers only (not Kies); your SII drivers may be interfering with the SIII drivers/connection.

    With Kies, my SIII would connect but my wife's wouldn't; after I installed the Samsung drivers only, they both worked.

    An uninstaller is probably a good idea.
  10. Szadzik

    Szadzik Well-Known Member

    Install drivers manually via Device Manager.
  11. fribourg

    fribourg Member

    I would try the method you mentioned but I dont know how I could posibly back up my SD card/copy the files from my sd card to my desktop since my phone wont connect to my laptop at all. The only way I can connect my s3 to my laptop is using KiesAir and a browser going to the IP the phone specifies.

    Thanks
  12. Gladiator2002

    Gladiator2002 Member

    You would have to first turn your phone off and take the SD card out, Or go into settings and choose the dismount SD card option, and then remove the card. Once you have done that put the SD card into the computer by SD Card slot or USB Dongle. Then follow the above Steps.
  13. fribourg

    fribourg Member

    So you are referring to the MicroSD card not the SD card/Storage. It didn't make sense for me. I have taken it out completely and still cannot connect my S3 to my laptop. Tried all possible ways I could think of and read about here on the forum. There is no way to successfully install the drivers on my laptop.

    I got it working on my desktop computer. This means there might be some issue with my laptop? Anything else works perfectly fine on these usb ports...
  14. pestalilla

    pestalilla New Member

    Had the same issue with my wife and daughter's SG3s. My problem was that I was using the USB cord from the car charger, not the wall charger. Don't know why, but that did it for me.
  15. Joseph11

    Joseph11 New Member

    exact same problem i have wit no solution
  16. rkab

    rkab Member

    I have the exact same problem. I have SGHT999V with Mobilicity (Canada). Same problem. Installed drivers , updated the Windows XP drives on desktop and laptop to no avail. Called Samsung , spoke with two people that kept contradicting themselves : one told me to get Kies , the other one didn't . They clearly had no clue what they are talking about. The only way I put files on is through kies air which is pretty inconvenient.
  17. eshaham

    eshaham New Member

    Hi
    Since I bought my phone and faced the same and tried to get some help from the forums without any luck, I tried on my own some investigation on the issue.

    Heres what I found I believe is the reason as my test proved it already :)

    S3 MTP level communication uses for connectivity now for USB cable. Its both for MTP and PTP for camera.

    In my case, first I cleared up the cache from the recovery mode in the Phone. (See other threads how to do that) to bring up my USB Icon in the phone stating its trying to setup the connection.
    But it never does.....

    Its because the security policy in the phone settings restricts it. You can find this under Settings - Security and Lock screen - Device Administrator.

    If any app ( for myself it was ActiveSync app which needs this access to get setup ) was sitting there. I removed this. Voila !! It allowed the access immediately. Both for MTP and PTP.

    as soon as I setup the app, the problem reoccurred. However, I confirmed that DME cllient does not do that as it does not need this Device admin right.

    This also prevented my WiFi Direct feature to transfer files to other S3 devices. When I removed this constraint, both my USB problem and WiFI direct issues also got solved .

    So, basically the factory reset will work on all phones as the phone is fresh with the ROM only. But if you use any app with "Device Admin" thingy as Mandatory requirement, it will restrict the USB connection. Hope this Helps Ya all .:p
    Winglight7 likes this.
  18. DaniDS3

    DaniDS3 New Member

    I plugged in my USB... Media device driver failed, so I clicked on the usb connections from the drop down window on my phone (S3), and chose (PTP) rather then (MTP), and the driver installed and worked. Hope this helps...

    PS,

    I have Win 7 home premium.
  19. chris338

    chris338 New Member

    I tried to connect with a 3rd party usb cable. No dice. This morning, I changed USB ports and used the cable that came with the Samsung Galaxy S3 wall charger. Windows 7 64 bit installed it no problem.
  20. griffly16

    griffly16 New Member

    Winglight7 and pooksmoher like this.
  21. daviesp007

    daviesp007 New Member

    I got my S3 from AT&T in October 2012, the USB cable that came with it allows the phone to charge when connected to a PC, but does not allow data transfer. Tried another cable, and it works fine.
    Winglight7 likes this.
  22. jerky101

    jerky101 New Member

    I didn't see it mentioned here, and this may not apply to you, but if I have my phone locked (pattern, etc) it will not connect to my PC. Once I unlock it then it works. Hope that helps.
  23. mrpnut

    mrpnut THE WORLD IS YOURS Guide

    Yeah sometimes the usb cord could be defective just use another samsung cord or a unversial usb cord.
  24. Mikishots

    Mikishots New Member


    You stated in your original post "Had this problem with my SG2 as well". Not sure what you mean - did you or did you not have a connection problem with the other phone as well? It may be the computer.
  25. batosai_vash

    batosai_vash New Member

    i have same problem with that. i have 2 s3 (peble blue and red) and 1 s2 white.
    its just the s3 blue that my pc wont detect the phone. its just keep on charging. any1 has same problem and know's how to fix it? thanks in advance
Loading...

Share This Page