Galaxy S3 wifi connection problemsSupport


  1. AIRTyke

    AIRTyke Member

    Hi,
    I have a SGS3, it has been working fine with home wifi for several weeks but all of a sudden it won't connect to my BT home hub. When I try to connect it says "obtaining IP address ..." then briefly says "connected, stored" but immediately returns to "obtaining IP address ..." I then get an Attention message saying "network disabled, poor connection".

    I know I have a healthy wifi router as I have several iPhones happily connected to it, as was this SGS3 for weeks, until it suddenly started this behaviour.

    The only thing that changed was I signed up for BTFon which is a free wifi subscription in the UK where your router is firmware upgraded to become a 'hotpsot' for other users. I am wondering if this change somehow affected the SGS3 although it doesn't appear to bother the iPhone users (much to their smug satisfaction).

    I have now deactivated BTFon but I am still having the same problems.

    I have rebooted everything several times - both router and SGS3. I have not updated any s/w on the SGS3 lately. I am running OS4.0.4.

    As I live in a poor GPRS coverage area this has made my SGS3 unusable so any help in cracking this problem would be very much appreciated.

    Many thanks in advance.

    Advertisement
    :
  2. CDPlant

    CDPlant Let's dooo-ooo it Guide

    I'm not sure if this will help, but you could try to 'forget' the router and re connect to it.
    If you go to settings > wifi and press the router name, there is an option to 'forget' the connection, and then you can try entering the SSID of the router again and seeing if that helps at all. For some strange reason mine worked with a similar problem, but i'm not really sure why!
  3. AIRTyke

    AIRTyke Member

    Thanks for the tip but unfortunately it didn't work, I got the same response :-/
  4. AIRTyke

    AIRTyke Member

    This is driving me crazy. 4 years an iPhone user, I finally make the switch to Android and then this happens. Am I alone with this issue? I can't see any other settings on the S3 I can try so any suggestions very much welcomed.
  5. mikes1

    mikes1 Well-Known Member

    Yeah it happens to me. I usually just hit the restart button. It may be a bit of a hassle but it works. And the restart is so quick on this phone that it barely bothers me. It seems to do this to me at work when I am going in and out of wifi areas. It's like it gets confused and can't find the router
  6. Loz22

    Loz22 New Member

    Seems that it may be a compatibility issue since the router has received a firmware update- are you able to connect to any other routers?
  7. AIRTyke

    AIRTyke Member

    mikes1 - restart doesn't work I'm afraid.

    Loz22 - yes it connects to other routers no problem, just not the one I need it to at home!
  8. cary328is

    cary328is Well-Known Member

    Try the wifi power save mode: off trick. Dial *#0011# > menu > wifi > power save mode= off.
  9. Shotgun84

    Shotgun84 Well-Known Member

    It might be worth changing the channel your router uses. I used to have the same problem with my old gs2 until I changed the channel from 7 to 11. I haven't had any problems since with either the s2 or s3.
  10. AIRTyke

    AIRTyke Member

    Nope afraid not. Tried wifi power save mode OFF and also changed router channels, neither work. Thanks anyway.
  11. cntryby

    cntryby Active Member

    I wish wifi was my only prob.:(
  12. rorygach

    rorygach New Member

    Had the same problem with my s3 when I came back from holiday, it having
    previously worked ok.
    Tried everything above but success came when making s3 "forget " the router,turn off S3 WiFi, rebooting the router before turning the S3 Wi Fi back on and hey presto. You may have to "add" your router again on the s3, I didn't have to though
    Hope it works out
  13. oldtimer1955

    oldtimer1955 New Member

    I just posted this in another similar thread:

  14. Clara A

    Clara A New Member

    I had exactly the same issue after I used BT Fon. I've just restored my system to the day before I used it and the problem is now resolved. I had a load of other security issues after the restore and have now got my system secure again.
    have you tried this?
  15. ldivinag

    ldivinag Well-Known Member

    If search for my posts here I had an issue with my S3 and a Linksys router.

    When I connect to it I could NOT get any speeds greater than 1Mpbs... nothing.

    I had other wifi devices that connects just fine and get the 8+ Mbps connect speeds. Including the phone the S3 replaced a dell streak.

    So one might assume its the phone. Right? Went back to the ATT store to swap another phone.

    Sure enough... same issue. So I start thinking and afterasking a few forums including this one if others on ATT had this wifi issue.

    No one said yes.

    So for the heck of it I connected an older wifi g router.

    Viola!!!

    Problem cured.

    So I reset the Linksys router back to factory settings in case I made some wacky setting.

    So default ssid and no wep, I was getting the same crappy <1 Mbps speeds...

    So I just configured the older router and returned the Linksys back to old settings so others in the house could use it.

    So lesson for the day? Try a different wifi router...
  16. Lolpoppa

    Lolpoppa New Member

    I have the exact same problem but only when using open, public WiFi such as the Cloud etc.

    This has only been for the past 3 days too and I've tried different settings, ROMS and modems.

    Proper confused...
  17. rynlpin

    rynlpin Well-Known Member

    I often find when I come home, my WiFi will connect to BT Fon and BT Openzone (BT customers can leech off other BT customers' WiFi through these services) rather than my own WiFi. Wondering if the BT Fon app is interfering.
  18. LaughingJohn

    LaughingJohn Active Member

    I just had the exact same problem with my son's S3. What was interesting was that my own S3 was connecting without any issue. Tried rebooting, forgetting the network etc.

    In the end I sorted it by getting the home hub to forget his device. On my hub you go to advanced settings/home network. Under the wireless list click on the android devices until you find the one with your Mac address (you can find that from either Wi-Fi/advanced or About device/Status on the phone).

    Just click the delete button and the router will forget the device and try connecting the phone again.

    Not sure why this worked, or whether it will for you, but thought I'd mention it in case it helps someone else out.

    LJ
  19. vijays3

    vijays3 Member

    solved !!! solved !!! solved !!!

    1. Go to your router settings.
    2. In wireless, go to "network mode"
    3. In network mode, there were 6 modes given:
    802.11 B/G/N mixed mode
    802.11 B/G mixed mode
    802.11 G/N mixed mode
    802.11 B only
    802.11 G only
    802.11 N only
    4. Select " 802.11 B only"
    5. Save and exit.

    Earlier, my router was in mixed mode (B/G/N) and there was error in connecting. The wi-fi singal was of pull power, but it was showing "poor connection, network disabled". After changing the network mode to "B" only, my Galaxy S3 connected seamlessly as before.

    i dont know the reason, why my s3 was working initially when router was in mixed mode, why it stopped suddenly? now i am happy...atlast working... - Try this step and if working., spread the news and help others - Regards..Vijay
  20. antlawa

    antlawa New Member

    I tried all of these fixes (static IP, *#0011# wifi power saver OFF, reboot everything, forget connection, etc.) to no avail and finally, in frustration, reset my router to factory defaults. Now the Galaxy s3 connects just fine, plus my other wifi devices are all much more stable.

    I had to forget the previous connections and scan for wifi again with security disabled (open), from my phone AND my laptop, get connected, and then change security settings back to WPA2 personal (also called WPA2-PSK) - AES on the router, laptop AND phone.

    Working great now.

    My pc had requested a new ip address from the router many times, so it was no longer the default setting of 192.168.1.1, but the router having a random ip address didn't seem to bother my old android or my ps3. It remains to be seen if obtaining a new ip address from the computer screws up the phones' connection every time.
  21. vijays3

    vijays3 Member

    solved !!! solved !!! solved !!!

    1. Go to your router settings.
    2. In wireless, go to "network mode"
    3. In network mode, there were 6 modes given:
    802.11 B/G/N mixed mode
    802.11 B/G mixed mode
    802.11 G/N mixed mode
    802.11 B only
    802.11 G only
    802.11 N only
    4. Select " 802.11 B only"
    5. Save and exit.

    Earlier, my router was in mixed mode (B/G/N) and there was error in connecting. The wi-fi singal was of pull power, but it was showing "poor connection, network disabled". After changing the network mode to "B" only, my Galaxy S3 connected seamlessly as before.

    i dont know the reason, why my s3 was working initially when router was in mixed mode, why it stopped suddenly? now i am happy...atlast working... - Try this step and if working., spread the news and help others - Regards..Vijay
  22. cavecreekaz

    cavecreekaz New Member

    I just picked up my Verizon Galaxy Note2 a couple of hours ago. Ditched my IPhone 4S. I love the way it's responsive and ease of web browsing!

    As soon as I got home I fired up the WiFi Config and got the problems mentioned. Tried everything suggested including modem configuration. I turned off the phone and fired it back up, no joy. After screwing with it I disabled the "Mobile Data" in the top screen bar. Did a Speed Test and it worked with my WiFi!! Then I turned the "Mobile Data" back on, GTG!! Running of my WiFi and not the "Mobile Data". Hopefully it unscrambled it's radio brain. If anything I'll turn off "Mobile Data" if the problem reacurs.

    Note: Love the Note2!! Had a Iphone 3GS then went to the Droid Razor. Loved the Razor but it died on me before the day was done all the time. Pissed me off when a month later they came out with the RazorMax. Couldn't handle losing my milage/GPS log (.50 a mile worth) when I would go ship in the late afternoon. Went to the IPhone 4S which wouldn't go dead even after 2 days! But really don't like the restricted IOS platform. So hopeing the Note2 has good battery life. Plus I saw that an extended battery exists that fits under the back cover if I need more life. Got interested in the Note after checking out my sons Note1 as we both enter data on our main computers using Slash Desk Top or Jump Desk Top for Android.
  23. fluffymcdeath

    fluffymcdeath New Member

    I just started having the "poor connection" problem today sitting in a cafe with my S3. It's a network I had never connected to and it happened after I thought I had connected. I googled all over on my backup ASUS tablet and found nothing useful. The ICS tablet was fine but the JB Galaxy was choking on the same network. Forgetting the network didn't help. Rebooting the phone didn't help.

    Then I remembered that I had just installed an app over the wi-fi right before it quit. In my case it was an OCR app called ScanToText. I checked in the app manager and it was running (after a reboot) so I forced quit and tried to reconnect. BINGO. Wi-fi connected right away and has been fine since. Think I'm going to uninstall this app. :)

    No idea why it happened but everything is fine now so maybe people want to try quitting and uninstalling recently installed apps.
  24. flametree

    flametree New Member

    Hi. I tried many of the suggestions posted in this thread. What worked for me was one of the more simple fixes. First make sure WiFi is turned on. Then Go to:
    1. Settings > WiFi > Tap on the network in question > choose the "Forget" option. Then reboot Galaxy. Galaxy should automatically find the network again. then if necessary, Go to:
    2. Settings > WiFi > Tap on the network in question > choose the "Connect" option.
    (I had the modem channel set to auto)
    Hope my feedback helps. Thanks very much to the forum for helping me solve this with the info posted.
Loading...

Share This Page