Galaxy S3 - WiFi problem after 4.1.1. OTA upgradeSupport


  1. colin415

    colin415 New Member

    A few weeks ago I received my new Samsung Galaxy S3 - GT-I9300. This is an International, unlocked unit.

    Everything was working flawlessly for several weeks, including stable WiFi connectivity, until Sunday when an OTA upgrade was automatically downloaded bringing Android to version 4.1.1.

    The upgrade appeared to install successfully, but the next day when I turned on the phone, the S3 would not connect to WiFi. When I looked at the S3 WiFi panel, the network SSID entry displayed "connecting" and then "disconnected" until the next scan occurred. The S3 continuously displays "connecting" and then "disconnected." Turning WiFi off and on again has no effect. I tried the "Forget" WiFi option, re-entered the logon info, but that didn't help either. I pulled the battery, waited several minutes, and reinstalled the battery also without any difference.

    My wireless router (NetGear WNDR3300) is working perfectly, and none of the 20 other network devices have any problems connecting. Only the S3 is having problems since the 4.1.1. upgrade.

    As an experiment, I unplugged the router's power connector and plugged it back in. Magically, the S3 immediately connected to the router! Early the next day, the phone still connected to WiFi without a problem. Then, later in the morning, the same thing happened - no WiFi. Again, I unplugged the router's power and plugged it back in. The S3 then immediately connected.

    I performed a factory reset and wipe on the S3, but the same thing continues to occur every day with Android 4.1.1.

    Since this is only happening on the S3, I assume it's the result of the 4.1.1. upgrade. Has anyone else has this problem, and if so, were you able to resolve it? Any suggestions would be greatly appreciated?

    Advertisement
    :
  2. davidmanvell

    davidmanvell Well-Known Member

    Most likely the S3 being a new device is trying to access something specific in the router and it's having issues handling it. Resetting the router obviously fixes it. i would suggest you check and see if the router has the latest firmware. if it doesn't do it I would consider replacing the router.
  3. colin415

    colin415 New Member

    Thanks for the quick reply. I appreciate it.

    The router has the latest firmware update available and has had a variety of "new" devices thrown at it without any issues (e.g., new generation iPods, iPads, and Win8 touch-screen laptops.)

    Are there any "hidden" settings that may affect the WiFi behavior? It almost appears as though the IP lease for the S3 isn't automatically renewing as it did in the previous version of Android 4.0.

    Thanks for your help.
  4. bmoliver

    bmoliver Well-Known Member

    I too have the same wifi issues after upgrading to JB. The only solution I have found so far is to disable the wifi power savings option. The problem with that it that it drains the battery faster.

    Based on the number of posts related to wifi and JB, I am surprised that Samsung has not addressed this with a quick fix!!
  5. davidmanvell

    davidmanvell Well-Known Member

    I know that I have not had any issues with the wifi before or after jellybean other than once when I had to reset my router as it lost connectivity. But that was quite some time ago and only once and I am pretty sure the router was at fault in that instance as other stuff was messed up as well.

    There are not many wifi settings on the S3 as there really is not much to set up when it comes to wifi. Only thing I can suggest is maybe assign a static ip address for the S3 in the router config.
  6. davidmanvell

    davidmanvell Well-Known Member

  7. colin415

    colin415 New Member

    Thanks for your suggestion.

    My wireless router is setup so that all attached devices have static IP addresses. I find it easier to manage the router that way.

    After finding the hidden ServiceMode through *#0011# and setting "WiFi Power Save Mode" to OFF, WiFi appears to be working again without pulling the plug on the router.

    I wonder if this is something that the Android developers are going to address?
  8. MrSpecbus

    MrSpecbus New Member

    Purchased two new s3 Verizon phones with 4.1.1 OS from Costco. Neither one will work with my home network. They fail authenication after the password is entered. Tried the "*#0011# fix but Verizon will not complete the call. Have rebooted the router (a comcast provided NETGEAR unit), changed thenetwork password, removed and replaced the battery and SIM. Nothing has worked. Still looking for a solution.
  9. NChay

    NChay New Member

    I am having the same experience which happened to colin415, when my s3 downloaded the newer version 4.1.1 automatically when access to public wifi couple days ago. Now finding a solution with Samsung.com and hopefully get an answer there.

    :mad:

    I am accessing internet through USB tethering instead and it works fine, but it is just 1-1 connection.
  10. SUroot

    SUroot Well-Known Member Developer

    There's been a bug in many versions of android that wifi sleep "never" uses less power than any other option so always best to use that. It takes more power to re establish a connection every time you turn your screen on than to maintain it when your screen is off.

    Anyone having issues with things not working after an upgrade should consider resetting like the sticky thread suggests
  11. NChay

    NChay New Member

    I have got the problem fixed!!:smokingsomb:

    I dont know how it works but please follow this, if you trust me,

    Setting > More settings > Kies via Wi-Fi > select OK, and then it will brings you to Tethering and portable hotspot, ON it. Your computer will then connected sucessfully to mobile wifi.

    In your next connection, instead of selecting Kies via Wifi, you may select "Tethering and portable hotspot" (just the same way you create wifi hotspot before version 4.1.1 upgrade.

    Hope it works for you too.
  12. AllRightie

    AllRightie New Member

    I too have had this issue and don't understand the 'fix" provided - when I go to Settings - More Settings - I don't have the selection for Kies Air. I have the following items selectable: Airplane Mode, Mobile networks, Tethering and ..., VPN, NFC, S Beam, Nearby Devices and AllShare Cast..... is this a version issue or? I am on version 4.1.2. I agree with others that Samsung should immediately provide a fix for this! If anyone has indeed found a fix that works for non-rooted phones, please let us know. Thanks.
Loading...

Share This Page