Galaxy S3 wont power off! cant get it to turn off HELPSupport


Last Updated:

  1. 4mypsp

    4mypsp New Member This Topic's Starter

    Joined:
    Nov 10, 2012
    Messages:
    3
    Likes Received:
    0
    Hi and thanks for viewing!
    Ok so I bought my S3 new about 2 months ago (running stock 4.0.4), Everything has been sweet up till now. Now when ever I want to turn my S3 off it boots straight back up again!!! I hold down the power button, select power off, it goes through the normal shut down process, then immediately boots back up! Ive tried clearing cache (didnt work) so then I tried a factory reset/delete all data/clear cache didnt work, So then a flashed a fresh copy of android 4.0.4 using odin. and still have the same problem!

    I dont want to do a warranty claim on it because ill be without a phone for a few days! But if I have too I will

    Thanks in advance

    EDIT: ive also tried pulling the battery out for 15mins then reinstalling. also tried removing the SD card and sim card. nothing has worked
     

    Advertisement
  2. GTWalling

    GTWalling Well-Known Member

    Joined:
    Sep 9, 2012
    Messages:
    1,277
    Likes Received:
    411
    You might try a Factory Reset and see if that clears it up. Make sure to backup you stuff on the SDCard just in case.
     
  3. Krunk83

    Krunk83 Well-Known Member

    Joined:
    Sep 27, 2011
    Messages:
    519
    Likes Received:
    110
    Did you pull the battery for thirty seconds?
     
  4. 4mypsp

    4mypsp New Member This Topic's Starter

    Joined:
    Nov 10, 2012
    Messages:
    3
    Likes Received:
    0
    Yes i did, (was also mentioned in the first post :) )
     
  5. 4mypsp

    4mypsp New Member This Topic's Starter

    Joined:
    Nov 10, 2012
    Messages:
    3
    Likes Received:
    0
    Yep ive tried that. I have flashed 4.1 to my S3 now. It seems to have solved the problem. But ive had other issues on 4.1 before so fingers crossed they dont come back! time will tell
     

Share This Page

Loading...