Galaxy/Stock android on behold 2 - It flies!


Last Updated:

  1. Gbear

    Gbear Member

    Joined:
    Jan 23, 2010
    Messages:
    21
    Likes Received:
    1
    Well I won't be doing anymore of this without help.I followed the instructions and started by putting the correct file onto my sd card I rebooted and the phone froze.I had to do a hard reset and now my sd card won't work.So I guess I screwed something up.:confused:
     

    Advertisement
  2. danalv93

    danalv93 New Member

    Joined:
    Jan 24, 2010
    Messages:
    2
    Likes Received:
    0
    So my phone unbricked itself after a while of sitting there with odin on. took about 2 hours to unbrick. Not sure if I wanna try this again but with my fingers crossed i might just give it another shot :cool:

    Edit: Btw after reading the forums a couple more times, I found out I had the same problem as shaun and flamereaper. If I disconnected my phone it'd bring up a white screen with "download" on it. however I found that if I took the battery out and turned it on directly to download mode, I could still mess with it on odin. I also got the 5% loading bar once while trying to figure out how to unbrick it.

    P.S. I did try it again, and I gotta say, I love it!!! Thank you everyone who was involved in making this happen. My phone is so much faster!
     
  3. several

    several Well-Known Member

    Joined:
    May 3, 2009
    Messages:
    53
    Likes Received:
    0
    Absolutely Fantastic.

    I just put the Galaxy ROM on my wife's Behold II. Thank you so much to everyone who worked on this!

    I created a public wave of things I got from this thread and from other places.

    The wave lists things in the order you need to do them, from rooting, to installing ODIN and backing up with it, to flashing the new ROM.

    The wave is here:
    https://wave.google.com/wave/#restored:wave:googlewave.com!w%252BKC1UAbTnA

    If that link doesn't work for you just search on all or some of the words in the title which is:

    The wave is set as read-only for now, but let me know if you want perms to edit it.
     
  4. chadmd23

    chadmd23 Well-Known Member

    Joined:
    Dec 17, 2009
    Messages:
    530
    Likes Received:
    57
  5. dreadmot

    dreadmot Member

    Joined:
    Jan 22, 2010
    Messages:
    7
    Likes Received:
    1
    Download the system image and extract the apks. Make sure you grab the one for 1.5
    Its about half way down the page.
    HTC - Developer Center
     
  6. shawn1224

    shawn1224 Ex CEO-DNPSEA foundation VIP Member

    Joined:
    Dec 10, 2009
    Messages:
    2,186
    Likes Received:
    292
    Maybe I should have tinkered with it a little bit more to resolve the problem but no worries, my phone is getting shipped back from Samsung today. They said it was locked up in operation and had to do an OTSL reset.

    Meanwhile I should be getting Fender mytouch pretty soon so I'll have 2 toys to play with. As hard headed as I am, when I get the Behold II back I might still try to port the Galaxy Rom back on it.:D
     
  7. Bugdog

    Bugdog Well-Known Member

    Joined:
    Jan 19, 2010
    Messages:
    132
    Likes Received:
    6
    That sounds great, thanks, but I don't know how to access it--when I click on the link, it takes me to Wave home (I have an account) but not to your wave. Does anyone know what I need to do to see the wave? Thanks, hope this isn't a dumb question...

    EDIT: Figured out I could just search "behold" using the "searches" button... easy enough. Thanks for putting that together!
     
  8. several

    several Well-Known Member

    Joined:
    May 3, 2009
    Messages:
    53
    Likes Received:
    0
    Oh wow. Didn't realize that link would fail for other users even though it works for me. Sorry about that. Glad you found it.

    And you're welcome, tweren't nothin.
     
  9. SoulCreator

    SoulCreator Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    71
    Likes Received:
    4
    Nice job with that wave, everything is put in a way more concise format than this thread.
     
  10. several

    several Well-Known Member

    Joined:
    May 3, 2009
    Messages:
    53
    Likes Received:
    0
    Thanks. Glad you like.
     
  11. xblue95

    xblue95 Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    81
    Likes Received:
    3
    I've been monitoring this thread for a few days now and I think I'm about ready to give this a shot, I just had a couple quick questions.

    1. If you've already rooted your phone, do you need to complete
    **Block 1**? some of the commands seem different than the original root commands I did.

    2. page 2, upperware posted:

    Originally Posted by kam187
    chmod 4755 /system/bin/busybox
    /system/bin/busybox --install -s /system/bin/

    Between those lines you need to mkdir /data/busybox

    is that true? I don't see it revised in post 1.

    3. Any guess-imation on when or if the BH2 original camera will get put back on? I like that camera better! What kind of bells and whistles do you get with Galaxy camera?

    4. Is MrAndroids script working or not?
     
  12. several

    several Well-Known Member

    Joined:
    May 3, 2009
    Messages:
    53
    Likes Received:
    0
    1. I wasn't sure either but it can't hurt. Since it differs a little I did it and it worked, no problems.

    2. The cat command earlier in the process created the new busybox dir a few lines up.

    Check out the public wave I made from info in this and other threads. search on title which is "Rooting the Behold II and flashing it with the Galaxy Android 1.5 ROM"

    It is easier to follow than this thread.

    lemme know if you need a google wave invite.
     
  13. xblue95

    xblue95 Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    81
    Likes Received:
    3
    Thanks for the info "several", Ya I'd love an invite to Google Wave! I applied for one a few months ago, but haven't heard back from them. I'm curious what it's all about....? Do you need my email address to forward it?
     
  14. SoulCreator

    SoulCreator Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    71
    Likes Received:
    4
    Yeah I'm in the same boat as you only I was wondering if anyone had any idea if the vibrate function will be fixed on the galaxy rom... That's kind of important for me as I usually keep my phone on vibrate 24/7.
     
  15. several

    several Well-Known Member

    Joined:
    May 3, 2009
    Messages:
    53
    Likes Received:
    0
    invite sent. time until you get it can vary from hours to days. They send out invites in batches.

    as for what wave is, this video does a pretty good job of explaining it:
    Two-Minute Video Makes a Lot of Sense of Google Wave - Google Wave - Lifehacker
     
  16. Bugdog

    Bugdog Well-Known Member

    Joined:
    Jan 19, 2010
    Messages:
    132
    Likes Received:
    6
  17. AlphaDomingo

    AlphaDomingo Member

    Joined:
    Jan 27, 2010
    Messages:
    13
    Likes Received:
    0
    Ok so I got all the way to the MMS fix. Once I installed I mistakenly unplugged the phone thinking I was good to go. Unfortunately now the phone boots up with the Samsung logo and stays there....forever. Any ideas?


    P.S. I was head over heels for the Galaxy rom until now of course.:rolleyes:
     
  18. dfellars

    dfellars Member

    Joined:
    Jan 27, 2010
    Messages:
    18
    Likes Received:
    0

    Thank you so much from this Android Noob... once I found a machine that would connect with ADB (Win7x64 no, Ubuntu 9.10 no, Win7x86 yes) it took me less than 30 miutes to complete!
     
  19. larcen

    larcen Member

    Joined:
    Dec 25, 2009
    Messages:
    6
    Likes Received:
    0
  20. AlphaDomingo

    AlphaDomingo Member

    Joined:
    Jan 27, 2010
    Messages:
    13
    Likes Received:
    0
    So now that I have the stock TouchWiz now, for some reason I can't get adb to recognize the device. I've uninstalled the drivers and reinstalled the behold 2 ones for adb. Still no luck and I'm on 4 hours of trying everything. Any help would be appreciated.
     
  21. larcen

    larcen Member

    Joined:
    Dec 25, 2009
    Messages:
    6
    Likes Received:
    0
  22. AlphaDomingo

    AlphaDomingo Member

    Joined:
    Jan 27, 2010
    Messages:
    13
    Likes Received:
    0
    Nope, debugging is clicked, phone is "unmounted". Im running vista 32bit if that means anything. I had trouble doing this in the beginning before I had to reload Touchwiz but somehow I got it working. Not now though.:mad:
     
  23. paul89

    paul89 Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    1,004
    Likes Received:
    84
    do you have it in studio mode? I rembember somewhere in the settings of the touchwiz rom you need to choose studio ovr the two choses of "samsung studio" and "never mount"
     
  24. jboston511

    jboston511 New Member

    Joined:
    Jan 24, 2010
    Messages:
    3
    Likes Received:
    1
    That was the issue I was having, I had to go into the craptastic samsung menus and change usb mode to pc suite
     
  25. paul89

    paul89 Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    1,004
    Likes Received:
    84
    hahaha ya retarted I know!
    I want android 2.1:eek:
     

Share This Page

Loading...