Gallery app Not enough memory Jelly Bean !Support


Last Updated:

  1. Argjent

    Argjent Active Member

    So I installed Jelly Bean, pretty happy with it except the battery of course and the Gallery app not working :-(.
    Every time I try to open it now it says: "Not enough memory, delete some unnecessary.....".
    Last day I tried deleting Android/Data/cooliris media cache it worked !
    But then after a day the problem has started again.
    At first when I flashed JB the gallery app including Camera wouldn't work due to same problem but the camera is OK now !?
    AND I DO HAVE A LOT OF FREE SPACE if that is what someone thinks of recommending ;-)

    Advertisement
  2. dostoyevsky182

    dostoyevsky182 New Member

    I had the same problem on Samsung Galaxy S2 after updating to Jelly Bean

    In my case there was the following problem:
    i noticed (with file explorer) that after about 2-3 minutes after starting the phone the filesystem /sdcard remounted read-only (!). This is a default behavior in case of error "remount=ro". And this was happening only when external SD card was inserted.

    So I copied /sdcard to my external SD and formatted it (through Settings-Storage). Then copied back the files and now everything works fine.

    Resetting to factory defaults would not work in this case.
    Cheers from Russia
  3. ms_saber

    ms_saber New Member


    Thanks mate, your suggestions solved my very same problem.
  4. Nonnz

    Nonnz New Member

  5. Nonnz

    Nonnz New Member


    i have the same problem with my S2
    please what do you mean by copy /sdcard to external memory, and how can i do it.
    thanks,
  6. dostoyevsky182

    dostoyevsky182 New Member

    you need to check that you have the same problem with /sdcard being corrupt and that it remounts in read-only mode after 2-3 minuted.

    in shell or terminal (if you have one) you can type something like "mount | grep sdcard" and check what filesystems you have and which ones are mounted "rw" (read-write) and "ro" (read-only). The one you are looking for is /storage/sdcard0

    So, anyway, get an app called "file manager", you should see a list of folders on your android.

    one of them is "/sdcard" which links to "/storage/sdcard0" -- this is internal memory that is installed inside of the phone for user files and that is where the problem is located. it became corrupt after the update in my case (see my previous post).

    so what i did is i inserted external card, it mounts to /storage/extSdCard. You can backup all your files from /sdcard or /storage/sdcard0(which both are the same thing) to /storage/extSdCard (which is external sd card, a micro card that you physically insert into the phone).

    So after having a backup you can go to Settings-Storage and format the /sdcard. Just be sure to format the right thing(internal memory is called USB storage in the settings menu, also remove external card to be 100% sure).

    When you are done with formatting you can bring application and user data from the backup back to your internal memory.
  7. sgajraj

    sgajraj New Member

    Thanks! I had the same problem and this solution worked for me. I didn't even need root access.

Share This Page