Gallery moving photos?


Last Updated:

  1. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    I have done some searches and cannot come with the answer I need. All the photos I take are moved to the SD card and not available to the gallery. It seem they stay in the gallery for about a day and then they are moved. I cannot figure out how to bring them back to the gallery or to so that I can send them out or edit them with the phones photoshop. The photos taken with the camera are on the SD card in the DCIM file while the downloaded photos are in the download file but I am not finding any menue that allows me to retrieve them back to the gallery. Any Help?
     

    Advertisement
  2. SinfulDragon

    SinfulDragon Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    614
    Likes Received:
    36
    wow, thats.... an odd one to say the least.
    I think I would unmount the SD Card (through settings, SD Card/Phone Storage) then mount it, open gallery and let it repopulate to see if that will bring them back.
     
  3. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    Thanks for the response. When I press "unmount" it says it is unmounting and that I will received a notification when when the process is done but it never happens. When I plug my phone in I get 2 notifications. One is that the debugging is on and the other is that USB is connected. I tap usb connected and and I have a screen that has a droid man and a prompt to "turn on USB storage". When I do this the droid man turns orange and the prompt says turn off USB storage. Before I rooted I used to get the "mount/unmount" promts.

    After I hit the unmount prompt my sd card would not show up. All the processes worked but it did not show up above the unmount/mount tab. I opened the usb via "turn on usb storage" and then the sd card info showed back up?
     
  4. SinfulDragon

    SinfulDragon Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    614
    Likes Received:
    36
    well, that sucks.
    Power down the phone, pull the battery then reseat the SD Card.
    Power back up, let your phone boot up enough that the little SD Card icon at the top goes away then go into gallery and see if it will refresh that way.
     
  5. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    Will I damage anything by taking the sd card out without "unmounting"?
     
  6. SinfulDragon

    SinfulDragon Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    614
    Likes Received:
    36
    not as long as you turn off the phone.
    During shutdown it will unmount it from the phone. on start up you will see in the top that it says preping the SD Card, this is due to the fact that during shutdown it unmounts it from the phone to ensure there is no damage.
    Earlier you were talking about seeing the mount/unmount option on the phone, well thats just unmounting it from the PC, not the phone.
     
  7. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    Well thanks for taking the time to try and help but it did not work. There must be something somewhere telling my phone to store the photos on the sd card and not the phone.
     
  8. SinfulDragon

    SinfulDragon Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    614
    Likes Received:
    36
    hm, well photos should be on the SD Card, thats where mine are stored.
    When you hook into the computer and browse your SD Card, are you able to locate and open your pictures?
    Are they in DCIM/Camera folder?
    Are you using anything like Astro where you have renamed the folder to be .Camera or .DCIM The '.' in front of the name would make the folders hidden folders and thus not shown in the gallery.
     
  9. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    Yea all the photos are still there on the SD card. The photos taken by the camera are in "DCIM" and the downloaded photos are in the "Download" file. I probably used Astro at one time or another but there is not a . in front of the folder. The photos are somehow not recognizable by the gallery. They are there on the SD card but just cannot be found on the gallery. Funny thing is after I take a photo or download one it will be in the gallery for a while but then it dissapears so it is found by the camera for a while but then cannot be found or it is stored on the camera and then transfered to the SD card and cannot be recognized.
     
  10. SinfulDragon

    SinfulDragon Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    614
    Likes Received:
    36
    wow, I'm pretty much at a loss.
    A last ditch effort would be to create a folder inside DCIM named Camera (so the structure is SD Card\DCIM\Camera) and move all of the pictures into the Camera folder.
    and I only say that because thats how mine is setup and I don't recall creating such a folder for them to go into.
    Sorry I couldn't be of more help.

    Anyone else have an idea here? I'm tapped out and VZW is just going to tell him to do a hard reset.
     
  11. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    I have been playing around with the phone and now I am beginning to wonder if they are being moved when I reboot? I am going to leave it alone for a couple of days and see how long they stay there if I don't turn the phone off. mmmmm
     
  12. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    I just looked into that and there is already a file "camera" in the DCIM file. There is also a 100ANDRO and get this...a ".thumbnails" file. Perhaps the "." in front of the thumbnails was what was screwing things up? Maybe it just could not find the thumbnails to put into the gallery? I will let you know. Thanks for all your help.
     
  13. x026092

    x026092 Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    375
    Likes Received:
    29
    two questions. do you have the camera SD store option on? and do you have a ".nomedia" file in the DCIM/camera folder"?
     
  14. klwheat

    klwheat Well-Known Member

    Joined:
    Jun 23, 2010
    Messages:
    172
    Likes Received:
    5
    Just my $0.02, but all my pics are stored on the SD card too...I like it that way. But, when I go into gallery, there's a folder for "camera" that has them all there.
     
  15. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    1. It must be on since the photos are being stored there.

    2. I don't have a .nomedia file in the DCIM file. I only have Camera, 100Andero, and thumbnails (which I just changed from .thumbnails).

    The photos are all on the sd card, I just cannot access them from the gallery.

    I took another shot and it is coming up in the gallery for now. I will check it now and then and see if it stays after changing the .thumbnails to thumbnails.
     
  16. supersaki

    supersaki Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    386
    Likes Received:
    36
    I've heard any file with a period for the start of the filename hides all contents in that folder from gallery/music player. It probably is the .thumbnails hiding them.
     
  17. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    Well the photo seemed to stay in there. I restarted the phone and it was gone (still on SD) so the problem MAY be when I am rebooting the phone. I wonder what is kicking it in there. Sort of like an automatic flush.
     
  18. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    I did a bit more experimenting. When I take a photo a new file is created everytime in the DCIM folder (.thumbnails). I delete the file but everytime I take a new photo the file appears again. Then, the when I reboot the phone the photos are gone from the gallery. I think something is creating the .thumbnails file which is taking my photos off of the camera everytime I boot. Any ideas what program it could be?
     
  19. supersaki

    supersaki Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    386
    Likes Received:
    36
    Try clearing data/cache for the gallery under settings>applications>manage applications. You may try also running fix permissions.

    The .thumbnails is a folder in your dcim folder, right?
     
  20. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    Not sure how to run fix permissions?

    I cleared the data/cache but it did not help

    Yes the .thumbnails is a folder in my dcim folder. I delete it but it comes back up when I take a photo.

    Any other ideas. I think there must be something wrong with "gallery"? Is there any way to delete it and reinstall?
     
  21. twistedlim

    twistedlim Well-Known Member This Topic's Starter

    Joined:
    Jun 9, 2010
    Messages:
    804
    Likes Received:
    80
    I think it was the astro. I removed astro and then removed any image or thumbnail file or folder that had a "." in front of it and the photos seem to be staying in the phone gallery. There were a ton of thumnails that I had downloaded for icons that had to be removed.
    Thanks for your help!
    Rich
     
  22. SinfulDragon

    SinfulDragon Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    614
    Likes Received:
    36
    Good to hear.
    I also have a .thumbnails folder, I never remove it nor clean it out, I figure its for the galleries ability to cache the pics to pull up the preview faster, of course it beginning with a '.' doesn't makes sense in that aspect.... but who the hell knows right LOL.
    At any rate, glad you're up and running and able to see your pics, for more than just a day LOL
     
  23. NeidRider

    NeidRider New Member

    Joined:
    Aug 19, 2010
    Messages:
    1
    Likes Received:
    0
    Hi all

    I'm new to this forum, but not to Android/Linux.
    To clear this out: the "." in front of "thumbnails" makes the folder invisible. You shouldn't bother with it, it's just sort of a commodity, an internal folder that the gallery uses to store the thumbnails. And since you're not supposed to bother with that, the system hides it from normal view with the ".".
    So:
    If you delete that folder, it keeps coming back.
    If you rename that folder, it will keep coming back.
    Just leave it alone, it's as simple as that ;-)
     

Share This Page

Loading...