Galzxy s2 for virgin mobile


  1. nsciucco

    nsciucco Well-Known Member

    Anybody know when there will be some development for this phone on VIRGINS network?

    Advertisement
    :
  2. ExtremeNerd

    ExtremeNerd Well-Known Member

    Honest answer? Likely never for that specific variant. Think like a developer. Would you want to buy, and develop, for a phone which is 18 months old? Even though it is new to Virgin, it's still an old phone. Most devs have moved to the GS3 or N4, the current high end devices.

    Try at your own risk, but the Sprint ROMs MAY work, since I believe they run on the same network. I would ask in the device specific forums if they're compatible.
  3. Digital Controller

    Digital Controller The Real Bass Creator Guide

    To make things a little more clear, Virgin Mobile does run off Sprint's network so you can try the ROM's for the Sprint S2 forum.

    Please though be wary of the harms of rooting/roming your device. We are in no way responsible if anything happens to your device.

    Here is the link: Sprint Galaxy S2
  4. kevindroid

    kevindroid Well-Known Member

    the roms for the boost s2 will work on your phone. after all both boost and virgin phones are rebranded epic 4g touch. also the sprint forum. readup on these plenty of development went on phone is aged now
  5. nsciucco

    nsciucco Well-Known Member

    ya .. But no mms
  6. SuperAfnan

    SuperAfnan Well-Known Member Contributor

    If sprint roms and rooting does work at least you'll have a modded phone :). Hopefully it will get some development on the virgin Mobile side but I doubt many developers will buy it.
  7. nsciucco

    nsciucco Well-Known Member

    You are Probably right. It sucks that a superior phone would not get any DEV support. The SG2 is far superior the EVO..... IMO
  8. ExtremeNerd

    ExtremeNerd Well-Known Member

    Of course it is, the EVO is more than two years old. However, it was top of the line when it was new. The Virgin S2 isn't new, and it isn't even top of the line anymore. It is like asking why the Nexus One isn't being updated to JB. It's an old phone. Simple answer.
Loading...

Share This Page