GAOSP Froyo Nightly Builds

Last Updated:

  1. Groovy

    Groovy Member

    I am using the first nightly build and am absolutely loving it, I cant believe what a difference it has made. Apart from the obvious missing SD card and Camera this is how the Galaxy should have been when it first launched.

    The only bug I have found is I cannot add a Facebook account along with my Google one, anyone got a work around for this?

    With regards to the new nightly build, I guess a wipe is not needed and all we have to do is apply the new zip and that's it, or will a wipe be necessary for every new build?

    Thanks for all the hard work Drakaz, your now officially my new Hero

  2. golanster

    golanster Well-Known Member

    if you mean to add facebook account from settings -- accounts. then you need to install the facbook app from the market first.
    I did a wipe before installing the new nightly. let me know if we don't need too.
  3. Groovy

    Groovy Member

    Thanks for the reply Golanster,

    I already have the Facebook app installed and when I click on the Facebook account it goes to a black screen then back to the accounts page.
  4. tsphere

    tsphere Well-Known Member

    Two apparent bugs for me with current build:

    a) sd cards don't work. neither one of them aren't reachable by estrongs (sdcard,sdcard2 and ext_sd directories are empty). external sd card for me doesn't mount.

    b) after using an app like market, returning to the home screen takes a few seconds.

    edit: titanium backup recognizes my backups, which I guess should be on the sdcard. could be an estrong file manager problem. will test further.

    edit2: the problem is that estrongs looks for sdcard in /sdcard directory, and it is mounted in /mnt/sdcard
  5. stanleylhs

    stanleylhs Member

    I also wanna know to from the old nightly to the new do I have to wipe????
  6. denial86

    denial86 Active Member

    I second this. Guess it is a bug in this build.
  7. tsphere

    tsphere Well-Known Member

    Okay, the mount issue is a serious one for me.
    The internal sd is mounted in a different directory than expected (/mnt/sdcard instead of /sdcard). This causes many of the apps which depend on the internal sd not to work.
    Tried to create a symbolic link using the shell but it won't work.
  8. denial86

    denial86 Active Member

    Is it just me, or does the device get slower with JIT enabled? I still have 23 mb free in memory according to advanced task manager, but now the home screen takes ages to reload after I press home from within an app. Also is it advisable to disable Surface dithering to reach an performance improvement or wouldn't it matter much?
  9. tsphere

    tsphere Well-Known Member

    JIT also slowed down my performance. really took a heavy hit. But I did not have the free memory you have.
    for some reason, even in galax0 top always shows me 1mb-2mb free.
  10. denial86

    denial86 Active Member

    Thats odd... with galax0 I got around 22-27 free mostly, same now with this one. I usually turn off all the animations and stuff that takes up memory. Kinda made peace with the limitations of the device and just trying to make it as usable as possible. So maybe cutting on transition animations and such might help you out a bit. Btw I confirmed my own query by disabling JIT; now all is smooth again. I really love Froyo, it is very enjoyable, even with the few bugs. I so far noticed the following:
    - obviously no camera
    - home screen reloading (solved to a point where it is not frustrating me anymore by disabling JIT)
    - occasional dissapearing of status bar, even though in adw settings this is disabled (I find this a bit annoying) - ADW issue, and solved by disabling in ADW settings menu
    - facebook integration doesn't work as stated previously (another annoyance/after all, no facebook means no friends ;) )
    - incredible slowdown with JIT enabled (really don't see a point of it as froyo is speedy by default)
    - high-res pictures load very very slow in gallery. Can hardly call this a bug since this phone is not compatible with terms which include 'high' (high-res, high-speed, high-end, etc.)

    I haven't encountered any mount issues with applications like you did tsphere, maybe I will after greater usage. So far I am happy with it and will continue to use it throughout the next few days and see how far I get with acceptable frustration levels. As for now I consider this a major upgrade over
  11. golanster

    golanster Well-Known Member

    very strange with the 1 - 2 mb of memory, i have 22- 27

    daniel86 - occasional dissapearing of status bar, even though in adw settings this is disabled (I find this a bit annoying) - its an adw feature which i hate too... swipe up on your device to show/hide the status bar

    i have all the animations on and jit and i havent got any problems with it.... no slowness or anything
  12. denial86

    denial86 Active Member

    Ow yeah I see, I disabled this now in adw settings, which seemed to have solved the problem
  13. tsphere

    tsphere Well-Known Member

    What app do you use to see free memory?
    I was referring to the output of "free" in the shell.

    Also, could you look where the sdcard is mounted for you? for me it was /mnt/sdcard, which was causing problems with several programs (specifically Waze and MyBackup). If this is not a common problem, perhaps I will try a reinstall.
  14. golanster

    golanster Well-Known Member

    i use autokiller for memory and it display 22 - 27
    same problem with the sd card, i tryed waze yesterday and could not get it to work, it was asking me to check if the sd card isnt mounted....
    but its still faster then the previous nightly and much faster then
  15. denial86

    denial86 Active Member

    Also using autokiller here. the issue with my backup pro was solved by me by upgrading it to the latest version (2.4.0). I was able to restore my backup with this version without issues.
  16. tsphere

    tsphere Well-Known Member

    Waze is one of the apps I use most. Seeing how there are about 10 different sd directories in this thing, I'm pretty sure this will get fixed in upcoming versions.

    I noticed that the internal sd card has a different name (in "df") than specified in /etc/fstab, but changing the relevant line in /etc/fstab didn't help (it was still mounted in the wrong place in the next boot). I guess it has something to do with android specific stuff which I know nothing about.

    Anyway, back to galaxo for me, in the meanwhile.
  17. davyu

    davyu Well-Known Member

    External SD card seems to be usable in many apps. Except the music player for one.

    Has anyone ever encountered the 'problem' where at moments of loading, you see the 'cursor' on screen?
  18. Groovy

    Groovy Member

    Yeah I see that a few times, Freaked me out the first time for a second or 2, thought I had been duped some how and was in fact running crappy windows mobile.

    I had a problem last night mounting the SD card to windows, kept getting a pop up saying the memory card needing formatting. Fixed this by booting into recovery and mounting the SD card that way:confused:.

    Also noticed today I could not receive or download an MMS which was most annoying but as I only get 2 a year I suppose it's not that big of a deal for me.
  19. davyu

    davyu Well-Known Member

    Hm... I don't think I had the mounting issue, I managed to transfer files between the external/internal while mounted.

    On the other hand, I only managed to do it with a computer where I have the ADB drivers installed. Anyone know where the 'Mass Storage Only' option went?
  20. bresslau

    bresslau Well-Known Member

    Well, here is another satisfied customer.
    I have been using the 26.07 nightly build since yesterday and haven't found any bugs so far. Much to the contrary, there are now so many more options, it is really daily usable, as golanster says.

    Camera doesn't work, but my latest phone didn't have a camera either, I can wait.
    And it is a bit more complicated to access the SDCARDS, both internal and external. It is possible, though, all files are available on /mnt/ as sdcard and sdcard2.

    Other than that, I haven't had any problems so far. Actually, if at all, the phone is now too responsive in some instances, like screen tilting. The sensor seems to be more sensitive and will tilt sometimes when I don't want it to.

    Looking forward to the next build.
  21. ryko

    ryko Well-Known Member

    Gave it a try yesterday, what's there works great but today screen goes blank had to pull the battery. Not complaining its only a test build, just great to see what we might have in the future. Thanks Drakaz
  22. davyu

    davyu Well-Known Member

    I made a nandroid backup (donut) in recovery 4, now I'm on recovery 5 and have no idea how to restore the previous backup...
  23. denial86

    denial86 Active Member

    Anyone else noticing quite a slowdown of the nightly build after a few days? It's considerably slower than currently...
  24. denial86

    denial86 Active Member

    ow btw, new nightly arrived... will start testing it!
  25. kresten

    kresten Member

    i'm about to install the goasp nightly - should i go for 07262010 or 07282010 ?

    thanks in advance

Share This Page