Garminfone Bricked . . Help me


  1. amrs21

    amrs21 Member

    Hi I am from India and this is a 2nd hand phone . .
    I have rooted my Garminfone by using z4root
    and then deleted many internal apps like
    Chao, Navigation, Garmin Maps, Connected Services Feedback, T-mobile Hotspot, Voice control, etc which were not in use to speed up my phone.
    And had unrooted the phone, the phone was working fine,
    but 1day I without thinking had reset my phone and from then my Garminfone is in this condition so if any1 knows how to make it working, Please let me know ! !

    I also tried to upgrade with the 2.1 Upgrade but got an error (shown in video)

    Please help me ! !

    The below is a video to show my Phone condition plz help me


    Garminfone Rooted, Deleted System Apps, Unroot & Bricked - YouTube

    Advertisement
    :
  2. Spazmogen

    Spazmogen Member

    Is it unlocked? If yes, do you still have the code?

    Can you connect it to the computer? If you can, go into the "Update" folder and remove the .update file in there. That should cure the aborted update attempt.

    Power the phone off.

    Make sure it's pluged in via usb or wall jack to give it power.

    Hold the D-Pad to the left as you power on the phone. "Wipe User Data" will appear on the screen. Do nothing to it for 25 minutes. It will eventually reboot.

    The screen will appear to freeze during the process, just leave it alone.

    What you are doing is this:
    http://androidforums.com/garminfone/424105-how-reset-your-phone-10-unlock-attempts-remaining.html

    It flashes the operating system from a hidden backup partition.
    Being your phone is a T-Mobile one, you can use the official T-Mobile firmware with ease, or you can change the firmware (after you've done the process above to get it working again). See how to do that here: http://androidforums.com/garminfone/424114-how-change-firmware-another-provider-country.html it works, but you will need 2 microsd cards to make it work easily.

    India is listed, but there is no A50 (Garminfone) listed. India has the A10 (not the same phone)- do not try and use the A10 software! If you don't care for the T-Mobile crap on their firmware, try the Canadian page (English). http://www.garminasus.com/en_CA/support/nuvifone-a50-software-updates.html
  3. amrs21

    amrs21 Member

    My phone is Universal Sim unlocked like gavey sim

    Yesterday I was trying to open my phone and then i click on "Privacy Statement" (Pic Attached) [​IMG]
    I opened the browser, by clicking on Favorites page i got into it
    and some how i was able to open google user registration page
    and some how got my wifi on
    the then i downloaded n installed z4 root n rooted my phone
    and installed rootuninstaller.apk and deleted some more apps and
    my big mistake was I deleted the "Android System.apk" file
    now the phone is stuck at Opening screen at the bot image please help me ! !
  4. Spazmogen

    Spazmogen Member

    You'll be back up and running in about 30 minutes.

    Plug the phone in either via USB or to a wall outlet for power.

    With the phone off, Hold the D-PAD to the left as you power on the phone. When "Wipe User Data" appears on the screen you can let go of both buttons.


    Leave it alone for about 30 minutes (it reboots on its own). It will appear to be frozen or not doing anything, just leave it alone....

    When you're back at the lock screen, its done.


    On the Garminfone A50, there is a hidden recovery partition that we can not mess with easily. You're forcing the phone to boot from that and wipe everything that was on it.

    I suggest a Master Clear when you get it back up and running.

    Everything you did (removing unwanted apk) will need to be done again, just more carefully.

    It sounds as though it still has 1.6 Donut Android on it. I suggest upgrading to 2.1 after the Master Clear.
  5. amrs21

    amrs21 Member

    My phone already had 2.1 Update ! ! n tried ur solution nothing happening :(
  6. Spazmogen

    Spazmogen Member

    Are you holding the D-Pad to the left (the outer metal ring, not the plastic button in the middle of it) ?

    It may take a few tries (you almost need a 3rd hand). I suggest you hold the d-pad left then power on the phone while still holding it to the left.

    When it powers on, let go of both buttons. Wipe User Data should appear on the black screen. Let it run until the phone reboots (30 minutes or so).

    This fix is forcing an over write from the hidden recovery partition onto the normal user partition. You would not be able to wipe the hidden one unless you know how to find it.
  7. amrs21

    amrs21 Member


    Yes I have tried nothing happening
    Left-D-Pad+power = userwitedata
    Kept for 30+mins nothing much going on
    Still Stuck there ! ! :(
  8. Spazmogen

    Spazmogen Member

    Try and re-install the android operating system:

    On your microsd card create a folder called Garmin. Inside it, create another called Update. Note the capital letters!

    Garmin/Update

    Inside that Update folder, I want you to download the latest official T-Mobile file there is: http://www.garminasus.com/en_US/support/eclair/006-B1130-00.update

    When you power on the phone, let it boot up. If you can still get as far as you did in the video, this may just work.

    It will tell you there's an update and ask to run it. Choose yes to run it. If it tells you that it is the same version as what is installed, run it anyway!

    If this does not work, you can try the D-pad to the left while powering on the phone trick again 60 minutes this time).

    If none of that works, then you've got a paperweight.
    sufaz76 likes this.
  9. sufaz76

    sufaz76 New Member

    Hello Spazmogen

    - I have some problem too, I have try to reset as your request, but nothing happen even waiting for long time (many hour) just stuck in garmin asus logo.

    -I try to update as your request but fail, nothing happen,
    -I try to connect with adb for reboot recovery (as your request in another thread ), but no serial number found in adb devices.
    I try to looking for the answer why my phone can not connect to adb,I have installed driver for my phone, in device manager already show adb boot loader.

    Do you know, why I can not connect via adb...???? what is wrong
    please.....
  10. amrs21

    amrs21 Member

    @Spazmogen
    please help us
  11. amrs21

    amrs21 Member



    Please help us ! ! I cant afford such a costly paper weight
  12. Spazmogen

    Spazmogen Member

    Sorry. I am out of ideas.

    I sold my phone a month ago and bought an HTC Vivid.

    Try registering it with Garmin and get their tech support help working with you.
  13. Spazmogen

    Spazmogen Member

  14. Spazmogen

    Spazmogen Member

    amrs21:
    In your video it showed the update process failing as the phone has 2.1 on it but the phone still had the 1.6 .update file somewhere.

    If you download the T-Mobile USA .update file from the website, put it onto a microsd card and then put that into the phone while its powered on, it will prompt to update (plug the phone into a charger!). It will say its the same version and ask if you want to update anyway.

    Choose yes.


    Here's the 2.1 update file: http://www.garminasus.com/en_US/support/eclair/006-B1130-00.update

    On your microsd card it should be inside the following folders:

    Garmin > Update > 006-B1130-00.update
    (note the uppercase letters in folder names).

    Inside the Garmin folder, create an Update folder. Put the file inside the Update folder: http://www.garminasus.com/en_US/support/eclair/006-B1130-00.update

    I forgot that "hot swapping" the microsd card can force an .update file to run. I just bought another Garminfone, as I missed the GPS features. I still have my HTC Vivid.
  15. amrs21

    amrs21 Member

    Now my Garminfone is totally stuck now
    I have an LG Optimus G2x but still wana use Garminfone :|
    Now my Garminfone is stuck at android startup screen
Loading...

Share This Page