Generic root method, do any exist


  1. 3d3d3d3d

    3d3d3d3d Member

    I have an android tablet running 4.1.1 its the NEO3DO. Im looking to root but as there is vitually no information on this tablet regarding rooting etc.

    Is there a root method that isnt device specific, and would it have to be android version specific method?

    any info would be appreciated.

    Advertisement
    :
  2. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Root methods that aren't device specific would have to be a vulnerability within the android code itself.

    There have been some of those in the past (gingerbreak exploit with 2.3 gingerbread for example), but Google always patches them very quickly.
  3. Thom

    Thom Premium Guide Member Guide

    Welcome to Android Forums. I moved this thread to the all things root sub-forum where root-related questions of your phone are discussed.

    ... Thom
    Rxpert83 likes this.
  4. PaulS

    PaulS Well-Known Member

  5. 3d3d3d3d

    3d3d3d3d Member

    Hi thanks for the link. But have already posted on that specific thread. My tablet is based on the gadmei e83d but nobody has advised if the same route method for the e8hd would work on other android tablets and if it would have to he the same firmware version.

    I dont know enough about rooting as to if using thay rooting method would just brick mine.
  6. jasmoelgato

    jasmoelgato New Member

    I also have a neo3do and after hours of trying to find how to root it I finally found a program called kingo root that worked. I used it on the 4.1.1 rom, interestingly it didn't wipe the device either. Once rooted I could uninstall the stock phereo and reinstall the new version off Google play.

    Hope this helps
  7. 3d3d3d3d

    3d3d3d3d Member

    Nice will have a look for kingo root. Have you tried overclocking it? Got the wife the new nexus 7 and performance is worlds apart if only we could have the nexus 7 performance and resolution with the 3d screen from neo3do.
  8. 3d3d3d3d

    3d3d3d3d Member

    Not having any luck with kingo, it says device not connected ensure debugging is enabled, which it is. Can only assume its a windows 7 android driver issue.
  9. jasmoelgato

    jasmoelgato New Member

    I'm sorry to hear it didn't work. It sounds like your computer is not recognizing the neo3do? Do you have the android adb drivers installed? I'm also using windows 7, but I have both the "android adb driver" and "google usb driver" installed previously for my other devices so perhaps those might help your computer recognize the neo3do.

    If you are looking to root the nexus 7 consider Wugfresh toolkit - pretty nice tool I used to root my Gnexus. It also walks you through installation of necessary drivers.

    For me the neo3do feels like a whole new device once rooted since I can now run adblock, autorun manager and uninstall some stock installed apps so that it runs much smoother. I was getting annoyed that I dropped $350 for it at first but now I"m pretty happy with it since it runs how I like. I haven't tried to overclock it since I don't play too many games or use cpu intensive programs much.

    Good luck

    FYI the other method I tried for my neo3do was oneclickroot - recognized the tablet but it couldn't root it.
  10. 3d3d3d3d

    3d3d3d3d Member

    Tried for hours on my desktop without sucess, 5 mins on the laptop and the neo3do was rooted. What adblocker are you using? When using autorun manager I can uninstall things like facebook but when I reboot gacebook remains. At least I can start to get the tablet how I want it.

    still looking for an overclock app that actually works on the neo3do.

    thanks jasmoelgato
  11. jasmoelgato

    jasmoelgato New Member

    I'm glad it worked! Hope this helps other NEO3DO owners as well.

    I use adaway by f-droid. You'll have to download the apk rather than through google play.

    Autorun manager can disable drivers of specific programs so they don't run in the background or at start up but it won't uninstall i believe. For that you need either root uninstaller or you and use link2sd (what i've been using) since both give you the ability to uninstall system apps. Just be careful you don't uninstall something that'll brick your phone. I uninstalled facebook from the system then reinstalled it as a user app.
  12. 3d3d3d3d

    3d3d3d3d Member

    Cheers removed all there unwanted apps now. Kingo definitely works for the neo3do.

    ive yet to find an overclock app that actually improves the speed. Been checking with antutu benchmark but scores haven't increased and havent noticed improvement during general use.
  13. 3d3d3d3d

    3d3d3d3d Member

    I can underclock but think the stock kernel may be stopping me overclock. This could be an issue that cant be resolved
Loading...

Share This Page