Geniatech Enjoy TV

Last Updated:

  1. interfreak

    interfreak Active Member

    Is someone going to post a video review? Would be great to see this device in action.

  2. szemo77

    szemo77 Well-Known Member

    Some old video for ATV1000 from the beginning of the year: (much has changed since then) Android TV - YouTube

    In short time Geniatech will releases Android v2.3 :D
    everst likes this.
  3. Dual_HD

    Dual_HD Well-Known Member

    Which version of firmware you are using now?
  4. HT1

    HT1 Member

    I have tried lots of their firmwares. The firmwares that have full market access are the worse with no catchup tv support. These have flash 10.2 Froyo built in which cannot be updated changed as I suspect that is the problem.
    I have also tried several versions of the standard firmware all of which can access catchup tv but are very jerky as to be unwatchable. I have also changed the browser setting from Ipad to desktop etc. with little to no affect. Geniatech have advised me that they are working on the problem and a new firmware will be released in the next few weeks.
    Interestingly they sent me a table of someone elses testing in Australia of different firmwares and settings for catchup tv so as I say they are geniune in trying to fix the problem.
  5. Dual_HD

    Dual_HD Well-Known Member

    Which catchup TV website you are testing with?
  6. HT1

    HT1 Member

    All australian.
    CH7, SBS, ABC Iview, CH10
  7. sstavross

    sstavross Member

    Well, did you tested it? Was it ok? Did it work?
  8. next121

    next121 Well-Known Member

    That's great news, hopefully they are working on some improvements to the media player UI too.

    Yes I gave it ago but wasn't practical, the spashtop app is suited to touch controls and doesn't work well with the remote, in addition there was very clear colour degradation on screen from compressing the video stream on Splashtops servers end.

    I've noticed also that Flash is trying to auto update itself to 10.3 but failing. You could probably manually replace/update it via Titanium backup if anyone is feeling brave enough.

    P.S. if anyone from Geniatech is reading this, port Geexbox (linux/XBMC distro that already runs on Arm SoC's) to your box and offer as an option to boot from SDCard or USB flash drive and it would be a very hot commodity.
  9. gio965

    gio965 Well-Known Member

    I have upgraded my ATV1000 with the new firmware released on 2011 09 09
    but I'm having only problems linked (I suppose) to the inbuilt presence of
    flash media player 10.2 not upgradeable to newest versions.
    Before this upgrade, videos were very fast (with FlashPlayer.v10.3.186.3) so I ask how and where can I find a firmware (older) that gives the possibility to install and upgrade flash media player, (I'm not able to enter in
    Thanks to everyone
    failla99 likes this.
  10. szemo77

    szemo77 Well-Known Member

    Hmm GeeXboX use BusyBox and Geniatech ATV boxes use Uboot bootloader. So first step is change the bootloader to BusyBox, then we can port :) ATV.
  11. gio965

    gio965 Well-Known Member

    Thanks szemo77, but if you could explain, step by step, what to do I will understand better
    ...I'm not expert
  12. HT1

    HT1 Member

    Follow the advice of next121 and use titanium backup. I was able to use this andremove the flash 10.2 and then install flash 10.3. Unfortunatley it made no difference to the catchup tv problem for me.
  13. szemo77

    szemo77 Well-Known Member

    To install the firmware you need the proper bootloader (starting program like Busybox, Uboot, etc. ...) like in open source routers. During the compilation of software you defined platform to operate and the default startup program (our bootloader).

    So Uboot (present on ATV1000 box) must have supportet image of GeeXboX firmware. On GeeXboX site i see that the have redy images for BusyBox only.
    So i don't :) want brick my ATV1000. I have only RS232 set for console.

    How ATV Box booting? Log from console:
    Code (Text):
    1. Firmware started, now starting u-boot...ucl decompress
    2. ready
    4. U-Boot 2010.06-V1.3.2
    5. DRAM:  xxx MiB
    6. NAND:  Amlogic nand flash uboot driver for m1, Version 1.0 (c) 2010 Amlogic Inc.
    7. NAND device id: xx xx xx xx xx xx
    8. NAND device: Manufacturer ID: 0xad, Chip ID: 0xad (Hynix B revision NAND 4GiB H27UBG8T2A)
    9. 1 NAND chips detected
    10. nand0 initialized ok
    11. SF: Got idcode c2 20 16
    12. SF: Detected M25X32 with sector size 4096, total 4194304 bytes
    14. SPI NOR Flash have write protect!!!
    15. In:    serial
    16. Out:   serial
    17. Err:   serial
    18. KGDB:  ready
    19. MMC:   SDIO Port A: 0
    20. Net:   select eth clk-1,source=400000000,out=50000000
    21. Apollo EMAC
    22. Dcache status 1
    23. Icache status 1
    25. get_adc_sample(4): 0x3ff
    26. get_adc_sample(4): 0x3ff
    27. get_adc_sample(4): 0x3ff
    28. get_key(): 0
    29. Normal Start...
    30. Hit any key to stop autoboot:  0
    31. Booting from nand ...
    33. NAND read: device 0 offset 0x800000, size 0x400000
    34.  4194304 bytes read: OK
    35. Wrong Image Format for bootm command
    36. ERROR: can't get kernel image!
    37. SF: Got idcode c2 20 16
    38. SF: Detected M25X32 with sector size 4096, total 4194304 bytes
    40. SPI NOR Flash have write protect!!!
    41. 4096 KiB M25X32 at 0:2 is now current device
    42. ## Booting kernel from Legacy Image at 82000000 ...
    43.    Image Name:   Linux-2.6.34
    44.    Image Type:   ARM Linux Kernel Image (lzma compressed)
    45.    Data Size:    1713388 Bytes = 1.6 MiB
    46.    Load Address: 80008000
    47.    Entry Point:  80008000
    48.    Verifying Checksum ... OK
    49.    Uncompressing Kernel Image ... OK
    50. Using machid 0xb8d from environment
    52. Starting kernel ...
    54. [    0.000000] Linux version 2.6.34 (steven@ubtsvr) (gcc version 4.4.1 (Sourcery G++ Lite 2010q1-202) ) V1.2.3 20110510.151351
    55. [    0.000000] CPU: ARMv7 Processor [411fc091] revision 1 (ARMv7), cr=10c53c7f
    56. [    0.000000] CPU: VIPT nonaliasing data cache, VIPT nonaliasing in
  14. gio965

    gio965 Well-Known Member

    All ok!! I have resolved installing a previous firmware released on 2011 08 04.
    This firmwware hasn't flash player inside, so I haven't had problem to install
    the newest version of flash player (v.
    I suggest everyone to install this release and test (for me it's ok) and then,
    for a 1080p HDMI output, I suggest also, to install Hdmiswitch.

    The link for this firmware is:
    (Unzipping file, you'll find two zipped file; the first,, is for firmware upgrade)
    Instead Flash player and Hdmiswitch can be find in:[link removed by moderator]

    Thank you szemo77 and HT1 for your advices
  15. next121

    next121 Well-Known Member

    It looks like Geniatech have blocked access to their website directory I cant see their downloads anymore or it just me ?
  16. gio965

    gio965 Well-Known Member

    It's the same for me, too. At this time we can't enter (I hope only temporarly),
    but if we know exact then we can download from it.
    More or less a week ago I could enter and I downloaded various files (not all files),
    and among these, fortunately, also file.
    A little trick could be, if they mantain the same format in, that of changing, progressively,
    the date (yyyymmdd) and try...try... more times (, for firmware upgrade).
  17. arun5555

    arun5555 New Member


    i want to buy this product, i want some clarifications

    1. it's play 1080p movies smoothly formats like mkv
    2. play you tube hd smoothly
    3. play online iptv smoothly.

    guys my english very bad,

    please reply i don't have knowledge in these players, please reply after ur answers, i put my order in asiapads.

  18. gio965

    gio965 Well-Known Member

    Hi arun5555, I have an ATV1000 (basic version of ATV2000) and quietly
    I watch 1080p MKV on external usb hardisk (using inbuilt videoplayer),
    I play youtube Hd videos and, as regard iptv, I use an application
    called TVUplayer, not in full version, that permits to watch hundreds iptv channels
    with interruption every two minutes (after subscription you should have vision without break),
    generally with a low, not hd, video resolution, (using other applications, surely, it will be possible
    watching channels with a higher video resolution).
    For playing hd videos from youtube and, generally speaking, for more correct internet browsing, is important
    changing web browser setting from: desktop (default) to: android.
    Obviously flash player and hdmiswitch must be installed, if not, you have to install them.
    I don't know other android tv devices, but I'm very enthusiast of this one.
    UPIcoBanni likes this.
  19. gio965

    gio965 Well-Known Member

    In the meantime, I have found other applications for iptv and live video streaming, that are:
    SpbTV, Tv Flash,, Ustream, StreamMediaPlayer and VPlayer.

    -SpbTv v.2.1 and TvFlash v0.9.96.2 are similar to TVUplayer (but without time restrictions or subscription)
    and they make us to watch many iptv channels (not in hd resolution)
    -Justin.tvPlayer v2.02 and Ustream v1.9.1 are applications that give the possibility to watch live cam
    and live transmissions from around the world
    -StreamMediaPlayer v3.2.3 and VPlayer v0.9.9 are media players with which is possible to play iptv and audio/video streams, inserting in URL search, a correct ip address (http, rtsp).
    I think that if you buy it, you will remain satisfied.
  20. Dual_HD

    Dual_HD Well-Known Member

    Comes from India, undertesting.
  21. gio965

    gio965 Well-Known Member

    I haven't already tested this application, but surely it should be interesting.
  22. szemo77

    szemo77 Well-Known Member

    If someone has a problem with market, or you do not see some applications use this is update:

    Procedure is the same as a regular update from SD card. Copy file to SD root, then from Setup-> Private take an update.

    Its a Market 1.82 package for Android 2.2 Amlogic AML8726-M platform. Tested sucessfull at ATV1000.

    :/ Adobe Flash 11 update crash, because its released for support Android 3.x
    I use now Flash v10.2.157.51 - no problem with use in apps.

    Newer versions require update 1.82 first.

    Next stable Market 2.2.1: (works perfect like 1.82)

    And new unstable Market 3.0.26: (not for use ;[ for me, search is broken)

    Other apps with automatic update form market was no problem.
    :D hehe i can say Flawless victory like in Mortal Combat.
    gio965 likes this.
  23. aussietaff

    aussietaff New Member

    Hi all, I hope that you will accept me in this thread, I have a neoniQ Android intelligent TV Box which is made by Geniatech and they have confirmed with me that it is the ATV1000 released for Australia.
    I have a problem that I would appreciate help with, I am trying to Update the Firmware. Geniatech have given me a link for the download, and that I should download it to my PC, then copy to an SD Card then rename the download to

    I should then disconnect the Power supply to the Box insert the SD Card, then press and keep the reset button pressed whilst connecting the power supply again to the box. This I have done numerous times, it scolls through the sequence and then the screen stops with the following error message :
    Finding Update Package
    Opening Update package
    Verifying Update package
    Failed to open / sdcard / (No such file or directory)
    E: Signature verification failed
    Finding update package
    E: can't mount / dev / block / sda1 (or / dev / block / sda
    (no such device)
    E: can't mount UDISK :
    system update aborted

    If anyone can help, I would be very gratefull, the lady at support at Geniatech is very good, but has not come up with the answer yet, so I am hoping that someone with an ATV1000 has the solution. many thanks.

  24. next121

    next121 Well-Known Member

    You don't need to do the power/reset button thing simply turning it on and having an SDCard with on it will cause it to flash the firmware.

    Re-format your SDCard as FAT32 and copy the zip file over to it then try again or try downloading the firmwares updates that were posted on the first page of this thread and flashing those instead.

    Post the link as well for what Geinatech gave for the firmware update as you cant download anything direct from their site anymore.
  25. gio965

    gio965 Well-Known Member

    If your device is an ATV1000 100%, then and (that you find inside this thread) must be installed easily, otherwise, this means that (probably) you need an australian version of the firmware.
    Before your upgrade, I suggest to note your actual firmware release (and, if possible, download it), because, even if you do factory reset you will not return to the original firmware but to the last installed.
    In this way, if you have not particular problems with your actual firmware, you can always return to it.

Share This Page