Geniatech Enjoy TV


Last Updated: 2015-01-13 21:39:04
  1. Fezinio

    Fezinio Member

    no im using the google remote or a usb mouse. how do i do that?

    thanks
  2. Barns

    Barns Member

    Hi all! First post here. I've read through the whole thread so apologise if these questions have already been answered, but I've not seen them laid out clearly in one place. Is there an up to date FAQ or Wiki or anything?

    I have got a "Smart TV Entertainment Box" on the way from Maplin (UK) - I believe this is an ATV2000? What's the first thing I should do after opening and checking it powers up?

    I'm thinking - what's the current best set of updates and fixes to apply and in which order, going from stock out-of-the-box. I'm pretty confident hacking about with stuff on command lines etc so all that doesn't scare me (running rooted CM7.2 phone and tablet).

    Also, what gotchas do I need to look out for? i.e. what stuff is known to not work properly (given the latest patching) or can cause trouble?

    Any hints or tips or must-have apps that work well on this unit? Suggested settings to configure? (I'll be connecting to a 40" 1080p Sony TV via HDMI).

    What I'm most looking for in the box is decent reliable playback of assorted video files, locally at first from a USB drive but later on streamed from a Win7 PC once I've got networking upgraded a bit - the existing 85Mbps Powerline stuff isn't really up to it, I find. I don't have a huge pile of uber 1080p BD rips or anything equally hardcore, just random SD recordings. That's not to say I won't push the rig more in the future.

    Do you get the standard Google Apps? Gmail, Maps, etc? I know sometimes on "unofficial" ROMs you need to hack them in later.
  3. stasik

    stasik Well-Known Member

    Fezinio, i know the right click is a pain in the ass, should be a separate button for "back". but the thing behind that is that the box is not a pc, so not too many options to be displayed, so they eliminated the right click. for options, use F1 on the remote. it will show the options/setting for that particular application, if any.

    Barns, i saw in malpins in ireland these boxez, they look like my atv2000 and the price is good, but are they original? will they work with Geniatech firmware? they could be clones... let us know.
    Fezinio likes this.
  4. wizard5

    wizard5 Member


    the boxs from maplins are the atv1000 oem black, i have updated mine to 21111228 and it works exellent. bbciplayer works for live tv but not for catchup(for me) itv player works at a avery very low framerate(for me ) hd streamed or local works exellent (mkv avi mp4).my box was already rooted
  5. Barns

    Barns Member

    Thanks wizard5 and stasik, glad to know it'll basically work ok for what I need with one update. IPlayer I'm not too worried about (can get that through my Freesat box). Can't wait to start messing with it!

    Is there a good way to perform a full device backup so I have a "clean" initial revision that I can go back to if I ever need to? (e.g. on my droid phone I have Clockworkmod installed that lets me take a full device backup).
  6. mickypogi

    mickypogi New Member

    Hello guys,

    I ordered a Smart TV Entertainment Box powered by Android from Maplin UK but I have not received it yet.

    Is there any of you here ordered the same from Maplin and had successfully upgraded the latest firmwares?

    If yes, would you mind to provide me the steps on how to do it? On Maplin's website, they have provided the SP1 and MArketplace downloads but im not yet sure if it is enought or if it is the latest firmware as i have not received the box yet.(http://www.maplin.co.uk/smart-tv-entertainment-box-powered-by-android-586939)


    Or could i just download the upgrade directly from Geniatechs website?

    Thanks so much in advance.
  7. graham688

    graham688 Member

    Hi
    I've upgrade my Maplin box fully into the 2812 version. First step was apply the upgrades on the Maplin website - that gives you a reasonable working unit. You can then apply appropriate updates and you'll find comprehensive instructions and links to the files earlier in this forum (page 13 I think - as an answer to my request for help on the same subject). I cannot get BBC iplayer or ITV player to work but I can stream almost any video format to the box from my NAS or PC.
  8. Fezinio

    Fezinio Member

    m8 how do you stream from NAS? im fairly good with IT and its got me scratching my head.

    I can see it when i look at the network but it wont show any files just the ip of the box
  9. stasik

    stasik Well-Known Member

    Fezinio, on previous page i explained how to stream/play from nas. it also was discussed earlier a few times. it would be advisable for every one to find 20 min and read through. u might be amazed how many useful tips u might find. let us know if it worked for u
  10. Fezinio

    Fezinio Member

    stasik,

    for your information i have read every post in this thread. I did this before i even made my first post. I also did actually see your explanation. And yes I have already got some great tips. If you find and READ my first post you will see this and I thanked everyone for it.

    For me it doesn't make sense and i haven't a clue what samba is, that's why i was hoping for some clarification and not for someone to get on their high horse thinking they are better than other posters.

    So thanks for your sarcastic comment but its not welcome.

    Can somebody else please explain how to access and play streams over the network in noddy terms? Like I said before I am actually competent in IT but am struggling with this problem.
  11. jimbobdog

    jimbobdog New Member

    I got one of these Maplin units and followed the upgrade on pg13 - worked a treat and the difference from the 2.2.5 that comes installed is utterly amazing - wired up to a 42" panel and it's superb!

    Overall it's a fantastic bit of kit for the money however there are a few problems/questions I have....

    1. Market Place, loads of the apps I want to install do not show up when I search for them, or if I search from a PC it says "none of your devices are compatible" and the install is blocked. I installed a locale setter app in case it thought the device was in the wrong country but that made no difference and I have checked that the app OS version is ok so anyone know why these can't be installed?

    2. WebCam - one of the attractions was having skype on it but no mic built into the unit, I tried a PC webcam (logitech) and nothing seemed to happen - maybe I need install some drivers? If there is a webcam that works with 2.3 on this device for Skype and anyone knows what it is then I'd love to know!

    3. ICS - will the Maplin/ATV1000 unit be suitable for ICS? I heard they will put it on the 512k/2000 units - can I install on this one?

    Cheers - great forum, those pg13 instructions are a godsend!

    /J
  12. stasik

    stasik Well-Known Member

    Fezinio, i am not trying to be sarcastic. i got help here, so now its my turn to offer help.
    ur question was "how to stream from nas" and not "what is nas".

    NAS =Network Attached Storage. i have a device (mine is like THIS but an older version), connect to my router via cable, and any computer from that network can access data ion NAS. so i download a movie to my pc from net, then upload it to nas, then with the box i stream from the nas, using SAMBA protocol. different NAS support different protocols. mine support samba, ftp and apple talk. with samba u can start watching the movie, and u dont have to download it firs (like with ftp). so once the movie is on nas, any PC from the network (including android box) can start watching the movie instantly.
    to get the box play/stream the movie from nas, u follow the steps described earlier. of course for that u need to have a NAS with samba protocol enabled and attached to network/router.
    sorry to sound sarcastic, did not try to offend u in any way.
    Fezinio likes this.
  13. Fezinio

    Fezinio Member

    Stasik,

    Thanks for your reply.

    I know what a NAS is I have two connected to my home Network (Neatgear Stora MS 2110)

    What I didn't know is what samba is and I'm still unsure. I can access my NAS from all my other peripherals including smart TV and media player. What I cant do is access my NAS with my ATV1000

    Thanks
  14. musogeek

    musogeek New Member

    I have the Maplin purchased device running fine with gingerbread update, only issue really being the catchup tv problems, can only get ITVplayer via the App, and I am not sure why but something keeps waking the box up, I do a power off and when I come home from work it is on again. Very odd! It is a great little device, and I have it accessing my local shares. If you have a cifs share then you can actually mount this to a folder location, which works really well when you have DVD folder rips on a shared drive, as you can use Daroon Player to stream them to your device. CifsManager is the app to use for this, but still working out if I can get it to mount them after a reboot automatically. Device reports as rooted, but not behaving as such. Only had it a few days though so I am sure I will work stuff out!!
  15. stasik

    stasik Well-Known Member

    what i do on mine, is transfer file with FTP protocol, coz its much faster (150%) but ftp is designed only for transfer, not streaming. samba protocol is designed for streaming/sharing, but less for transfer.
    the only thing what come to my mind, check ur nas manual and check the protocols supported. if samba (or smb) is not listed, most likely the box will not see the nas, coz it can stream only over samba (but i could be wrong). somebody reported success streaming over ftp, but its very complex. also check ur router setting, maybe the IP/mac of the box is blocked? maybe nas coul be blocking the box? maybe port forwarding? it all depends on ur system.
    but if ur smart tv can stream it, make shure the box is in the same sub-ip range, and doe not connect to network via router connected to router. what ip of the nas & box? what do u see when u press "network" on the box applications?
    post the IP of the box & nas, and if still no luck, u could try CifsManager, it will mount the nas folder and video player will think its local folder
  16. stasik

    stasik Well-Known Member

    musogeek, now what u mentioned it, i find my box ON some times. i thought my sister is using it and not turning it off)) yeah, CifsManager is a good application, but it wont start/mount on boot, coz u have to start the application first, which is fine coz its only few clicks to mount. u dont have to root ur box, it might have been rooted, so no need to worry.
  17. Barns

    Barns Member

    I thought it was only the DVB-T receiver that was different between the 1000 and 2000? Maplin certainly lists the unit as having 512Mb RAM. Would be a shame to miss out on an ICS upgrade :)
  18. jimbobdog

    jimbobdog New Member

    I found this webcam from Logitech for their Revue/Google TV - dunno if it will work and at $150 I'm not sure I wanna find out!

    http://www.logitech.com/en-us/smarttv/accessories/devices/7538
    http://www.bhphotovideo.com/c/product/775034-REG/Logitech_960_000665_TV_Cam_Webcam.html

    /J
  19. szemo77

    szemo77 Well-Known Member

  20. mickypogi

    mickypogi New Member

    Have finally managed to update the Smart TV box i purchased from Maplin!

    A very very thank you to Enviro8 for providing the detailed instructions on how to do this , as well as all of the guys here in the forum. You guys are great!

    Thanks again!
  21. everst

    everst Well-Known Member

    i have some http streams and im using it with mxvideo player but the only probelm is that every time i need too copy the stream in the player when i want to change the chanell ,is any chance to make a playlist for mxvideoplayer? i tried with moboplayer but the stream dosenot work with it.thx
  22. Dual_HD

    Dual_HD Well-Known Member

    It is a very good question, I have this question as well. any body can tell us?
  23. bryanspink

    bryanspink Member

    Got mine from Maplins today after a false start. I ordered a B-Grade model to save a few pounds. Ita rrived promptly but I noticed that all the promise apps were not there. I tried to do the upgrades and ended up with a box with no Android. Sent it back and received a NEW one today.
    First impressions (after doing the SP1 & Market updates) and a couple of hours tinkering :
    1) Market - New app only shows a very limited selection (The same as the original market app?) I've managed to install a few apps from backups taken on my phone.
    2) iPlayer - Won't play from web site and app seems to hang (Not tried the ITV one yet)
    3) YouTube - App crashes but videos play in browser
    4) Calendar -Any way of getting that to sync with my Google Calendar?

    Time to read back through the thread and see what the best update options are.
  24. Barns

    Barns Member

    Last night I updated my new Maplin-bought unit using the comprehensive instructions by Enviro8 (thanks!!) on page 13 of this thread and they worked fine as long as I was very careful to follow everything precisely. I now have a patched-up unit with working Market which seems to show the apps I'd expect. I've not had a chance yet to test much else but the other reports on this version sound promising.

    I'm looking forward to the ICS ROM which is (hopefully) materialising in Feb sometime?
  25. enviro8

    enviro8 Well-Known Member

    How to get the Latest Market App installed

    You need to download

    Root Check Basic – this will check to make sure the TV box is rooted – it does not root the TV box

    Root Explorer – this only works with a rooted TV box

    The latest Market App (vending.apk) from:

    xda-developers - View Single Post - [GUIDE] Install Full Android Market on Kindle Fire (Compilation Master Thread)

    The Market app is most likely stored in the TV box’s System folder and you need to have root access to manipulate it.

    Install and run Root Check Basic to make sure your box is rooted

    Copy the new vending.apk to your SD card and put it in the box.

    Install and run Root Explorer

    In the top left of Root Explorer make sure that it says “Mounted as r/w” if not click on the white box that says “Mount R/W”

    Scroll down to the “system” folder and open it.

    Scroll down to the “app” folder and open it, make sure that the folder is “mounted as r/w”

    Scroll down to “vending.apk” and long left mouse click on it.

    I recommend renaming it, although you are going to move it out of this folder, so you can store it on the SD card without overriding an app with the same name.

    After renaming it, long left click and click “move”

    Navigate back from the “app” folder through to the “system” folder to the “root”

    There you should see the “sdcard” folder just above the “system” folder

    Open the “sdcard” folder and paste your renamed file there

    In the “sdcard” folder, find and long click on the new “vending.apk” file and click on “copy”

    Move back out of the “sdcard” folder and to “system” -> “app” and paste it in the “app” folder

    Back all the way out to close down Root Explorer.

    Reboot the TV box and the new market will be there.

    If you do not like it simply reverse the process using the version you moved out earlier.



    This method can be used with FlashPlayer and others apps.

Share This Page