Geniatech Enjoy TV


  1. enviro8

    enviro8 Well-Known Member

    Yes you can.

    I did it sometime last year but did not particularly like it at the time and with subsequent system updates I lost it.

    I will try again this weekend
  2. enviro8

    enviro8 Well-Known Member

    I found what I did, but whether or not it is the "latest" Market Apk, I don't know, but if you find a newer one, the method should work with it.

    How to get the Latest Market App installed

    You need to download

    Root Check Basic
  3. elmes

    elmes Member

  4. retspan

    retspan New Member

    I would still be most interested to hear from anyone that actually has apps like facebook, youtube and angry birds showing in android market on a Gingerbread ATV1000 or 2000. If you do, please include as much information as possible (firmware and SPI version, settings, mods).

    Despite elaborate efforts that have seen me try several older versions of the market, and many different suggested fixes (changed primary google account, tried different lcd density settings, can't even remember how many times I cleared app data/cache and device cache), I'm having no luck. The apps do show in the browser version of the market, where they keep being reported as incompatible with the device and can't be installed.

    I can of course use the relevant apks, however for reasons that include re-saleability, I really would like the market to show (nearly) all apps...
  5. Maplinbox

    Maplinbox New Member

    I've been watching the thread for a while and would really like to try out the sky go app just launched, any ideas how to get it onto the atv2000? Got it on my iphone with mates sky codes but a bit small to see whats going on. I'm desperate to find a way of watching F1 without selling any major organs!
  6. bryanspink

    bryanspink Member

    I tried Sky Go on my HTC Desire and the only channel I could get to work was Sky News. The picture quality was awful. I haven't tried it on the Smart TV box but I wouldn't expect it to work.

    You can pick up F1 for free with a cheap sat box and a dish pointing at 19.2.
    I was expecting to have to do this util Sky said F1 would be free to HD subscribers. Only one downside - it will be in German but there's always commentary on 5Live.
  7. gio965

    gio965 Well-Known Member

    Hi retspan, in these days I have made various tests and I have noted that,
    particularly, there are two factors that make an android device compatible
    (or not) to an app from Android Market: permissions and fingerprint.

    Some firmwares have only few files in their "permissions" folder
    (in: /system/etc/permissions), others many more (update20120111.zip
    has only 14 files .xml).

    We must add permissions to our device to obtain more compatibility, so I decided to gather
    (from various firmwares) these .xml files, all in one folder that I named "full_permissions"
    and I reached 38 files.

    I haven't had time to test which of them, effectively, make the difference,
    but surely their presence doesn't give any problem for a correct working of
    our device.

    For adding these files, I suggest to use rootexplorer (on a rooted device) --->
    rename original folder "permissions", for example in "permissions_backup",
    ---> copy "full_permissions" in: /system/etc/---> rename it in "permissions" --->
    change its attributes in: rwxr-xr-x


    As regard fingerprint, I have tested many of them and, actually, the best
    is surely the HTC Thunderbolt one.

    Using rootexplorer, you must edit build.prop and change the original fingerprint:


    ro.build.fingerprint=MBX/stvm3/stvm3:2.3.4/20111212/20111212.163332:user/test-keys

    to:

    ro.build.fingerprint=verizon_wwe/htc_mecha/mecha:2.3.4/GRJ22/206244.9:user/release-keys

    (automatically, a backup copy of build.prop will be created)


    At this point, we must make working these changes:

    We must enter: Settings ---> Applications ---> Manage applications ---> All:

    click to: Google services framework ---> clear data ---> ok ---> Force stop (back)

    Click to: Market ---> Clear data & Clear cache ---> ok ---> Force stop (back to home page)

    We enter Market icon and a message of error will appear (an error has occurred - Please try again later),
    it's all right and we give "ok".

    Now we switch off device, we wait for few seconds and switch on.

    We enter Market again and probably (no fear, it's ok) a new message of error will appear, we click "ok"
    and try again to enter Market (generally after two errors, we have the TOS page, we give "accept" and
    a more complete Market will be ready for us. Enjoy it!!)

    Referring to everyone would try this method, I can say that I have never had problems
    and I'm not responsable for everything could happen (I suggest a previous backup of data and apps)

    In the next days I will realize a video guide to show, step by step, all passages.


    You can download "full_permissions" folder here:

    full_permissions.zip
    stasik and retspan like this.
  8. Maplinbox

    Maplinbox New Member

    That's good news Bryan, is it in the clear on RTL or similar do you know? I've still got an Aston analogue/digital reciever in the garage somewhere!

    Thanks
  9. everst

    everst Well-Known Member

    gio964 i folowed these steps i made it work and instaled an app ,is working
  10. vikidroid

    vikidroid Well-Known Member

    hello! me again.

    untill today, i didn't do anything. my KB is still dead, it will be sended back to store and service/replace.
    but, i have one more question, esspecially for NotOnlyTV owners-how amount of memory is shown in properties or some system info application, and which processor is reported? on official site stands A9, in web stores A8, mine shows A7. WTF?!?
    so, please, can you wrote me those infos.
    thanks in advance!
  11. cupi1234

    cupi1234 Active Member


    From Wikipedia:
    The ARM Cortex-A9 MPCore is a 32-bit multicore processor providing up to 4 cache-coherent Cortex-A9 cores, each implementing the ARM v7instruction set architecture.[
  12. gio965

    gio965 Well-Known Member

    ...ooops!!!:)
  13. gio965

    gio965 Well-Known Member

  14. vikidroid

    vikidroid Well-Known Member

    yes, i found also this. at the end, they're all based on ARMv7, but different speed and number of cores? ok, then, those apps like "android system info" shows architecture/base, but not real version od processor? i must say that i'm not very clear with this. it seems to me that for some apps, my lgp500 is quicker than this android box. of course, not with movies and multimedia.
  15. atters72

    atters72 New Member

    Update to latest BBC I player . Unistal flash 10.2 and download latest version and BBC it and 4od all now work ok
  16. meggiedude

    meggiedude Well-Known Member

    Hmm, you sure? and flash is OK and not sluggish??

    I thought others had tried this and it completely scr*wed Flash, as the version pre-installed on the box (which I thought was 10.3??) was specifically tweaked by/for Geniatech. That's why others here on this forum have not upgraded flash on the Geniatechs. Or if they have, have quickly backtracked.

    Can anyone else confirm these finding as I don't want to screw my (currently working) setup.

    MD
  17. atters72

    atters72 New Member

    The bbc iplayer app itself had a major update this week
  18. webcris77

    webcris77 Member

    Hi, atv200t with deb-t tuner support PVR features? i.e. timeshifting, recording, etc...pip?
  19. Harvey2000

    Harvey2000 Member

    If you upgrade to Flash 11 you'll get working iPlayer, 4OD and such goodies - BUT Flash 11 doesn't support the hardware video acceleration, resulting in about 10FPS if your lucky.
  20. meggiedude

    meggiedude Well-Known Member

    Thnaks, That was exactly what I was concerned about.
    I don't want to compromise general flash performance to get iplayer/4OD working after a fashion.
    We need something better from Geniatech to make this all work.

    I did email to their Support addy about flash and iPlayer, but got no response.

    cheers.

    MD
  21. Harvey2000

    Harvey2000 Member

    Keep at it, I got:
    With 10.2 attached. :mad:
  22. meggiedude

    meggiedude Well-Known Member

    Well I've tried again - this time via the on-line form - and marked FAO the tech support team.
    Geniatech.com Contact Form

    If a few of us ask then we have a better chance of things changing. Hint. :p
  23. ziczac

    ziczac Member



    I tried as your guide, but I couldn't access Internet anymore. So I restored the orginal permissions folder but I still get the Internet issue.
    Please help me to solve it.
  24. gio965

    gio965 Well-Known Member

    Hi ziczac, I don't know if in the meantime you solved... surely your problem is not due to permissions folder
    or fingerprint...(they can't give this kind of problem)
    but probably (even if in my video I was able to enter Market without issues, at first attempt),
    you need to try more times before you can have results.
    So, if you have (always) this message of error ("an error has occurred - Please try again later"), then
    you must reboot (every time) your device
    and try to enter Market (even once or twice more).
    If your problem is another...please, you should specify better.
    Let me know...
Loading...

Share This Page