Geniatech Enjoy TV


Last Updated: 2015-05-11 02:32:43
  1. atters72

    atters72 New Member

    I am running android version 2.3.4 kernel version 2.6.34 v1.3.0.33
    I have updated the google services framework and market using root explorer so that the market is on version 3.4.4 build and i can pretty much download any app from the market. Ive downloaded voodoo ota rootkeeper so that i can watch movies from market too ( so that it hides the root) . Whilst HD movies stutter normal ones dont and thats the same for bbci player , itv player 4od and the modified sky go app from xda. Perfectly acceptable watching on all of them. Apart from getting the box to play content from my external hard drive now Ive got it running pretty much as i'd wish.
    Before the iplayer and flash player updates this week i would have agreed with you that it was pointless as it was stuttering and not worth bothering with . But im well pleased with the performance now..

    Advertisement
    meggiedude likes this.
  2. meggiedude

    meggiedude Well-Known Member

    Interesting.
    I take it you got the instructions from here?
    http://androidforums.com/google-tv/442783-video-guides-tests-previews-geniatech-devices.html

    If not can you please point me in the right directions for what you have done.
    I guess I also need a link to the orig Geniatech version of Flash 10.2 (with the hardware support). That way I have a way to back out Flash 11 in case I am not happy with the results.
    Any help appreciated.

    MD.
  3. webcris77

    webcris77 Member


    I upgraded to beta ICS 4.0 my ATV2000 , after downgrade to 2.3.4 i lost the DVB application.
    I installed the latest 1.9.2 Hidtv but when i try to start i receive the USB dongle missing...my DVB-T is built-in. help me please!!!
  4. atters72

    atters72 New Member

    Yep you may have to reboot a few times and I had to clear cache but all worth it in the end.
  5. webcris77

    webcris77 Member

    Ciao Silvano, hai risolto? sono nel tuo stesso casino...
    Ho provato la 1.9.1 e 1.9.2 ma il mio atv2000 risponde che vuole dongle usb...
    cavolo che palle!
  6. enviro8

    enviro8 Well-Known Member

    When I updated to ICS, I got the same message.

    It appears that the HiDTV app is not yet compatible with ICS. We will have to wait until an update is released.
  7. webcris77

    webcris77 Member

    Hi, aftere the restore procedure to 2.3.4 i have missing hidtv app and if i install hodtv 1.9.2 i receive the same error messagge.
  8. meggiedude

    meggiedude Well-Known Member

    OK, I'll give it a go, but could do with a link to the Geniatech tweaked version of Flash 10.2 should I decide to back it out.
    If anyone has this link I'd appreciate it.

    Cheers
  9. enviro8

    enviro8 Well-Known Member

    If you have carried out the Geniatech updates you should already have the tweaked market installed and running on your TV box.

    To get a copy, all you need to do is to follow my post #984 and access it.

    Then copy it and save it to your SD card where it will be available to be reinstlled.
  10. retspan

    retspan New Member

    Thanks again for all your trouble gio! Unfortunately, while not having used this box at all for a few days, the market will now crash upon selection of an application in 3.4.4, provided I have your permissions folder present. If I uninstall the updates and try it with 3.3.11, or move back to the original permissions folder, then the crashes are gone. To my surprise the usual tricks to stop the market from updating, involving market-updater and/or vending-updater, no longer seem any use, as it turns out the market is now perfectly able to update itself without either of these even being present at all...

    Are you or is anyone else having the same issue?
  11. ziczac

    ziczac Member


    Hi gio965,

    I reset the firmware, everything is ok. And then I tried to update permission folder , build.pro as your guide again, I couldn't access internet from web, market. v.v app.
    I don't know reason why I got it.

    Thanks
  12. smokeydog1

    smokeydog1 New Member

    arrrhh ooops hi guys may of done a fail was following said guide here (nikking store)

    and were it says remove sd card immediatly i may have done it too soon now i have a green screen
    + blocks then it goes into update failed and sits there not wanting to regonise stuff any ideas? :S
  13. gio965

    gio965 Well-Known Member

    Hi retspan and ziczac, I can't give a certain answer but I can tell you that
    I decided to realise my two videoguides only when I was sure of my results and
    indeed I have never had problems.

    At this moment, I have a 2.2.5 release (update20110909) and if you have the latest 2.3.4
    (update20120111), probably, difference in firmware could be a reason of your issues.

    Is there any other user that (with latest firmware) has successfully updated to
    a complete Market, using permissions and/or fingerprint trick?

    Then indeed, it's right to say that, if permissions trick has been tested by me, only on a 2.2.5
    device...instead, fingerprint trick is a well-known method, tested by many android users
    on more different devices and firmware releases, so at least, this one should work quietly.

    I could suggest, as last solution (but in my opinion, it should be the first), a complete wipe
    and the reinstallation of firmware, so that you can be sure to have made "tabula rasa"
    (previously, you must take care to make a copy of your data and apps, using for example mybackup pro.apk),
    then you should try these tricks separately, so that, more easily, you can understand the wrong passage.

    Let me know (I hope positively)...
  14. enviro8

    enviro8 Well-Known Member

    I have something very similar and you now must perform a recovery by connecting it up to a PC and flashing it.

    I have not been successful.

    The reference sites are:

    KGDTeam • Ver Tema - Recovery por RS232 los Mygica ATV300 - ATV1000 - ATV2000

    Which is Spanish, and

    ICONBIT.RU • ???????? ???? - ?????????????? Toucan W ????? ????????? ????????

    which is Russian

    There are also some earlier posts on this thread that discuss the matter
  15. cajen

    cajen Member

    I also had a problem connecting to the internet after editing the build.prop. I was also using 2.2.5, but I did not follow your instructions exactly. Instead of editing the original build.prop, I copied the original and replaced it with an edited copy. I don't know if that made the difference or not.

    The only way I was able to restore internet access was to upgrade the system to 2.3.

    I also tried the permissions folder trick on both firmwares and had no problems, so it must be the build.prop trick that caused the internet problem.
  16. gio965

    gio965 Well-Known Member

    Hi cajen, regarding to your different procedure for fingerprint trick, I think that it's the same thing
    (in fact, you must consider that, even if in my video I edited original build.prop, instead during my trials
    I used an edited copy of it).
    In the next days I will update my firmware to latest release (20120111) and I will make my tests...
  17. gio965

    gio965 Well-Known Member

    Hi retspan, ziczac, cajen and everyone...
    I updated my firmware to latest 20120111 release and after various trials,
    I have found the solution for a correct upgrade of permissions folder and
    fingerprint, also on ATV1000 with 2.3.4 release.

    Pratically, using the same "permissions" folder and fingerprint line, we must
    follow a different procedure...

    First of all we must go to ---> Settings ---> Applications ---> Manage applications
    ---> All ---> GoogleServicesFramework ---> Clear data and Force stop (back) --->
    Market ---> Clear cache and Force stop ---> (back home)

    Then we enter Rootexplorer ---> go to: /mnt/sda/sda1 and copy "full_permissions" folder
    from pendrive (long press on left click) ---> go back to: /system/etc ---> click on "Mount R/W"
    ---> rename original "permissions" folder (for example to: permissions_backup) --->
    paste "full_permissions" and rename it to "permissions" ---> give same attributes of original folder
    ---> (back to the root)

    Now we edit build.prop and change original fingerprint line:

    so, we go to: /system ---> we open build.prop using text editor (long left click on file)
    ---> delete original fingerprint line:
    ro.build.fingerprint=MBX/stvm3/stvm3:2.3.4/20111212/20111212.163332:user/test-keys

    and insert new fingerprint line:
    ro.build.fingerprint=verizon_wwe/htc_mecha/mecha:2.3.4/GRJ22/206244.9:user/release-keys

    (automatically, a backup copy of build.prop will be created)

    Remaining in: /system ---> we enter "app" folder and (temporarily) uninstall GoogleServicesFramework.apk
    (we can do that renaming it, as for example, to: GoogleServicesFramework.apk1 ...if we check and go to:
    Settings ---> Applications ---> Manage applications ---> All
    we don't find the application)
    then rename again: GoogleServicesFramework.apk1 to GoogleServicesFramework.apk ---> (back home)
    (This last passage makes the difference and resolves all difficulties with internet connection)

    At this point, we reboot device, enter Market, insert our Google account and a more
    complete Market will be there for us!!
    So we will find missing apps like facebook, tweetdeck and more...

    Referring to everyone would try this method, I can say that I'm not responsable for everything could happen
    (I suggest a previous backup of data and apps)

    In the next days, I will make a video guide, to show visually all passages

    Edit:
    For more working apps, you must add this missing file: com.google.android.maps.jar
    to "framework" folder in: /system/framework and change its permissions to rw-r-r

    For more compatibility, I suggest to use this fingerprint line:
    ro.build.fingerprint=verizon_wwe/htc_mecha/mecha:2.3.4/GRJ22/206244.9:user/release-keys
    (if you have a 2.2 "froyo" firmware release)

    and this fingerprint line:
    ro.build.fingerprint=google/passion/passion:2.3.4/GRJ22/121341:user/release-keys
    (if you have a 2.3 "gingerbread" firmware release)

    More fingerprint lines here: Google Nexus One - OpenGL ES performance and system information
    (go to --> "Browse the GLBenchmark"--> choose your device --> (ok) --> "System Information" -->
    scroll down to --> "android.os.Build.Fingerprint" --> choose your fingerprint line to test)

    If your market release is 3.4.4 or superior, you must remove this file: android.hardware.nfc.xml
    from "permissions" folder in: /system/etc
    vikidroid likes this.
  18. meggiedude

    meggiedude Well-Known Member

    Thanks, but I was actually after a link to the original Geniatech tweaked FLASH 10.2 code, in-case I need to back out the flash 11 code.
    I'm prepared to give the Flash 11 upgrade a try, as per atters72 suggestions, but want a get-out-of-jail in case I am not happy with the results.
  19. cupi1234

    cupi1234 Active Member

    meggiedude likes this.
  20. leemitchell

    leemitchell New Member

    after all updates and firmware have been done,im still getting out of audio sync with the video...has anybody got any ideas what will fix this please....thanks
  21. miskol

    miskol New Member

    Anybody is able to compile kernel from amlogic sources for ATV1000 ?
    I want to compile own kernel but without success
  22. vikidroid

    vikidroid Well-Known Member

    gio, hi! one question. i bougjt another notonlytv android box. so far, all is going ok. but i have two questions. one-on my first box, i was able to connect it to pc monitor via DVI-hdmi cable, and that worked ok. now, with this new, i can only get picture via hdmi connector. is that ok or not.
    but, my second question matters more to me. i have tweetdeck on sd card, and when i try to install it i says "installation not completed-it is incompatible with device". will this "permissions fix" fix that incompatibility? i must say that i didnt try to searchit trough market, only direct access to .apk file.
    thanks!!

    EDIT:
    i done "permissions fix", i get FB, TW and other apps, but tweetdeck does'nt work. so, can anybody confirm that tweetdeck works or not (no matther before or after permissions fix).

    thanks!
  23. gio965

    gio965 Well-Known Member

    Hi vikidroid, regarding your first question, I can't give any answer because I have never tried
    to connect via DVI-HDMI cable...
    Instead, for your second question, I can confirm that if you add "full_permissions" folder
    (following my last videoguide), you will fix incompatibility with tweetdeck...:):)
  24. vikidroid

    vikidroid Well-Known Member

    hi gio!
    dvi - later. maybe somebody will know. i dont have monitor with both connectors, so i must look at pc in one room and second floor, and google box is downstaris on big lcd. so, i must run up and down. ;-)

    apropos tweetdeck. i done all as described in latest video. i changed that one row in video from yesterday - alternative procedure (LINK).
    but in first video with two procedures, in first You didn't change anything in system files (LINK).
    maybe that is problem? i get tweetdeck, it starts, i sign in my account (i use it on pc also), but than it crashes.
    any idea?
    thx!

    EDIT:
    tried with original and changed build.prop file still nothing. tweetdeck install ok, start ok, i enter my twiter data, press ok, and in that moment it crashes. android is 2.3.4, from "update20111102.zip", with no added applications and rooted from the beginning.

    for now, it seems that i must try with some other firmware, or wait for 4.x

Share This Page