Getting GPS to work using GPSCLRX (also, how to get your SPC code)!Support


  1. TRS-80

    TRS-80 Well-Known Member

    I have decided to make this it's own post, if it takes off and becomes useful, maybe it will end up getting stickied or something. Having it in it's own post will make that easier. The background info (and work up to this point) can be found in this post: http://androidforums.com/samsung-galaxy-indulge/359440-gps-taking-forever-find-your-location.html.

    That was so disappointing, not having the GPS functionality working on this phone, and it was a little frustrating trying to get it to work. Well, it took me some fumbling about and following various steps, but I finally got it to work right. So I kind of just wanted to put everything together into a simple, easy to follow step by step guide in hopes of helping out some others out there who may also be having these issues. So, here goes...

    TRS-80's Guide to Getting GPS to work on teh Samsung Galuxy Indulge!

    Background: I had first tried several GPS utilities (GPS Test, GPS Aids, GPS Status, GPS Essentials) to do various clearing of caches, clearing and re-downloading of GPS data, as well as clearing the cache of Google Maps itself, as well as other places on the phone, all to basically no avail. Something may have worked like one time, but I couldn't reproduce it (so I'll just throw it out as a fluke). Now I may very well have borked something just by messing with one or more of those apps and/or settings. So if you are in the same (or similar) boat, read on... Also, if we can narrow it down to which one of those apps may have killed the GPS in our phone, I suppose that would be good info to make note of here as well (please leave your thoughts on that below).

    The problem I was having, was after turning GPS on, and opening one of those utilities that shows how many satellites you are connected to, etc. was that it would always just sit there and say "0 satellites" and just do nothing. So I will tell you what I did that worked for me, and hopefully it will help others.

    All credit goes to tiede, ciper (and others?) who originally found all these individual bits out, I will only take credit for putting it all together into one place.

    So now, without further ado, the actual Guide...

    UPDATE 10/11/11 - Realize that you must be outside of buildings, in clear view of the sky, or your GPS will not work. Try this first (go outside) before performing any of the steps in this guide!

    UPDATE 9/14/2011 - First attempt just using the GPS Test app (see below) before using GPSCLRX. It's quick, easy and sometimes fixes the problem!


    1.Gather your materials. You will need the following things:

    A.One (or more) of the following apps:
    GPS Test
    GPS Aids
    GPS Status & Toolbox
    GPS Essentials
    These apps will allow you to see how many satellites are currently in view, as well as a bunch of other interesting info (altitude, speed, bearing, your actual coordinates, etc.). Besides using one of them for the procedure in this guide, I think they are just cool and very useful to have on the phone anyway (geocaching anyone?! :)). So far, after limited use, I like GPS Test and GPS Essentials. But try them all out for yourself.

    B.MEID Converter tool/app. You can find it here: MEID Converter.

    C.Your actual MEID number. You can get this from your phone a few different ways:
    1.By getting it off the box your phone came in.
    2.By removing the battery, and looking behind it on the little white sticker (Isn't it time for a battery pull anyway? That fixes all sorts of things! ;)).
    3.By going into "Settings->About phone->Status." Scroll down a little and it will say "IMEI." As noted earlier, ciper discovered this is not really your IMEI, but rather your MEID.
    4.Whichever of the three methods you follow, the number you are looking for is a 14 digit number, mine began with "990000" and I imagine that most (all?) Indulges should also (not sure on that point however...).

    2.Now, convert your MEID to your SPC. Using the MEID Converter tool, enter your MEID and it will spit out your SPC (Service Programming Code). This a number that will be based on your MEID and therefore unique to your phone. It can be used for this guide, as well as accessing other hidden menus and all sorts of neat things. Make a note of the SPC code. The MEID Converter app actually saves your MEID and SPC code for future reference, which is very handy.

    Note: If you are using physical (slide out) keyboard, screen will be in horizontal/landscape view and only show the first 4 lines of results (long hex and decimal conversions of the MEID), and not the 6th line containing the all important SPC code (and you cannot scroll down). Enter your MEID in vertical/portrait mode using the soft (touch screen) keyboard to avoid this issue. Also, be careful not to tilt the screen to vertical, doing so will clear the info and you will have to enter it again (or just look up result under "View Past Calculations").

    The number you are looking for will actually say "MetroPCS SPC: XXXXXX" (mine was a 6 digit number).

    3.Using your phone dialer, enter ##GPSCLRX# <-Those are phone dialer "letters" on the soft phone touch keypad; in other words, press the phone number keys "##4772579#". A window will pop up and ask you for your SPC code. Enter it. The screen turns black and it says something about "GPS will be reset" (iirc). Now I don't know if it resets the GPS instantly, or if it takes a little while, so I waited a little bit just to be on the safe side before hitting back to exit out.

    Now at this point, I was all excited, I thought I had really done something! lol But trying to turn on Maps or Nav, and do anything, I got the same old nothing. :( So I figured, well maybe I need to reboot, so...

    4.Reboot your phone. Now I don't remember if things started working correctly for me at this point or not, but at some point I did one more step...

    5.Open one of the GPS utilities listed above, and have a look at your constellation of satellites. Now I don't know why this works, but for me it seems to. Please let me know your results as well (and I will update this guide accordingly).

    Before, when I would turn GPS on, and then go into one of these utilities, nothing would happen. Nothing at all, just sit there, 0 satellites, etc... But now, after doing this GPSCLRX (and rebooting), as soon as I open up one of those bad boys it starts a goin... 2, 3, then 9, 12 satellites! And I mean like lickety-split! Awesome! Then when I open something that needs GPS, bang, immediate lock on! Suhweet! That's all you have to do! Your done!

    The above steps should only need to be done ONCE. The steps below are to be done each time you need to use GPS.

    Now, one thing I have noticed, is that if you just go straight into Maps or Nav, it takes a lot longer to get a lock (maybe forever? I dunno, I never wait that long). Now this may be because I keep GPS off all the time, and just turn it on when I need it. Maybe if you keep it on all the time you won't need to do this. But if you are like me, and believe in keeping GPS off, follow the following procedure whenever you need GPS (in my case, mostly for Nav):

    1.Turn on GPS. The method doesn't seem to matter, I use the notification shade toggle.
    2.Open one of the GPS utilities (I use GPS Test) and look at your constellation of GPS satellites, they will all start popping up like crazy right away. Wait until you see about 9-12 satellites (this took only a few seconds for me, please let me know your results).
    3.Exit out of your GPS utility.
    4.Now open your Nav, or Maps, or whatever you need and you should have nearly immediate lock.

    A side note: I think that when using Places, or Maps, usually getting your location off the cell tower is close enough to find a nearby "chinese restaurant" for example. I pretty much only fire up the GPS when I need to use it like an actual GPS, i.e. for Navigation.

    Well, that's it! I hope this guide is helpful to someone. Please let me know if it worked for you or not! Also please feel free to point out errors and omissions below and I will fix them. And if this works for a lot of people, then start pointing/linking others with GPS issues to this post. I will try and keep it updated over time.

    Advertisement
    :
  2. dsrtegl

    dsrtegl Active Member

    Thanks TRS. This worked for me, at least initially. I'll post later on to tell you if this consistently works to fix the complete unreliability of this device's GPS.
  3. TRS-80

    TRS-80 Well-Known Member

    Cool beans, glad to hear it! T3XAN tried it in IRC as well, said it worked for him too. So far, 2/2 (3/3 including myself), keep the feedback coming everybody!

    You should only need to do those top steps once, after that just follow the second set of steps at the bottom each time you need to use GPS (I also added that back into the OP for clarification).

    But then again, I only did this earlier today myself, so we shall see how it goes over time...
  4. facecook

    facecook Member

    Will try when I get home.
    But this was all done with the pull down standalone gps and not the google location services one?

    Also, is there a reason why one would be better than the other one?
  5. T3XAN

    T3XAN Well-Known Member


    Standalone GPS uses actual satellites (usually anywhere from 8-12 satellites) to route you getting you within a meter or so of your location.

    You can also download different navigation apps and use downloaded maps with GPS instead of having to relly on Metro's spotty nationwide service.

    Google Location Service uses cell towers (usually 3) to route you hence not getting you as perfect a location but usually close enough.
  6. dsrtegl

    dsrtegl Active Member

    UPDATE: 3 days in and my GPS is still working. I agree with you that firing up a GPS utility app first increases your odds of getting a lock, doesn't seem to make sense but it does.

    To clarify, I do not have WiFi on and am getting a pure satellite lock, just like I'm supposed to.
  7. Supanovah

    Supanovah Member

    TRS-80 thanks for posting this. I had one question though....what do you have checked in the "Location and Security" options?

    Do we suppose to check STANDALONE GPS SERVICES and/or GOOGLE LOCATION SERVICES?

    Well I guess the "standalone gps services" automatically checks itself when you turn on the GPS via the gray notification slide menu at the top of the phone. So then I guess the question is do we check the Google Location Services?

    Thanks for posting this tutorial bro!
  8. tiede

    tiede Well-Known Member

    Google location services is for the "a" part of our aGPS phone. The a stands for assisted, and with google location services/wifi on, a rough estimate of the location is sent along with the location query, thereby narrowing the range of the search, which in turn decrease satellite lock time.
  9. dsrtegl

    dsrtegl Active Member

    I've been running with the Google Location Services off in order to make sure the satellite portion of my GPS is working properly.

    I used it extensively today on a trip to San Juan Capistrano.

    It ran pretty well. It lost satellite lock once on the trip, and Google Navigation force-closed one time, but a quick re-launch and it was back in business. Of course, it happened just as I was getting off the freeway right when I needed it most. :-/
  10. tiede

    tiede Well-Known Member

    Yeah. that happens a lot. it's called the "adventure mode"feature,i believe... And it's always going to be somewhere you've never been before!

    But yeah, google's location service helps the gps, but it's NOT required.
  11. mightyboosh

    mightyboosh Member

    didnt seem to work for me =( maybe its because i uninstalled the metro navigator app =(? or maybe because im using the $50 monthly plan? idk
  12. TRS-80

    TRS-80 Well-Known Member

    I always leave "Google location services" checked (all the time, whether I am using Nav or not). A lot of times, I think this gets you "close enough" if you are searching for a nearby "chinese restaurant" for example. I only turn on "Standalone GPS services" when I am getting ready to use Navigation, or when Google can't seem to find my location. I'm pretty sure "Standalone" is the checkmark that is checked when you use the GPS toggle in the pull down notification shade.

    Another update: After using this method for a little while, I'm not sure that the GPS utilities help it to get lock faster or not. But personally, I like to see feedback whether something is happening or not. That's why I like to open one of the GPS utilities and watch it go from 0 to 2, 3, then up to 8 satellites (or whatever), when it gets lock. Sometimes this happens immediately, sometimes it takes like 30 seconds. But if nothing ever happens, then you know something is wrong. Then, after I get lock, I close the GPS utility and open Nav, Maps or whatever and bang there's that little blue triangle, right on target! Personally, I think that is better than opening Maps or Nav and just looking at the larger blue circle thing for 30 seconds and not knowing whether it is doing anything or not...
  13. TRS-80

    TRS-80 Well-Known Member

    Hmm. Did you give it some time? Sometimes it can take like 30 seconds to find satellites (use one of the utilities I mentioned, I like GPS Test, to see how many satellites are "in view"). If no satellites pop up after a minute or two, something is probably wrong.

    I am on the $50 plan as well, so that shouldn't be it. I don't use Metro Navigator, what is that? Are you talking about Google Navigation that comes with the phone? It's a blue triangle logo and is called simply "Navigation." I don't see Metro Navigator on my phone. I have removed bloatware, and after some checking I don't recognize Metro Navigator as any of those that were removed either. This may be your problem? Need more info.
  14. nps531

    nps531 Well-Known Member

    i downloaded the one metro makes and it works fine i have a problem with my gps working to the point i bought a gps off someone that was getting rid of one for a good deal (magellian) but the metronavigtor works just fine
  15. SwervFusion

    SwervFusion Member

    Metro Navigator is available in Metro's App Store for free. It's not installed on the phone by default, you have to install it manually. I only used Google's Navigation once, but I assume it's the same exact concept .. voice turn-by-turn directions with a map.
  16. tiede

    tiede Well-Known Member

    Navigation is better... If GPS works.
    Metro's relies primary on Metro towers, and therefore YMMV!

    Also, the graphics, and UI interactions are WAAAY better with Navigation then with MetroNavigator...
  17. Phil42

    Phil42 Well-Known Member

    If you are in landscape mode you can click past calculations. The SPC will be the six digit number at the right hand side of the table.
  18. pcguru2000

    pcguru2000 Member

    Turn off Google location service. It worked for me. The second I turned it off, the satellites started coming up. I then switched to navigation and within 5 seconds it found my location.
  19. TRS-80

    TRS-80 Well-Known Member

    This is sort of what I was thinking tiede. I haven't used Metro's Navigation, but I can only assume it is "based on" or at least uses the same Google Maps data maybe? And I couldn't imagine the UI or implementation would be better than Google's.

    The Google apps and tight integration with other Google services should be one of the main reasons for buying an Android phone. I guess I just don't understand why anyone would even try something put out by Metro, when you have the "real thing" (Google Navigation) preinstalled on the phone already?
  20. TRS-80

    TRS-80 Well-Known Member

    Again, I don't know if the GPS Utility is sort of "prodding" the phone to seek satellites or not, but at least you can see that something is happening. Feedback is a Good Thing. :)
  21. Phil42

    Phil42 Well-Known Member

    While this method worked for me, it is by no means permanent. I've had to reset the GPS a couple of times and it's especially annoying if I'm the car and have to look up the SPC.
  22. Joshuah22a

    Joshuah22a Well-Known Member

    it hasn't worked for me! ugh...i did everything here and it's 0 in use and 1 in view..but nothing else..
  23. Joshuah22a

    Joshuah22a Well-Known Member

    ok im having an issue...well i tried the above method and it reset the gps..nothing happen still the same thing..looked on the box and it had a different number for the meid..then i noticed i replace my phone so it shouldv'e worked the first time...im going to try again and see if it works..
  24. Joshuah22a

    Joshuah22a Well-Known Member

    WOW! holy crap well it did work..for some reason when im in my house it won't get signal but AS SOON as i steped one foot forward over the canopy it went from 2-10 IMMEDIATELY and it locked in! I can't never express how much thanks i owe to this forum! and a special thanks to you TRS-80!
  25. TRS-80

    TRS-80 Well-Known Member

    Awesome man, glad to hear it!

    Feel free to hit that "Thanks" button on the OP. ;)

    "Will work for Thanks." :D
Loading...

Share This Page