Gingerbread broke SMSSupport


Last Updated: 2013-01-22 19:04:50
  1. jezcooke

    jezcooke Member

    After being happy to finally get the Gingerbread update I've now found out that it's broken the sending of SMS messages, they'll fail every time with 'message not sent' if packet data is enabled, disable packet data and they go through fine. This is the same on both mine and my wife's phone and with either the stock Messaging app or Handcent.

    Model: Samsung Galaxy Ace GT-S5830
    Firmware: 2.3.3 (CPW) - Official through Kies.
    Network: T-mobile UK

    I can find several references to the issue online but none with any sort of conclusion as to the cause and fix (best I could find was a convoluted method that involved automatically disabling packet data when in the messaging app - novel but not an acceptable solution).

    Does anyone know how to fix this properly? I don't want to do a factory reset unless it's a definite fix as it'll take ages to set everything up again.

    Advertisement
  2. jezcooke

    jezcooke Member

    Just a bit more info I found it works when connected to the 2G network even with packet data enabled (GPRS) so it seems that it's just when connected to the 3G network with packet data enabled that it doesn't work.
  3. GrahamF

    GrahamF Well-Known Member

    Hi, sorry to hear you have this problem. I can't offer a solution, but it seems this is a common error, I believe Vodafone & Virgin have withdrawn their GB updates for now until they can resolve it. So only solution is a "fix" from T-mobile I guess. Regarding the factory reset & re-installing everything, I understand there is a built-in "backup & restore" option in Froyo 2.2/GB 2.3, but I haven't been able to find out exactly how it works. Can anybody shed any light on that please?? Thanx. GrahamF. London (on 02). :confused:
  4. gingerheart

    gingerheart Member

    Thats very strange , i,m on 02 , got 2.3.3 update through kies and have 3g and packet data enabled and am having no problem sending or recieving sms txt messages.
  5. jezcooke

    jezcooke Member

    What firmware CSC do you have (e.g. O2U = O2 UK, XEU = generic UK, CPW = Carphone Warehouse etc). Wonder if it's down to the firmware edition or the network provider.
  6. gingerheart

    gingerheart Member

    It was generic uk xeu
  7. jezcooke

    jezcooke Member

    Ah yes should have recognised your username form the other thread. I get the impression that CPW is much the same as XEU (no visible difference and the update came at exactly the same time) wonder if it's a network (T-mobile) issue then.
  8. gingerheart

    gingerheart Member

    Could well be a provider issue , would be nice if any one else on other networks in the UK could say if their having problems or not to narrow it down if it is that , but like i said no problems for me on 02.
  9. gingerheart

    gingerheart Member

    Ok , done some checking around on other sites , samfirmware etc and is seems quite a few are having your problem after the update and it looks like you need to get back apn settings from provider , remember this isn,t me telling you what to do just passing information from what i,ve read on other sites :) , hope this helps.
  10. jezcooke

    jezcooke Member

    Thanks, do you have a link to the info, I couldn't find anything on samfirmware? I did use the T-mobile website to send the settings to the phone before posting this thread just in case but no joy, I just checked the APN settings manually and they seem to match those listed on T-mobile's site.
  11. ns77

    ns77 New Member

    I have the same problem since update,the phone is direct from CPW.using a virgin sim card in it,i've found if my phone is connected to my home wifi it sends & recieves ok,just wondering if i should flash it using the pre release version of 2.3.3 using odin
  12. Gammer

    Gammer Well-Known Member

    I posted about this problem a few months back. I'm with Virgin UK and have this problem. I did flash back to froyo but decided to go with GB again and put up with this.
    It's not an apn issue as mine match,still can't find a fix for this though but I have put a widget switch on my homescreen to turn my packet data off with ease.
  13. jezcooke

    jezcooke Member

    Still no fix here either, yes being connected to WiFi fixes it as being on WiFi disables packet data (also why I didn't spot the problem immediately) at least the SOD issue seems to be fixed so I can leave WiFi on permanently.

    I didn't install a widget to workaround as there's the option to disable packet data when you hold down the power button, I think that's quicker than using a widget as I can do it without leaving the SMS app. Of course we shouldn't have to workaround it at all, let's hope 2.3.4 isn't far off and fixes this (preferably without breaking something else in the process!).
  14. ns77

    ns77 New Member

    Has anyone that installed S5830XWKPN or any other pre release got the same problem,just hope the guys at cyanogen get the version for the ACE rolled out soon.:mad:
  15. Chrisff60

    Chrisff60 Member

    Must say this is a big fail on Samsung's part! It takes them the better part of a year to come out with an upgrade, and when they finally do, it's got more problems than it had to start with! I can't connect to my wifi, sms sending and receiving and even phone calls, the basic function of a phone is sporadic! Have half a mind of selling the Ace and buying a Nexus. Turning out to be one smartphone that is not smart at all, after the update that is. Two thumbs way down.
  16. pixie78

    pixie78 Member

    Hi

    I am on Orange and i have have been having the same problems with messaging. Orange didnt know anything about it when i phoned them this morning.

    it works ok when i have 3g switched off too. I hope there is a fix soon as i have been waiting for gingerbread!!

    the build number i have is gingerbread.XWKPN (XEU)

    no problems with using wifi........yet!!
  17. johnboy2410

    johnboy2410 Member

    yup, ive also got the same problem. virgin network and cpw model, upgrade to gingerbread and txts wont send while data is on. turn it off an no problem at all.

    anyone knows of an update, please post it here
  18. Gammer

    Gammer Well-Known Member

    Have you called virgin and told them? I did this awhile back to make them aware of the problem although it's happening on other carriers.

    This needs a major fix asap.
  19. crazyinweston

    crazyinweston New Member

    hi im on orange got phone from phones4u and im currently using august build xwkpt 2.3.3

    i had the same problem with a may build xxkph 2.3.4 but now on xwkpt i have to turn off wifi and 2g and 3g and packet data and its just a horrible mess

    went to a later build of 2.3.3 thinking it would solve it but alas it hasnt

    i have no idea what CSC im using though
  20. AFX77UK

    AFX77UK Member

    Same problem here - on Orange and downloaded 2.3.4 the other day and now I can't seem to reply to text messages unless I reply by creating a new message.
  21. z80dan

    z80dan New Member

    Orange have posted this on their site....

    "Handsets that currently have Android Gingerbread installed on the device may be having problems sending SMS (Text) messages.
    This issue has been highlighted and Samsung are currently working on a resolution which should be available next week (02/10/2011)
    As a temporary fix you can follow the below instructions to change your handset from 3G to 2G only which will allow you to send text messages"

    So - fingers crossed!
  22. Frank01709

    Frank01709 Member

    Good news for you. I just got an update through Kies and it has solved the problem :D
  23. jacklow_23

    jacklow_23 New Member

    Me also got the update via KIES...

    But SMS still cannot be send when 3G is active
  24. Frank01709

    Frank01709 Member

    That is strange, mine never fails now.
    Check it has updated correctly, my firmware version is now

    PDA:KPY/PHONE:KPA/CSC:KP1 (XEU)
  25. jacklow_23

    jacklow_23 New Member

    Mine is S5830DXKPD

Share This Page