Gingerbread WiFi QuestionSupport


Last Updated:

  1. nalden

    nalden New Member

    Hello everyone,
    First time posting, so let me know if I leave out any important information.

    First things first: I have a Motorola Bionic, Android version 2.3.4

    Recently (past few months), I have been unable to connect to the Wi-fi at work. I thought this was odd because I previously had no problem, and many of my co-workers are able to connect with their iPhones and BlackBerries (very few have droids, they don't know what they're missing). In addition, I am able to connect everywhere else I've tried.

    That being said, I contacted my IT department regarding the issue and they informed me that I would not be able to connect to the Wi-Fi here without Android version 4.x.

    That doesn't really make a whole lot of sense to me.. Is there something new with Ice Cream Sandwich Wi-Fi (security feature? connectivity... thing?) that would explain why I would need to upgrade - which isn't an option yet :( - in order to use the Wi-Fi?

    Thanks!

    Advertisement
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    Welcome aboard! Have you tried updating your baseband? It requires a little bit of work but can help with wifi connections (I know it does with my Nexus).
    If you don't mind, I'm going to move this to the Motorola Bionic section. There's some great folks over there who can help you out.
  3. x026092

    x026092 Well-Known Member

    Seems odd since ICS is on so few devices... It sounds like a security feature, but I have not heard of a ICS WiFi security feature.... especially since the current OS can handle all the existng wifi security modes. Can you get more info from the IT staff?
  4. Thom

    Thom Guides Guide

    ... yes ... it seems a little ... how should I put this ... odd.

    What version of the system are you running? Go to ...
    Menu | Settings | About phoneand look at System version

    ... Thom
  5. doogald

    doogald Guides Guide

    As somebody who once managed an IT department, let me just say that sometimes staff members, much to my annoyance and chagrin, said things to users that weren't necessarily true, (though it was generally out of ignorance.)

    So, ask the IT folks very politely if they will tell you what exact feature(s) that Android 4.0 added that are required for connectivity? Or, precisely, what exact technology/feature is Gingerbread missing that prevents connectivity?

    It may be that they are using WPA2 enterprise, rather than WPA2 PSK (pre-shared key). I've never tried connecting using WPA2 enterprise, but I understand that it can be done with some non-ICS Android phones. Anyway, if you can find out what exactly the issue preventing connection is, that may help figure out a next-step try.
    Thom likes this.
  6. Thom

    Thom Guides Guide

    ... or they changed the Password a few months ago and never told him?

    ... Thom
  7. x026092

    x026092 Well-Known Member


    I am currently using WPA2 EAP with my Bionic.
    Correction: I am using 802.1x EAP with PEAP EAP method.
  8. doogald

    doogald Guides Guide

    That would have nothing to do with an ICS requirement, though.
  9. Thom

    Thom Guides Guide

    Agreed.

    I was also going under the premise that as you said ... "... let me just say that sometimes staff members, much to my annoyance and chagrin, said things to users that weren't necessarily true, (though it was generally out of ignorance.)".

    It would not surprise me in the least to find that it is something VERY simple.

    ... Thom
  10. nalden

    nalden New Member

    Hey everyone,
    Thanks for all the replies! I just sent an email to my IT department asking about specifics, they usually respond pretty quickly, so I should have an update soon.

    Dreadnatty08, how do I go about updating the baseband? My current version is CDMA_N_4.07.00R LTEDC_U_07.1F.00

    As for my system version, Thom, it's 5.9.902.XT875

    The way we access the WiFi is just by typing in the username\password (so I think EAP PEAP?), but it's possible that changed. Hopefully, I'll know more soon.

    Thanks again, everyone!
  11. Thom

    Thom Guides Guide

    Could you tell us the kind of company? If it is too spooky they may have invested in a third-party add-on and perhaps that add-on was written for 4.0 and never checked out for 2.x or 3.0.

    ... Thom
  12. nalden

    nalden New Member

    Alright, I just heard back from the IT department. Turns out it was as doogald suspected; our company uses WPA2 Enterprise which they said is only accessible in Android 4.0+. Then they asked me why I didn't just upgrade to 4.0 T_T

    I'm a bit of a WiFi noobie... Is the ability to connect to WPA2 Enterprise a hardware thing, or is it just software not built into gingerbread?
  13. Thom

    Thom Guides Guide

    I haven't played with it either. I goggled "WPA2 Enterprise android" and there is a nice article at ... Connect Android to a WPA2 Enterprise Wireless Network | NickEscobedo.com ... on how to set it up. The article does not identify the version of android being used.

    Wow ... typing at the same time ...

    ... Thom
  14. doogald

    doogald Guides Guide

    I also found this at the Motorola forums: https://forums.motorola.com/posts/90de5e9ea2

    Perhaps with this and bringing brownies or cupcakes down to IT you'll get somebody to use one of these documents to try a connection with your phone...

    Good luck!
  15. nalden

    nalden New Member

    Those links look promising. Thanks everyone for your help! :D

Share This Page