glsurfaceview onDrawFrame rate?


Last Updated:

  1. JustFrozen

    JustFrozen Well-Known Member This Topic's Starter

    Joined:
    Apr 13, 2010
    Messages:
    111
    Likes Received:
    22
    I've got a problem where onDrawFrame is called only a few times per second, even if there's nothing but logging inside the function. The same is true for every android opengl example I've run. It's basically impossible to make anything run smooth enough

    Am I doing something wrong, or is the simulator just really this slow?

    edit: after some more tinkering it turns out i'm getting 6-7 fps. still seems crazy slow though. i've read other people complaining about the simulator being 5x slower than a device. is this true or should i be getting closer to 60fps when rendering barely anything?

    edit2: i've noticed i go from 20-30 fps to 8fps when enabling GL_TEXTURE_2D. that doesnt sound right. how can enabling texture mapping drop my framerate so bad? i'm only rendering two quads right now
     

    Advertisement
  2. antialiasing

    antialiasing New Member

    Joined:
    Sep 15, 2010
    Messages:
    1
    Likes Received:
    0
    Hi, i seem to be having the same issue---do you now have a solution to this problem? Thanks.
     
  3. jonbonazza

    jonbonazza Well-Known Member

    Joined:
    Jul 13, 2010
    Messages:
    1,934
    Likes Received:
    458
    You MUST test applications using OpenGL on an actual device... The emulator will not do anything involving OpenGL correctly...
     

Share This Page

Loading...