Gmail app doesn't delete emailsSupport


  1. mpetruzz

    mpetruzz Active Member

    I'm still new at this android thing. I've had an iphone for the past year. The problem I'm having is this, when I delete an email from my Gmail app it still shows up when i log into gmail via my laptop.

    I've let it sync and still nothing. When I used to delete an email on my iphone it would come off instantly.

    Is there a setting I'm missing?? Is there another mail app I should use that will do that for me??

    Advertisement
    :
  2. gloriousnumber1

    gloriousnumber1 Well-Known Member

    I delete and then sync my gmail account, and all that does it add it back from my computer to my phone, so it looks like I'm in the same boat!
  3. TheXFactor

    TheXFactor Well-Known Member

    Are you looking at all mail or the inbox? Do you have the proper sync boxes checked on the phone? I know for a fact when you delete an email on the phone, all it does is change the label in gmail. The deleted email will no longer show in the inbox, but will still show in all mail folder. It's a stupid gmail thing.
  4. mpetruzz

    mpetruzz Active Member

    I think I figured it out. When you go into contacts and sync I needed to create a gmail account to sync it too. The only one i had was a google account that was syncing.

    I added it and that's working fine.
  5. mpetruzz

    mpetruzz Active Member

    Ok maybe I spoke too soon. So when i went into accounts and sync I noticed that there was a google account but not a gmail account. So I created a new account under gmail. I now have a google account to sync and a gmail account. Now when i get an email I get a notification but when I open it, eventhough it shows a gmail icon, it is opening the default mail app and not gmail.

    I am friggin confused!
  6. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    When you click on the google account there should be a gmail entry inside, check the settings there. (there should be a gmail, contacts, calendar, etc in there)
    You should open the stock mail app, delete the gmail account... Then open app drawer and find the native gmail app (pre-installed on every android phone) and see if that is the one you have been using.....
  7. mpetruzz

    mpetruzz Active Member

    Ok, I went into accounts and sync and see google. I click on that and see instant upload, google+, contacts, gmail, picasa and calendar. The only ones I have checked are gmail and calendar since I don't use anything else.

    Do I need to have auto-sync checked?? Currently it is not, could that be the problem?? I had turned it off because i was told it would conserve battery.

    I do have the gmail app installed and have been using that.

    On my iphone is turned off push and had it set to fetch email every hour. How can I configure my phone that way?
  8. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    you would need auto-sync turned on for it to work correctly..

    if you want gmail to only come every hour then uncheck it from the google entry, add a new account as a pop3/imap account (not as gmail). This will funnel it through the stock mail app....
  9. mpetruzz

    mpetruzz Active Member

    I checked auto sync and it seems to be working fine.

    The only reason I turned off auto sync was to save battery. Does it really save that much??

    So if i create the new account with the settings you said to make it fetch, will i still get my email in the gmail app or will it go to the stock??
  10. TheXFactor

    TheXFactor Well-Known Member

    See, if you had read my post you would have been all good.:)
Loading...

Share This Page