Gmail app: What are the "sync label" options?Tips


Last Updated:

  1. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    Ok, I don't get this Gmail app. It doesn't seem to sync properly with my Gmail account. First off, sometimes the main screen will show "Inbox (1)" or whatever number to indicate I have email, but there are no emails when I tap "Inbox" (but there *are* emails on the website, so they are really in my inbox).

    This may also be related to the label syncing options. I have them all set to "sync all" because I assume this means it will keep everything synced no matter how old it is, and if you specify a number of days, then it just syncs as far back as that many days. But this seems to cause a problem too, in that sometimes I have email on the website, but the phone isn't detecting it.

    Finally, both times I've tried to send an email, it won't work. The email ends up as "sending" in the Outbox, but never gets sent. And yes there is a data connection. I see no reason why it shouldn't send immediately.

    Hope someone can help. I didn't expect the Gmail app, of all things, to be so problematic on an Android phone!
     

    Advertisement
  2. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    Please, someone explain this to me. I just got another email on the website, but my phone didn't detect it. I don't understand why but I know this whole "label sync" business has something to do with it.
     
  3. drexappeal

    drexappeal Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    10,781
    Likes Received:
    3,118
    Just for clarity sake, do you only have 1 gmail account set up?
     
  4. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    Yes I do.
     
  5. drexappeal

    drexappeal Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    10,781
    Likes Received:
    3,118
    For the Auto-advance setting, do you have it set for conversation list? If so, are you sure that one of the "new emails" that shows up next to the Inbox as unread isn't part of a conversation threaded email? Sometimes, that happened to me where I thought I had selected the email that I hadn't read in a threaded email.

    Have you tried removing the account and then adding it again?
     
  6. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    No, that's not the problem. However I just changed "sync all" to "sync 7 days" and now it seems to work again! But the emails that show up go back farther than 7 days, so I have no idea what this sync option does.

    But now the notification icons don't show in the top bar when I have new email! :(
     
  7. drexappeal

    drexappeal Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    10,781
    Likes Received:
    3,118
    Hmmm...Sorry I can't be of much help. Best I could tell you is how I have my Labels sync'd and mine works just fine.

    I have Number of days to sync set to 4 days (I think this was the default). Mind you, I can still see emails that are way past 4 days old.

    Inbox, Starred, Sent Labels set to Sync All. The rest of the sub labels I don't have set to sync because I just transfer emails into those inboxes and don't have emails automatically transferred into them.
     
  8. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    When I have my Inbox, Starred, and Sent labels set to Sync All, it just doesn't seem to work. I wish I understood what this setting even meant. And apparently it's affecting my notification icon too, because I have that set just as it was yesterday when it worked, but now an icon doesn't show up when I have new mail.
     
  9. drexappeal

    drexappeal Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    10,781
    Likes Received:
    3,118
    I was never able to get a notification number on the stock gmail icon (from EVO release day). That's when someone posted the Gmail Unread Widget app that's available through the market for free! I downloaded that and it worked perfectly for what I needed.

    I'm not sure if this is what you're looking for, but just to explain what that does, it acts as a widget (smallest widget possible, just like putting an app on one of your homescreens). Everytime I get an email or multiple emails (for 2 of my gmail accounts), the widget works similar to the stock mail app (which I have connected to another one of my email accounts) where it shows the number of unread messages.
     
  10. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    No, I don't need a number, it's just that the notification wasn't working *at all*, but now suddenly it works again today! The Gmail app is seriously confusing me. I wish someone could explain what this label syncing really means and why it's causing all these issues.
     
  11. drexappeal

    drexappeal Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    10,781
    Likes Received:
    3,118
    Okay, I just experienced what you were saying about there being 1 email showing as "unread" even though there are no emails in the inbox that are unread.

    For me, it was definitely what I had mentioned earlier about threaded emails (coming from the same sender about the same subject). Thing is, even after clicking every email open from that same sender, it still showed "unread."

    Originally, I had moved these emails to one of my labels (while using my PC), so it wasn't in my Inbox anymore. When another email came in from the same sender and same subject, it moved back into my Inbox. This is what I did for it to go away.

    1) Went into that Gmail account on my phone
    2) Checkmarked the box next to the threaded message that was showing as "unread" (I verified which one it was by checking my gmail account online).
    3) Once the pop-up comes up on the bottom of the phone, I clicked Labels
    4) This email thread (about 5 emails total with the same subject and sender) was indicated having Inbox as a label and the label that I had moved the thread into
    5) Unchecked Inbox as one of the labels.

    Once I did that, the "unread" indicator went away. Now, I know this doesn't completely answer your questions about what the "label sync" does on the phone, but just wanted to share what I did to make that unread mail indicator go away.
     
  12. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    Hmm, that's strange. It doesn't quite sound like the same thing as mine, since it was multiple emails showing as unread in All Mail, but not appearing in the Inbox. But again, this only happened when I had the labels set to "Sync all," so changing it back to "Sync X days" fixed the problem, I just wish I knew *why* it fixed it. :)
     
  13. drexappeal

    drexappeal Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    10,781
    Likes Received:
    3,118
    You and me both...LOL.
     
  14. grohiit

    grohiit New Member

    Joined:
    Nov 15, 2010
    Messages:
    3
    Likes Received:
    0
    I have the same problem as well. Could someone tell me how to change the setting from Sync all to sync x days? I don't seem to find it.
     
  15. grohiit

    grohiit New Member

    Joined:
    Nov 15, 2010
    Messages:
    3
    Likes Received:
    0
    I tried to use the technique of removing the account and gmail says if I want to remove the account, the phone should be restored to factory defaults and I loose all my personal data. I wonder if I would loose "all" my data, including contacts list etc. If someone removed and added the account, please advice.
     
  16. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    Go to the Gmail settings and choose "Labels"
     
  17. grohiit

    grohiit New Member

    Joined:
    Nov 15, 2010
    Messages:
    3
    Likes Received:
    0
    Hi John,

    I did a factory reset on my phone and the notifications came back. I think there was a problem since I played around with the sync options. It may work for you as well.

    Regards,
    Rohit
     
  18. JohnJSal

    JohnJSal Well-Known Member This Topic's Starter

    Joined:
    Jun 17, 2010
    Messages:
    894
    Likes Received:
    61
    Everything's fine now (without a reset) but only because I put it back to a certain number of days. "Sync all" just seems to mess it up.
     

Share This Page

Loading...