Gmail App won't sync second account


  1. uofmrob

    uofmrob Member

    Hi Everyone,
    Recently, my workplace has switched over to Google Apps. Previously, I was running my personal email through the Gmail App and my work email through exchange in the Android Email app. Now that it's switched over, I'm running both accounts through my Gmail app. They are both Google Apps accounts, one for my personal domain and one for my work domain. The personal domain account is the main account on the phone that's tied to the Google Play store and such. That account is auto syncing just fine and I'm notified of emails nearly instantly. However, the second account just will not auto sync. If I force a manual sync, it's fine, but once I've done that, it will go on forever without autosyncing again. I've gone through all of the suggestions that I've been able to find for this problem. This is what I've tried so far (with all possible combinations of this that I could think of):

    Clearing the Gmail App Data
    Removing the secondary work account and reloading it
    Cycling autosync and the individual toggles for Gmail under the actual accounts
    Disabling autosync for the personal account
    Rebooting the phone in combination with the above steps
    I've freed up memory on the phone (it's got 140 MB free out of the 500 MB of internal storage and typically 180 MB of free RAM)
    Turning off 2-step verification for the work account

    Here are the details of the phone OS and such:
    Samsung Conquer 4G
    Rooted with a slightly customized ROM, but pretty much stock Android 2.3.6
    Slightly customized with UOT Kitchen
    Gmail version 2.3.6

    Any possible suggestions other than flashing the ROM or using a different ROM would be greatly appreciated. If it comes to that, I might do that, but I would really just like to get it working without having to start all over again. I don't really care about the personal account notification as I leave that off anyway, but the work account is pretty important. Any help would be greatly appreciated!
    Thanks,
    Rob

    Advertisement
    :
  2. uofmrob

    uofmrob Member

    Some additional information:

    I just tried to add another standard Gmail account and the behavior is the same. Also, I checked all of the Gmail and Google account settings for both and they seem to be the same. I'ave also tried to change which labels are synced to no avail.
  3. uofmrob

    uofmrob Member

    Another update. I would still like to get this working natively, but I came across a solution of using Tasker and the plugin Synker to schedule a force sync. That seems to be working.
  4. k3vin 71

    k3vin 71 Member

    Try "clear data" in settings/apps
  5. uofmrob

    uofmrob Member

    As mentioned above, I have cleared the Gmail app data. I've even cleared the app data, removed the second account, and restarted the device to no avail.
  6. Crashdamage

    Crashdamage Well-Known Member

    Try a newer version of the Gmail app. 2.3.6 is very old, the current version is 4.2.1.

    Linux user #266351. Android since v1.0
  7. uofmrob

    uofmrob Member

    2.3.6 is the latest version for Gingerbread. 4.x is only available for ICS and higher.
Loading...

Share This Page