Gmail contacts showing up in messagingSupport


  1. Firebrand

    Firebrand New Member

    Hello all!

    I have this little but annoying problem with my new Gio (upgraded to 2.3.4):
    I keep all my contacts as gmail contacts. Some emergency contacts on SIM card, but I don't use nor need them on a daily basis; no contacts as "phone contacts". From about 1000+ contacts only 120 are people with phone numbers, and they are all grouped in separate group called "Android". All the rest are just e-mails collected during all the years with gmail.

    Now, I want only the people from this group "Android" to appear in my contact list. To achieve this:
    - in contacts -> display options -> select contacts to display -> google -> I've chcecked only the box next to the "Android" group; all other boxes are unchecked;
    - in contacts -> display options -> I've checked the box next to the "display only contacts with phone numbers" option.

    And in Contacts everything works fine. I only see people from the "Android" group with phone numbers on the list. All other hundreds of people remain hidden.

    But this doesn't work for Messaging. When I try to write an SMS, after I start typing the name of the recipient, I still get the whole list of contacts from all groups: Android, other groups, and "Other contacts" - generic group for all contacts that are not part of any other group. I also get the contacts without phone numbers.

    I can't see any specific display settings for Messaging app, and I expected it to behave exactly as the Contacts list, but surprisingly - it's not.

    I've also made a little test - exported all contacts from all other groups to csv (as a backup) and deleted them from gmail. Now I only have this 120 contacts in Adroid group, and both Contacts and Messaging app are showing correctly only this list. Then I've manually added a single test contact in "Other contacts" group: "John Example" with only e-mail: "test@test.com".
    This single contact didn't appear in Contact list on my phone, but it appeared in Messaging app.

    This is quite an annoying thing, as every time I want to send an sms, I need to dig through a bunch of useless e-mail-only contacts just to get to the right person's phone number. Do you know how to make this work fine?

    I've read posts describing similar problems, but suggested solutions were mainly "clean up your gmail contacts" and "create separate group for your phone contacts". I've done that, but still nothing. Please help!

    Advertisement
  2. katyjean57

    katyjean57 New Member

    I had same prob. There's a bug with the initial load up. The solution is to manually delette... easier by selecting all then uncheck the keepers. For new users... at initial log in and sync, DO NOT SYNC Contacts. You can sync later if you wish and then they will be put in seperate folder with display options. Good luck.

Share This Page