Gmail crashes on syncSupport


  1. tw012

    tw012 Member

    Hi,

    Running pretty much stock everything on my Bionic, and over the last couple of days, Gmail force closes whenever it tries to sync my email. As a result, the only way I can tell if I've probably received email is if I happen to check my phone and see that nasty "force close" dialog box.

    Manual, automatic, doesn't matter, after a minute or so of syncing, Gmail force closes and will occasionally do it when I'm just looking at my inbox. I've tried clearing Gmail's app data, I've tried uninstalling/reinstalling the Gmail app updates, I've tried re-adding my account, and finally I did a factory reset, (didn't have much in the way of customization invested in this phone, no big deal).

    Any suggestions on how to fix this? Thanks.

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Log into GMail on a computer and see if there is some very large attachment that your phone is trying to download.

    Other options might be to see if there is a message that has a lot of non-standard characters (extended ASCII characters, for example) or that is in a different language.

    If you find any of those, move that particular email to a different folder that you do not have set up to sync, and then try synchronizing again on your phone.
  3. tw012

    tw012 Member

    Thanks for the response.

    Just tried that, and I'm afraid that didn't help.

    Do you know anything else I can try? I've got a warranty on the handset so I guess I could try and swap it out if nothing helps, but this seems like something that should be fixable.

    Thanks again.
  4. BestInGalaxy

    BestInGalaxy Well-Known Member

    Same problem here, except syncing isn't an issue, it's when I'm trying to set a notification ringtone. Wonder if anyone else is having the same problem.
  5. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    So, there is no issue with your GMail account? Try loading GMail in the web browser and see what happens...
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Since this really is not the same issue (his is sync, yours is not) could you make a new post so that this thread does not get confusing with replies to 2 different issues?
  7. tw012

    tw012 Member

    That is correct, my Gmail account itself is fine. Logs in perfectly on a PC, no odd messages that might freak out the Android app; the issue is definitely an issue on my phone.
  8. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Did you check all folders that it tries to sync? Not just you inbox, just things like the Spam folder, Sentbox, etc...?
  9. tw012

    tw012 Member

    Yeah, I checked those as well. There's nothing that can I see in my account that could possibly be causing this issue.
  10. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    OK, let's go back to basics - are you rooted? Since you already mentioned performing a factory reset, I'm guessing you're not rooted, but still...a factory reset only resets data, nothing else.

    Also, are you on 3G, 4G, or WiFi?
  11. tw012

    tw012 Member

    As I mentioned in my first post, I'm running totally stock. Unrooted, and the issue occurs on 3G, 4G, and WiFi, tested them before I came into work this morning.

    The problem happens whenever I get a new message or manually start a sync, so I am pretty sure the problem is with the Gmail or sync programs. Specifically, the force close message says "The application Gmail (process com.google.android.gm) has stopped unexpectedly. Please try again."

    Happens EVERY time sync is started by a new message or manually by me.
  12. doogald

    doogald Guides Guide

    If you are getting Gmail FCs, before you do something as drastic as a factory reset, I'd try this:

    - from home, settings->applications->manage applications
    - Gmail should be in the "Downloaded" tab. (If not, it will be in the "All" tab.) Scroll down to it and tap it.
    - Try tapping "clear cache". Go back and se if you can get into Gmail now.
    - If clear cache does not help, try "clear data". This will wipe all of gmail and settings off the phone, so you'll have to go back in, wait for it to sync again, and change any settings you may have made before (i.e., labels to sync, notifications, etc.)

    See if that fixes it.
  13. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Hmmm. Totally stock, no customizations since you did ht factory reset, and yet it does it on all types of connections. No apps installed, nothing, straight OOB, right? you said pretty much, so let's go the whole nine yards and make it completely stock, and only add your Google account, and nothing else, and then try to sync.

    Mind going into Settings --> About phone and telling me what version you have under System version? Just the part up to XT... is fine....

    After this, I'm probably going to tell you again to perform a factory reset to test it again - but I really, really *REALLY* think this is an odd issue.
  14. tw012

    tw012 Member

    Yeah, I've got ONLY my Gmail account added. It is totally OOB, stock, however you want to describe it.

    System Version: 5.5.886.XT875.Verizon.en.US

    If your next suggestion is to do another factory reset, I'm not going to bother. When I finished my last reset, first and only thing I did was add just my Gmail account to test it, and the error still persisted. It only happens with email messages; tried sending a message from my school email account to my Gmail address, and sure enough a few minutes later the Gmail app crashed.
  15. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    it sounds like a connection issue then. I've got 3 different GMail accounts set up in my GMail app and none are having issues at all.

    Since you're at 100% stock right now, do you have a second Gmail account that you can add? If you do, turn off sync for the first account and then add the second account and let it sync.

    If you don't, I have a throw away Gmail account that I created for the fun of it that we can try with and see if it works or not.

    Let me know.
  16. tw012

    tw012 Member

    Yeah, I added a second Gmail account, sent a few dummy messages to it, same issue.

    As for a connection issue, that doesn't make much sense considering everything else is working normally. Facebook, app downloads, web browsing, etc etc.

    I may just go drop by my Verizon office once I'm off work and see what they can do.
  17. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Might be a good idea - but when you added a second account, did you disable sync on the first account? If it is account specific, as long as sync is enabled, even if you're only in the second account, it will try to check the first account too.

    Also, did you check on the computer if, when composing messages, if they're actually being delivered? if they are being delivered, then it's not the sending of messages itself causing the issue, it's the subsequent check for new messages 8after* sending that is causing the issue.

    And if that is the case (that this is account specific), I suggest making a new 'folder' in GMail via your PC (GMail calls them labels, but essentially, they act as folders) and then moving everything in your inbox to that folder (temporarily - you'll move it back later). try syncing your phone. if it still happens, manually clean out your spam folder from a PC (link is at the top - empty spam, I think it says) and try again. If it still happens, make a new folder and move all your sent items stuff to a new folder, and then try again.

    If after all this it is still doing it, then something gone screwy with your phone - you could try using the FXZ file to restore to stock (just in case it is an app issue as opposed to a connection issue and / or specific account issue) or, you could take it in to VZW and let them fool with it. Your choice.
  18. tw012

    tw012 Member

    Well son of a gun, I never thought to disable sync on the main account.

    Just disabled it and re-added my secondary, and sure enough it works perfectly. I guess it's time to try cleaning out my main account, though frankly I have no idea what it could be; I deleted/removed from my synced folder anything from the last week (the problem started Saturday).

    I'll post again if I manage to get my main working again. Thanks!

    Edit: I should note that I have cleaned out my spam folder earlier, as well.
  19. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Yah, let us know where it was coming from - You might also check the Gmail app itself, for that particular account, and see if it is trying to sync some weird folder or whatever, OOB - it shouldn't, but since we can now pick which folders to sync, it may have automatically picked a folder that is, say, full pics, and be trying to sync, only to time out every time....
  20. tw012

    tw012 Member

    Just tried your suggestion and moved EVERYTHING, and I do mean everything, to an "old" folder that isn't set to sync. Checking the Gmail app, it's only set to sync my Inbox, and nothing else. Even with an empty inbox and no other folder set to sync, it still force closes. If I disable that account and enable my secondary, sure enough the force closes stop.

    This is really bizarre. I'm relatively new to the Android modding/hacking thing, so could you point me to this FXZ thing you're talking about? I figure I might as well give it a try if it's feasible.
  21. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    My signature has the links.

    Better yet, though, read this post: http://androidforums.com/bionic-all...ngs-root-guide-updated-9-26-11-a.html#restore and use the manual method. It explains it in detail.

    READ THIS FIRST::: However, since the application is not doing it with your other account, there nothing wrong with the application, and thus your system - it only happens on this one account, so there is something wrong with the account - and thus a restore is not really going to hep in this case.

    However, this might - since you have the sync disabled for your main account, now go into the settings -- Applications --> Gmail and clear the cache for the Gmail app, then reboot and try manually syncing your main account.
    tw012 likes this.
  22. tw012

    tw012 Member

    That makes sense.

    Anyway, I didn't have any cache data to clear, but with sync turned off, I cleared out the app data, and now everything seems to be back in working order. I guess leaving sync enabled on the last few clearing attempts kept something ugly from being deleted.

    You have saved me from a trip to Verizon, (at least until I try in vain to sweet talk them into letting me pick up a Galaxy Nexus or Droid RAZR at a reasonable off-contract price [lol]).

    Thanks a lot!
  23. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Glad you got it all worked out. Enjoy!
    tw012 likes this.
  24. karanberry

    karanberry New Member

    I have the exact same problem and I hope this forum will hep me resolve it since I have tried without success over the last week.

    I have a rooted HTC desire with MIUI GB Rom. Everything worked fine till a week back the gmail app suddenly stopped syncing and has been since then stuck on the "waiting to sync" page - "Your email will appear shortly". When i manually sync it, the app force closes. Even if i go into "accounts and sync" and uncheck and re-check auto-sync, the app force closes.

    Googling this issue showed that tons of other folks have had this issue but I haven't found a solution. I've literally tried everything (i think):

    Manual sync, uncheck and recheck auto sync, phone reboot, removing battery, uninstalling updates, uninstalling the app itself via Titanium backup and reinstalling via market, clearing cache and data of gmail app, clearing cache+dalvik from recovery, full wipe and reinstall of rom, factory reset and trying different rom, upgrading to Nikez lente ICS rom...

    The issue happens only with my account and not other accounts i sync.

    I just moved ALL my inbox mail to a new unsynced label but it did not help. I deleted a lot of my mail and also changed IMAP settings to sync nothing but the inbox which is now empty...but no success.

    EDIT: Oh and the proposed solution of deleting data/cache has not helped either

    Help!
    Karan
  25. Thom

    Thom Premium Guide Member Guide

Share This Page