Gmail Not Deleting... fresh rom problem???


Last Updated:

  1. wonthanhguy

    wonthanhguy Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    18
    Likes Received:
    0
    I've checked the other threads and it doesn't seem to be the same problem as mine.... so here goes.

    Everytime I receive an email, I delete it. When I delete one email... it'll show the inbox with the number ZERO in between parenthesis. Then 1 more email comes in.... the paranthesis number is 2. Delete the email that is actually new, and the new parenthesis is 1. Receive one more email... it'll show up as 3.

    Basically, the ones i deleted aren't deleted on google's server, but they won't show up again in my phone inbox- only in the "unread" counter. And no... it doesn't go away after a few minutes when gmail syncs.

    Do I really have to get onto a computer to clear the "unread" count??

    I am running fresh .7.
     

    Advertisement
  2. nick325i

    nick325i Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    491
    Likes Received:
    189
    Are you using the HTC Mail app or the Gmail app ?
     
  3. wonthanhguy

    wonthanhguy Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    18
    Likes Received:
    0
    Gmail app. I would use the htc mail app, but it seems as though gmail mail receives it faster.

    That and... gmail seems to be built in. No point in using HTC mail because it'll have to sync too. Wasting more battery and memory by syncing through gmail and htc mail.
     
  4. nick325i

    nick325i Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    491
    Likes Received:
    189
    Ok, that is what i wanted to confirm. If you were using the mail app from HTC i could see how this is a problem.

    Can you check your gmail account settings from a computer and make sure under the "Forwarding and POP/IMAP" section that you have IMAP enabled?
     
  5. wonthanhguy

    wonthanhguy Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    18
    Likes Received:
    0
    It's enabled of course. I don't know for sure, but I don't think I'd get emails if it wasn't enabled.
     
  6. nick325i

    nick325i Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    491
    Likes Received:
    189
    You get e-mails just the same if its disabled. I just tested it :p
     
  7. wonthanhguy

    wonthanhguy Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    18
    Likes Received:
    0
    o okay. Well i still can't figure out this problem. And it's really bugging me.
     
  8. rockcrawler

    rockcrawler Well-Known Member

    Joined:
    Oct 13, 2009
    Messages:
    110
    Likes Received:
    2
    I am having the exact same issue. it started after the MR. I have had it on a stock rooted setup as well as with Fresh .7. Would also love to figure this out, It's diving me nuts!!
     
  9. nick325i

    nick325i Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    491
    Likes Received:
    189
    I'm running the .6 fresh rom and not having that problem at all. I wonder if there is some other app that is conflicting for you guys.. or if it is something .7 related. Have you talked to flipz yet over at XDA about it ?
     
  10. wonthanhguy

    wonthanhguy Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    18
    Likes Received:
    0
    No, haven't talked to him yet.

    Funny... now my phone mailbox says (-4) due to some mixups because of facebook mail notifications on comments
     
  11. looneylu

    looneylu Well-Known Member

    Joined:
    Jan 5, 2010
    Messages:
    67
    Likes Received:
    1
    Did you ever find a fix to this problem? I am having the same issue?
     
  12. aversusb

    aversusb Member

    Joined:
    Feb 24, 2010
    Messages:
    24
    Likes Received:
    0
    I had the same issue yesterday.

    FIX:

    1) MENU<SETTINGS<APPLICATIONS<MANAGE APPLICATION

    What you are looking for is GMAIL and GMAIL STORAGE. If you don't see GMAIL STORAGE hit MENU<FILTER<ALL

    clear the cache on both of these. Then go back to home. THEN:

    2) MNEU<SETTINGS<DATA SYNC<GOOGLE<MENU<SYNC NOW

    That should fix the issue. A reboot wouldn't hurt either.
     
  13. looneylu

    looneylu Well-Known Member

    Joined:
    Jan 5, 2010
    Messages:
    67
    Likes Received:
    1
    Thanks, worked great!!!!
     

Share This Page

Loading...