GMail Notification Issue (slow/delayed sync and/or notification)Support

Last Updated:

  1. Kevin C

    Kevin C Well-Known Member

    Hoping someone can help me.
    I am sitting at home in front of my computer.
    My old EVO (still connected via Wifi) buzzes, about the same time my PC pops up with a GMail notification of a new email.
    My LTE never notifies me of a new email.
    Now I am looking at my email and realize that my GMail has not synced since sometime this morning (when I did not have Wifi access - was on 3G)
    Thought this was happening yesterday as well, but got tired last night and gave up trying to figure it out.

  2. PattiCakeUS

    PattiCakeUS Well-Known Member

    When you go into your gmail account on your phone, there's an option under Settings called "Notification Settings". That allows you to pick the notification sound and turn on notification vibrate. Are either of those turned on?
  3. Kevin C

    Kevin C Well-Known Member

    Yes, it works sometimes and other times it does not.
    I am testing by sending emails from my yahoo account on my pc to my gmail
  4. Kevin C

    Kevin C Well-Known Member

    In my Gmail--> Settings --> Select my account --> The checkbox for Email notifications is checked and it is set to ring and vibrate
  5. PattiCakeUS

    PattiCakeUS Well-Known Member

    That's odd if it's working intermittently. You can also check under the regular Settings for your phone - Settings -> Sound -> General - there you can turn vibration on and off for calls and notifications (General is the name of the section on the Sound menu).
  6. Kevin C

    Kevin C Well-Known Member

    I just sent a new message and it rang and vibrated.
    Then I sent another and no notification and the second one is not showing on my phone
  7. Kevin C

    Kevin C Well-Known Member

    It seems to me that it is not actually staying synced continuously...
  8. kevindroid

    kevindroid Well-Known Member

    try another email client such as k-9, enhanced email, maildroid. maybe you can get a different result. also do you have the latest g-mail app. hope this helps you
  9. PattiCakeUS

    PattiCakeUS Well-Known Member

    So you're having problems both with syncing and with notifications?

    I'm no expert on this but I'd check the global sound/notification settings since it sounds like they're right in your gmail account.

    If you're having sync issues too - do you have your Auto-sync turned on in your global settings?
  10. Kevin C

    Kevin C Well-Known Member

    Yes, auto-sync is on for Google, my Yahoo Mail and Weather
  11. PattiCakeUS

    PattiCakeUS Well-Known Member

    Then I'm out of ideas... I have 2 gmail accounts myself but they're not my primary account so I don't have notifications turned on for them. Hopefully someone else has more ideas for you to try.
    Kevin C likes this.
  12. PattiCakeUS

    PattiCakeUS Well-Known Member

    Hey Kevin, I've been searching the other forum threads to see if I could find anything to help you resolve your problem. I have another question - are you using the gmail app for your gmail account? I actually don't use that, I just access my gmail accounts through the regular mail app - but it looks like there are additional settings in the gmail app.

    Look on the GMail Settings screen, then tap on the account name (ex: and it opens up a hidden menu of options. Under Email Notifications, you'll find Ringtone & Vibrate, when you select that it opens up ANOTHER menu of options. There I found a setting there that says: Notify Once = Notify once for new email, not for every new message; for me it's checked and if it's checked for you, I wonder if this might be the problem?
    dustwun77 likes this.
  13. tropicalsuns

    tropicalsuns Member

    I would remove the gmail account from the original evo...
  14. Kevin C

    Kevin C Well-Known Member

    You are really going the extra mile...unfortunately I had already seen that and it is not checked.
    As I played with it more earlier, I am starting to think it might be more something to do with the Gmail server than the phone, but I will continue to monitor.
  15. PattiCakeUS

    PattiCakeUS Well-Known Member

    Hopefully you're right and it's just a server issue and it'll resolve itself. Good luck! I'll post if I find any other ideas but I'm crossing my fingers for you :)
  16. kct1975

    kct1975 Well-Known Member


    It sounds to me like a sync problem.

    I completely agree. I would suggest completely remove your Gmail account from your old EVO.
    3vodroid likes this.
  17. marctronixx

    marctronixx Moderator Moderator


    have you completely removed the gmail account and re added it? i had to do this to my htc hub account to get it to work.
  18. devgrp

    devgrp New Member

    Its not a sync problem. There is an option under gmail settings to have the notifcation only play for the first email, then it will stop if you get more email. This drove me crazy on my 3d until I found the option.
    marctronixx likes this.
  19. NeoteriX

    NeoteriX Well-Known Member

    Also may be a Priority Mail issue if you use it in GMail -- I know I can configure the phone to notify on all new mail or just Priority Mail.
  20. EarlyMon

    EarlyMon The PearlyMon Moderator

    dustwun77 and marctronixx like this.
  21. Kevin C

    Kevin C Well-Known Member

    That was not the problem. Already had that one figured out.

    It actually appears that there must be some kind of conflict created when I have both my old EVO and my new EVO on at the same time. The issue totally goes away when my old EVO is off and reappears when I have them both on. And I want to say it may only be occurring when they are both together and on Wifi here at home.
    Not a worry for me as when I am home at PC, I get the notifications on my PC anyway.
    EarlyMon likes this.
  22. jpkotor

    jpkotor Well-Known Member

    I'd like to bring this back from the dead. My Gmail's Push notifications are also not working. This is not a notification issue, it is set to notify just as I like it. On my OG Evo, when I received an email in my gmail I would see it pop up on my phone and computer pretty much at the same time. Now, I only get my new emails on my phone if I go into the Gmail app so it refreshes, or if I go to Settings> Accounts & Sync > Google and either hit "Sync Now" or uncheck and recheck "Sync Gmail" to force a sync.

    Also, I deleted an email on my phone and had to hit the Sync button in gmail a couple times to make it appear deleted in my inbox.

    Any ideas? I removed and added my Google account already with no results.

    Edit: I should add that I did not remove my google account from my old Evo although it is off with the battery out at home.
  23. Kevin C

    Kevin C Well-Known Member

    In the FWIW column...I have not removed the Gmail account from the old EVO, but now the LTE is notifying at about the same time as my PC and the old EVO is not...guess there is some sync issue with them all being on the same WIFI connection?
  24. jpkotor

    jpkotor Well-Known Member


    I'm still at my school's library studying. OG Evo still battery-less at home. On the WiFi my LTEVO doesn't get the push notifications from GMail, but as soon as I turn off Wifi the notifications get pushed. Using 3G I was getting emails at the same time as my computer then switching to WiFi and no more notifications. Then again now I'm not getting them on 3g anymore. I hate technology.
  25. usadaytrader

    usadaytrader Member

    I upgraded to the LTE from the OG4G. My new e-mail notifications are much slower than my old Evo4G phone. Gmail, yahoo mail and the default mail apps are slower than my old phone.

    My old phone would instantly notify me of an e-mail. I checked the accounts and sync and made sure it was turned on. Is there anything else I can do? It pisses me off my old phone is better than my new.

Share This Page